ZMM distributive consists of nine modules

For a quick start, create a temporary working directory ~zmm/temp/ and copy file ~zmm/test/proteins/pdb/1cbs.pdb to ~zmm/temp/

- In Windows:

· Open MVM, a Graphical User Interface for ZMM

· Click button Project

· Set directory ~zmm/temp/ and project name 1cbs

· Click button Make from PDB

· Select file 1cbs.pdb

· When button Results turns green, click it

· Click button Visualize

· Click Secondary Structure in pull-down menu Hot scripts

· Enjoy the view

- In Unix, Linux, or Windows command-line environment

· Type: zi 1cbs

· See file 1cbs.0.pdb using any molecular viewer

In this example, ZMM module zi imports structure form file 1cbs.pdb and makes system calls of modules zp, zm, zg, zs, and zv. Upon successful termination, several files occur in the working directory, including

- 1cbs.pep

- 1cbs.0.tsk

- 1cbs.0.list

Explore these files by using MVM or any text editor to get an idea of general structure of most important ZMM files

File 1cbs.zm.warn warns that two electro neutral groups have non-zero charge. Warning files inform about minor conflicts that should not affect your results.

Open ALL books in ZMM help, and have a quick look at ALL entries just to get an idea how many option are available. You do not need to know all these options to start working with ZMM. You will learn the most important options step-by-step when working with concrete projects.

Explore ZMM examples:

- Read batch files .bat in sub-directories zmm/test/. They include many examples.

- Run the batch-files. Files .dif will appear to show difference between results of the tests .list and templates files .lab. (Results that depend on processor-specific random numbers may not match exactly template files.)

- Execute commands from the batch-files one at a time and read resulting files. This will help to understand ZMM.


What is New

See ~\Test\ZMM_Controls.xls for summary of all ZMM Controls & Tests

February 2021

· Command zv molname.jobname.stacktype -rc delivers file molname.jobname.stacktype.re in which three last columns characterize the tightest contacts

May 2020

· zu -hm ... returns files model.pep and model.csv. The latter relates Uniprot residue numbers with PLIC/labels. Run Test/Utilities/0_run.bat and see file Q13936.csv

· User can specify first line in file [zmm|molname|jobname].index as follows:
#H <alias1, alias2, ...>. Aliases, which should depict ALL indexes in the file, will be delivered in the first row of file *.csv to clarify excel charts. Example: ~ZMM\Test\Proteins\safe\DEKA_500.index

· START/TAKE PDB 'molname.pdb' (TAKE MEC does not work with *.pdb files)

April 2020

· zu -pdb2csv

· zu -center

· ~ZMM\Test\safe\WAT_500.pdb

· ~ZMM\Test\safe\WAT_box.pdb

· Index ERWI Energy of Residue-explicit Waters Interactions

· REWD Default clash distance for REWC

March 2020

· Indexes DRR, DRRP, RPC

Feb 2020

· command 'zv molname.jobname.stack' -rc file delivers file 'molname.jobname.re.csv' that shows for each residue intersegment and interdomain energies and top contributors to the energies. Made to analyze state-dependent contacts

· In double-shell jobs, use key "FIXMC" to preclude main chain deviations of fixed residues, which are downstream from the flexible residues and are not specified as "m" residues in the .pep file.

· Index NVIS

November 2018

· Command "zu -plics PLIC.list O1N4 A6520 50" delivers file "PLICS_O1N4_A6520_50.csv" with distances between atoms Oi and Ni+3 in segment IS6 of all channels specified in file PLIC.list.
See ~\ZMM\Test\Utilities\0_run.bat

· TLRE - Threshold of Ligand-Receptor Energy to add a MEC in stack

July 2018

· Command "zu hm 5gjw_P.pep align" reads template file 5gjw_P.pep and alignment file align to generate homology-model file model.pep

June 2018

· Command 'zi -molname.pdb -h' preserves ligand geometry (use to test ZMM-made models)

· command 'zu -cm job.tsk' compares PLIC files

· Constraint DIPT (Dipeptide)

· Command "zl molname.mol2" imports a TRIPOS-format file with partial atom charges.

February 2018

· Constraint SGSG segment-segment

· SGSG in file *index

· MPI jobs deliver file molname.jobname.rm_to_get_PDB. Remove it to get current PDB

· TIMEJ job time limit in hours

October_2017

· zu -fasta molname.pdb generates excel-importable file molname.fst

· zi molname.pdb -olg preserves original ligand geometry. Default is using standard ZMM geometry for ligands.

September 2017. Utilities to generate PLIC-3DA. See "How to make PLIC-3DA files" for detail

· zu -toc molname.pdb generates Table of Content molname.toc_

· zu -rr molname.pdb molname.toc returns file molname_.pdb with label assigned according to molname.toc

· zu -lb molname_.pdb alignmnet.csv returns file molname_L.pdb with PLIC-3DA labels.

· zs molname_L.rb.tsk -r runs RIBOM without generating file molname.bin

· zu -pc molname.pdb molname_L.rb.pdb returns file molname_A.pdb with labels from molname.pdb and coordinates from molname_L.rb.pdb

July 2017

· Boron atom (B) is added

April 2016

· PROIN, RELPRO, FIXPRO (Manipulate prolines, useful in homology modeling)

April 2015

· AEUP, REUB, KEPDB (Alchemistry)

December 2014

· zi key ‘–ala’ makes file molname.pep with all amino acids except G and P substituted by alanine

November 2014

· zu -rr (re-labeling pdb files)

October 2014

· RRC index

August 2014

· RRD, RSD, SSD, SSDM

July 2014

· DELEL

March 2014

· SSDT

· KLEC 7 (ligand-protein short contacts)

· Default KLEC = 6

· SEG1, SEG2

January 2014

· SCWRL4

December 2013

· “KLEC 6” – All MECs in “molname.jobname.stack” have different sets of short contacts.

· ‘RMSD’ ‘CAX’

November 2013

· Command zv molname.jobname.stacktype –rc generates file
molname.jobname.stacktype .[n[-n2].]cvs
with inter-residue heavy atoms contacts shorter than SCT (Default 5 Å).
see ZMM help for zv module

· File molname.lbl can be used to deliver alternative residue labels in molname.*.*.cvs. Alternative residue labels facilitate analysis of protein families, e.g., P-loop ion channels (Zhorov & Tikhonov, 2004)
or G-protein coupled receptors. Example: ~/zmm/test/proteins/Kv12_pore.1.*

· AAX Atom to Atom in X-ray structure constraint

· AAXM AAX Multiple

· SCT Short Contacts Threshold

May 2013

· REXB, REXS

February 2013

· zu –namd molneme1 molname2

October 2012

· DTORS

September 2012

· FIXTA

· RELTA

August 2012

· SHELL_S - Hot Grid samples torsions in a Static Shell around a residue

· SHELL_D - Hot Grid samples torsions in a Dynamic Shell around a residue

May 2012

· LGSC – Ligand-Sidechain constraints

· RSLD – index <Residue Sidechain to Ligand shortest Distance>

· ILSB – Ignore ligand-sidechain bumps at the seeding stage

· LIBRARY – import library of precomputed conformers in HGRID

· IIRI – Ignore Intra-Receptor Interactions

September 2010

· Utility mgf converts a file from .mgf to .pdb format

May 2010

· Tune/Residue Settings/ REDSIN ' ___9 ' ' ___9 ' 7. 10.
Residues of the Double Shell to Include
Generates a double-shell model without making a new .pep, .sym. and .bin files

October 2009

· Force field AMBERL – AMBER Ligand. Useful to generate a library of ligand conformers (Garden & Zhorov, 2010)

June 2009

· Intersegment interactions with SEGM

· Calling zi with a key “–r” makes central residue in a chain the root

· Floating constraint PAGS is disabled in zv

· In symmetric systems, image residues can be specified

May 2009

· SDHB S olvent D ependency of H-B onds Strength.

· New Defaults: KES = 0; LIMIT 200

December 2008

· HotGrid BACKBONE, FI_PSI

· KPLRC Key to Print Ligand-Receptor Contacts

· DPLRC Distance threshold to Print Ligand-Receptor Contacts

November 2008

· MCAD

September 2008

· Index RMSD may contain range of residues to be compared

August 2008

· PINS – PIN Shifted. Randomly shifts template alpha carbon up to sqrt(3*SPIN)

· SPIN – maximal Shift of PINA template (coordinate of alpha-carbon)

June 2008

§ MSCD - M ake up protein S ide C hains by D unbrack’s program scwrl3

§ MSCR - M ake up protein S ide chains by R osetta

§ REIN – Re sidues to In clude in calculations (use after REX to focus on a cluster)

May 2008

§ Very fast rigid docking (see zmm/test/proteins/1cbs.hg.tsk)

§ Fixed residues (status “x” in .pep file) may be amino acids, nucleic acids, ligands, etc.

§ Module zu: interface for ZMM Utilities

§ Put li -gand .sym file to ./safe or ./pdb to prevent its removal after zp or zi. This is equivalent to zp -mvm or zi -mvm

§ Utility zu scd: S ide C hain conformations by D unbrack method

§ Utility zu aph: A dd P olar H ydrogens to pdb file

§ Utility zu cif: importing ligand coordinates from CIF format

April 2008

§ Indexes ELSI, ERT, NASH

§ Indexes of intraligand energy ELN, ELBA, ELTO, and ELT are delivered relative to reference energies, which are calculated for the MC-minimized free ligand

January 2008

§ Module zb – ZMM PDB Browser developed by Bojan Garic. Currently zb provides distances of disulfide bonds and generates library of side-chain conformers.

§ New parameter –r runtime for serial-farm jobs to be submitted at UNIX clusters via sqsub command

July 2007

§ PINI

June 2007

§ PAGS – Pin Alpha carbons to Grid Start

§ TAKE SCHL_ALL – Assign library rotamers to all side chains

§ TAKE SCHL_MIS – Assign library rotamers to side chains missed in PDB

May 2007

q Cutoff for ion-dipole interactions CUTOFD

q To avoid collecting complexes with bad ligand geometry, ligand-receptor energy in files LRBEST is now the sum of the ligand-receptor and intra-ligand energy components. For some ligands, the energy may be positive due to bond angles strain and close intra-ligand contacts. Listing files still show ligand-receptor energy and intra-ligand energy separately.

March 2007

q EPS4

q New Defaults: KES=4; KEE=4.

q Index ERSI

q UNPIN

February 2007

§ Environment-dependent dielectrics (key KEE has 5 positions)

§ By default, ion-dipole interactions are calculated without cutoff

January 2007

q Multiple-torsions constraints DMCT, DT

August 2006

q VESA, AISA, AESA

q KLEC 5

q Parameters NSERF, JSERF, FSERF for serial-farm jobs

q Command-line keys –il, -iw, -ii, -is for zi

July 2006

§ Flexible KMSR

§ Key MST

June 2006

q RMSD LIG in files molname.index and molname.jobname.index

q RESA in the RESUDUE SETTINGS field of .tsk file

May 2006

q Comments starting from ‘!’ or ‘#’ are allowed in any line of file .tsk

q File solvent.dat contains solvation parameters that can be edited by user

q Command-line keys for zv: -a, -c, -d, and -x

q Index-files molname.jobname.index, molname.index, and index

q Indexes RMSD instruct zv to compare MECs in a stack with a template MEC.

q Command zv molmane.jobname.stack –x returns file molmane.jobname.stack.xls for Microsoft Excel. Example: ~\test\proteins\1iol.trans_1.tsk

q Key KDSF

q Index DAR

q KLEC 4 instructs zs to merge MECs with similar conformation of the ligand in file moname.jobname.stack

q Stack controls DLTAS, DLTRS, DLEAS

q Subdirectory ./safe can be used to protect files from accidental deletion. Keep there .stack, .grid., and other precious files for future analysis by zv. Files .pdb can be stored in either ./safe/ or ./pdb/. Example: ~\test\peptides\safe

April 2006

q Key –sc in command zi generates a double-s hell model around a c hain of residues

q SCENT makes ZS to sample a side chain around specified residue at every second MCM step

q Key LIMNS is disabled

q Indexes ESHA and ESHR

q Energy value in the stack files is delivered in format f7.1. Old stack files, in which energy was delivered in format g7.1 are still valid

March 2006

q Default value for dielectric constant is D(r)=4r.

January 2006

q Parallel GREN

q Indexes ELT (Energy of Ligand Total) and ELST (Energy of Ligand’s Strain)

December 2005

q Residue to target constraints: RA, RAT, RLC, RPNC

q Parallel Hot Grid

q Parameter ETTS

November, 2005

§ Stack molname.jobname.lrbest is introduced to accumulate MECs with the best ligand-receptor energy. To support the stack, specify key LBEST in the PARAMETERS field and residue label in operator PART under RESIDUE SETTINGS field. Example: test\long\1iol.lri.tsk

§ Tunable Hot Grid allows generating random starting points in specific regions. Example: test\long\kvap_s.hot_grid.tsk

§ Parameter CNBR allows to reduce van der Waals diameters of atoms

§ KROM, FCROM, DROM – parameters to control deviation of Omega torsions

March 2005

· Parameter MSEA is introduced (default 3). When MCM or GRID samples an Euler angle of a free molecule, the latter is rotated around the geometrical center rather than the root. See example in ~zmm/test/proteins/rhz.cent_mcm.tsk

· PIVOT constraints are enabled. See example in ~zmm/test/proteins/rhz2.grid_pivot.tsk

December 2004

· Inter-residue cross-links are delivered to file .pep when module zi is called with key –c. See LYS-RET cross-link in rhodopsin ~zmm/test/proteins/1h2s. The built-in library of cross-links will be developed.

· Constraint DDCG is introduced

· New method of searching ligand libraries. See Library of ligands and keys to module zi

· New ZMM utility zu_cif converts CCDC to PDB files

· zg orients water molecules to minimize bad contacts and OH groups to bias H-bonds

· Project-related PDB files can be placed in folder pdb/ in the working directory

November, 2004

· By default, zi generates file .pep with titrable residues in the ionized form. Use key –ni to generate file .pep with non-ionized residues

· For ligands generated by zl, benzene groups are assigned standard bond lengths (1.39 A for C-C and 1.07 A for C-H)

· By default, command zi imports structure, calculates energy but does NOT optimize it. Uze key “–o” to perform short optimization

· Calling zg with key “–n”, generates “no optimization” task-file for zs.

June, 2004

· Symmetry is introduced. It can reduce essentially time of energy calculations and speed-up MCM converged for systems that have n-fold symmetry around axis z. See key KSF and test zmm/test/proteins/KcsA_symmetry

May 2004

· Parameter KMSR – Key for Multi-Step Relaxation.

· When zg generates tsk-file, atoms mismatched between the model and template are not excluded. If more than 10 such atoms are found, zg sets parameter KMSR=1 for multi-step relaxation.

· Default parameter LIMNE=1000.

· Selenomethionine is introduced (MSE, mse)

· New constraint DGEN – Deviation of GENC from starting structure

· New Tune commands RELO, FIXX, FIXY

· FIXR fixes all degrees of freedom of given residue, including root-atom degrees (if any)

March 2004

· zi automatically determines tautomeric forms of histidines to improve energy of H-bonds and N---Metal bonds. This improves starting energy (see, e.g., test/projects/2HN4.

December 2003

  • New format of *.sym file.
  • Four ZMM programs are renamed as follows:
    zp (ZMM Polymer) substitutes zgp
    zi (ZMM Import) substitutes ztbp
    zl (ZMM Ligand) substitutes zgl
    zg (ZMM Generate geometry) substitutes zgt
  • Ligand's atomic charges are computed via system call of MOPAC-6, a freeware program, which is NOT a part of ZMM.
  • A library of ligands zmm/ligands/*.sym is introduced. The user if free to customize this directory.
  • New command-line keys of program zi:
    -i, Ionizable residues are set in ionized form
    -n, No ligand generation
  • New Command-line key of program zl:
    -n, No MOPAC call and No energy optimization
  • Folder zmm/test is split to three subfolders: small molecules, peptides, and proteins

October, 2003

  • New parameter MPDB is introduced to deliver PDB file of the double-shell model arranged by increasing residue labels from both flexible and fixed shells (MPDB 1) or to deliver double-shell model incorporated in the template (MPDB 2).
  • Key KPRSE partitions system energy by residues, each residue having two components: inter (interaction with other residues) and intra-residue energy

July, 2003

  • New control parameters KDISC, ETCR, ETRC for delivering residue-residue contacts

June, 2003

  • ZMM is parallelized on GRID and GREN levels

May, 2003

  • Command HGRID (Hot Grid) instructs ZMM to assign random values to all torsions at each node of the grid. In combination with MCM (KOPT 2), HGRID effectively searches global minimum of ligands and peptides.
  • Control parameter MCM2 is introduced for two-step MCM in GRID. Allows to relax bad contacts

April, 2003

  • Program ZL calls CNDO, ZM, ZD, and inserts charges and reduced van der Waals radii in file .sym automatically
  • New Format of the ELASTIC Field in .sym files

February, 2003

  • New Control Parameters to accelerate MCM:
    ISAS, Interval to Shake Around most Strained residue
    LSAS, Length to Shake Around most Strained residue
  • Control parameter KRELS is disabled
  • New entry in the START field of *.tsk file to enable symmetry operation:
    CLONE_B - Clone backbone torsions
  • ZMM developers: files *.dat, *.htm can be in the source code directory. This does not affect ZMM users.

January, 2003

  • New Control Parameters:
    KPRSE, Key to Print Residue to System interaction Energies. 0, nil; 1, not sorted, 2 sorted by the energy

December 2002

  • New Control parameters: KHPDB, Key to print hydrogens in PDB file
  • New command zmm <filename> executes several ZMM programs as child processes. For example, the command
    zmm 1bra.pdb is equivalent to the following series of commands: zi 1bra.pdb; zp 1bra.pep; zm 1bra.sym; zg 1bra.0; zs 1bra.0.tsk

November 2002

  • DNA can be modeled. See example 1glu.* in the file zmm/test/0_home.bat

September 2002

  • Program PASS has been renovated. New control parameters (MNPD, IMDV, and JRB) and new entries in the START field (TAKE START, TAKE FINISH) have been introduced. See zmm/test/mecyh.pass.tsk
  • When zl imports a MVM-generated file that contains a connectivity matrix, bond lengths and bond angles are not included in *.sym file, and ZM generates a standard valence geometry.
  • Program RIBOM has been renovated. See test KcsA.z_ribom
  • New controls: FPIN, DPIN, LSTAT, ELIM
  • Updated controls: KPT, LIMNE, LIMIN

August 2002

  • Arbitrary location and name of the zmm_root folder. This directory must have folders exe, dat, pdb.
  • Directory zmm_root/pdb is a standard depository for pdb files used by ZMM. It is recommended to keep all pdb files in this directory.
  • A residue in *.pep file can be assigned a mobile status (m). While such residue belongs to the peptide chain, it has six additional degrees of freedom for translation and orientation. This simplifies homology modeling. It also can make MCM more efficient: sampling of the backbone torsions of residues N-terminal to the mobile residue does not affect position of the mobile residue and residues C-terminal to it. See test g_mobile
  • Program ZT (Tune). Command zt molname.jobename.tune
    generates file molname.jobename.tune. Under Windows, ZT may can be executed as a child process called by ZS. Under UNIX, ZT should be executed manually before ZS
  • Program ZV has been modified. Command zv molname.jobename.stackname [MECs] [option]
    generates files molname.jobename.stackname.pdb and/or (molname.jobename.stackname.list or molname.jobename.stackname.stat)


Popular molecular modeling programs such as AMBER and CHARMm work in the space of Cartesian coordinates of atoms

Ten reasons to try ZMM

1. ZMM is universal: you can model drugs, peptides, proteins, nucleic acid, and ligand-receptor complexes.

2. ZMM is fast. It minimizes energy in the space of generalized coordinates (Zhorov, 1981; Zhorov, 1982) and employs highly efficient method of Monte Carlo minimization (Li and Scheraga, 1987).

3. ZMM is flexible: large number of controls can tune ZMM for a specific task.

4. ZMM is user-friendly. It includes a graphic interface MVM and can also be used with any molecular graphics program, e.g. PyMol.

5. ZMM is easy to use: you can import molecular structure from a PDB file in one command or mutate a protein in one keystroke.

6. ZMM is easy to learn. It includes comprehensive description and hundreds examples.

7. ZMM integrates 30+ years of experience in molecular modeling of biomolecular systems.

8. 200+ publications on ZMM-based studies are available.

9. ZMM runs at Windows and UNIX

10. Parallel ZMM for UNIX is available.


Molecular Modeling package ZMM

ZMM searches optimal structures in the space of generalized coordinates: torsion angles, bond angles, bond lengths, positions free molecules and ions, and orientation of free molecules. Any generalized coordinate may be kept fixed. Molecules and fragments and that are not expected to undergo significant conformational changes may be treated as rigid bodies.

Popular molecular modeling programs such as AMBER and CHARMm work in the space of Cartesian coordinates of atoms. During energy minimization of a big system, many Cartesian coordinates-variables move collectively. For example, rotation of a benzene ring around the C-Ph bond in the Cartesian-coordinates space involves collective motion of 33 variables. In the generalized-coordinates space, this rotation involves variation of just one torsion angle. In ZMM, any fragment of a molecular system may be treated as either rigid or flexible. The generalized-coordinates method saves large computational resources if only a small part of a system is considered flexible. Examples are ligand-protein and protein-protein interactions. The savings occur because the sampling space is reduced and because molecular interactions within rigid fragments are not computed.

ZMM implements various methods for conformational search:

- Energy minimization in generalized coordinates (Zhorov, 1981, 1983)

- Nested rotations with building multidimensional grids

- Monte Carlo minimization (Li & Scheraga, 1987)

- Monte Carlo minimization (MCM) in the space of scaled collective variables (Noguti & Go, 1985; Maurer et al., 1999)

- Biased MCM (Abagyan & Totrov, 1994)

- Nested MCM protocol (unpublished)

- Stochastically restrainable MCM (unpublished)

- Computing MC-minimized energy profile of a ligand in a protein (Zhorov and Lin, 2000)

- Computing multidimensional MC-minimized energy map of a ligand in a protein (unpublished)

ZMM includes well-known force fields:

· AMBER (Weiner et al., 1984; Weiner et al., 1986) - Default force field

· ECEPP/2 (Nemethy-Scheraga, 1983)

· MM2 (Allinger, 1977)

· CHARMm

ZMM also includes

· AMBERL – AMBER without attractive van der Waals terms. Useful to generate a library of ligand conformers for subsequent docking to a protein

· Force field by Valerii G. Dashevskii (1970)

· Force field by Zhurkin et al. (1983)

· In the ZMM help files, items under development are colored red


ZMM was used in many molecular modeling studies, for example:

ZMM was used as the major modeling tool in 200+ studies, including:

- Protein modeling with MTSET-substituted cysteines (Bruhova & Zhorov, 2010)

- Flexible ligand docking (Garden & Zhorov, 2010)

- Docking Ca2+ ions in flexible proteins (Cheng et al., 2010)

- L-type Ca2+ channel with phenylalkylamines (Cheng et al. 2009)

- L-type Ca2+ channel with dihydropyridines (Tikhonov and Zhorov, 2009)

- Na+ channel with insecticides (Du et al., 2009)

- Polyamine toxins in ionotropic glutamate receptors (Nelson et al., 2009)

- Na+ channel with batrachotoxin (Wang et al., 2007)

- Local anesthetics: access and binding in Na+ channel (Bruhova et al., 2008)

- L-type Ca2+ channel with benzothiazepines (Tikhonov and Zhorov, 2008)

- Slow Inactivation and ligand binding in Na+ channel (Tikhonov and Zhorov, 2007)

- Correolide in Kv1.3 channel (Bruhova and Zhorov, 2007)

- d-Tubocurarine in K+ channel (Rossokhin et al., 2006)

- Mechanism of Na channel agonists (Tikhonov and Zhorov, 2005; Wang et al., 2006)

- Local anesthetics and benzocaine in Na+ channel (Tikhonov al., 2006)

- Predicting the pore geometry of the Shaker channel and mechanism of its block by Cd2+ (Bruhova and Zhorov, 2005). Predicted geometrical features of the channel agree with the later x-ray structure(Long et al., 2005)

- Mapping steroids’ binding site in an enzyme (Blanchet et al., 2005)

- Modeling selectivity filter of sodium channel (Tikhonov and Zhorov, 2005)

- Large-scale conformational transitions in a protein (Tikhonov and Zhorov, 2004)

- Noncompetitive antagonism in a nicotinic acetylcholine receptor (Tikhonov et al., 2004). This paper shows, in particular, that a protein model made with ZMM and published in 1998 predicted important features of the experimental structure published in 2003)

- Simulation of antifreeze proteins at ice (Jorov et al. 2004)

- Ligand action in voltage-gated ion channels (Zhorov and Tikhonov, 2004)

- Block of NMDA channels (Bolshakov et al., 2003)

- Agonist action in Ca2+ channels (Yamaguchi et al., 2003)

- Block of glutamate receptors (Tikhonov et al., 2002)

- L-type calcium channel with ligands (Zhorov et al., 2001)

- Structure and function of testosterone-binding enzyme (Nahoum et al., 2001)

- Modeling ligand-gated chloride channels with blockers (Zhorov & Bregestovski, 2000)

- G-protein coupled receptors with ligands (Zhorov & Ananthanarayanan, 2000)

- Structure-activity relationships of polyamine amide toxins (Tikhonov et al., 2000)

- Systematic search for the steroid-binding site in an enzyme (Zhorov and Lin., 2000)

- Modeling of ion channels of glutamate receptors (Tikhonov et al., 1999)

- Modeling of collagen (Milchevski et al., 1999)

- Nicotinic acetylcholine receptor channel with blockers (Tikhonov & Zhorov, 1998)

- Modeling of a synthetic calcium channel with ligands (Zhorov & Ananthanarayanan, 1996)

- Interpretation of ambiguous NMR spectra (Ananthanarayanan et al., 1996; Qi et al., 2000)

- Conformations of opioid peptides (Zhorov & Ananthanarayanan, 1994; 1995; 1996)

- Conformational analysis of curare alkaloids (Zhorov, 1993; Zhorov & Brovtsyna, 1993)

- Conformation-activity relationships of cholinergic drugs (Brovtsyna N.B. et al., 1980-2003)

- Cholinesterase substrates and inhibitors (Rozengart E.V. et al., 1975-2003)

- Pheromones (Tsendina et al., 1989; Bykhovskaya and Zhorov, 1996)


Terms Abbreviations, and Designations

Term/Abbreviation

Meaning

AA

Amino Acid

Constraint

A penalty function (parabolic or flat-bottom) imposing specified absolute or relative disposition of an atom or group of atoms in 3-D space.

EM

Energy Minimization

GENC

Generalized Coordinate

Eigen GENC of an atom

GENC affecting position of the atom and its up-the-tree descendants but not down-the-tree ancestors

MCM

Monte Carlo Minimization method (Li and Scheraga, 1987; 1988)

MEC

Minimum-Energy Conformer

Restraint

Constraint stochastically activated and inactivated in the Stochastically Restrainable Monte Carlo minimization protocol

Root atom

Atom in the origin of the local coordinate system of a free particle.

Root residue

A residue comprising a root atom

SCV

Scaled Collective Variables in MCM

Stack of MECs

A collection of MECs accumulated during MCM protocol or stream energy minimizations. Each MEC is represented by its energy and number of visits (number of times the MEC was found in energy minimizations). MECs in a stack are ordered by the energy increase, the lowest-energy MEC being at the top of the stack. A new MEC found in an energy minimization is considered as a candidate to the internal stack stored in RAM if its energy does not exceed the apparent global minimum by DELEQ kcal/mol. If the energy criterion is met, the geometry of the candidate MEC is compared with all MECs in the stack. The criterion of geometrical similarity of two MECs is defined by parameters KLEC and TLDS. If the candidate MEC is dissimilar from any other MEC in the stack, it is included to the stack. Otherwise, the candidate MEC and its closest match in the stack are compared by energy. If the candidate MEC is lower than the match, it replaces the match in the stack. The internal stack has a limited capacity; when overflows, it is delivered to the external stack molname.jobname.stack. During this procedure, MECs exceeding the apparent global minimum by more than DELEQ kcal/mol are removed from the external stack, and geometrically similar MECs are merged. After delivery to the external stack, the internal stack retains only the lowest-energy MEC. The internal stack is delivered to file molname.jobname.mcm after each IDEMth energy minimization and upon the job completion.

VMA

Vector Model of Atom, a set of unitary vectors (rays) drawn from the atom center towards its bonded neighbors (Zhorov, 1975; 1982). A VMA is represented by a matrix whose elements are projections of rays at the local coordinate system of the atom. Usually, first ray coincides with axis -x, and second ray lies in the first quadrant of plane xOy.

PDB

Protein Data Bank

i, j

Numbers of atoms

m, n

Numbers of residues

G

A name of Generalized coordinate, e.g. 'Fi.ALA.12'

A1, A2 ..

Atom names e.g.: ' CA .MET .123'

DL

Lower distance limit in a flat-bottom constraint, Å

DH

Higher distance limit in a flat-bottom constraint, Å

F

Force constant in constraints, kcal/mol

xn, yn, zn

Cartesian coordinates of atom N

C

Real-number Criterion do discriminate MECs by their indexes


Examples of ZMM jobs

Examples

ZMM comes with many examples that can help to learn ZMM and to clone analogous projects. For lists of the examples, click here


Size Limits of ZMM effective November, 2002 (see files *

Size Limits of ZMM (effective January, 2004)

Current version of ZMM has the following size limits, which are suitable for most applications. ZMM version with larger limits is available upon request.

Size-limiting parameter |  | Value
NAM | Number of Atoms Maximal | 100,000
NDFM | Number of Degrees of Freedom Maximal | 50,000
NRM | Number of residues maximal | 10,000
LIMGEN | Limit of Generalized coordinates in the internal stack | 400,000
LIMMEC | Limit of MECs in the internal stack | 10,000
LIMIL | Limit of Interaction List | 2,000,000
LTMM | Length of Triangle Matrix Maximal (250 x 250)a. | 31,375
NFLMM | Number of free ligands/molecules maximal | 1024
NLM | Number of Loops Maximal (L-type bonds) | 1,000
LSC | Limit of Short Contacts to display in listing file | 2,000
NESSVM | Number of ESSential Variables Maximal for SCV | 500
NHBM | Number of explicitly specified H-Bonds Maximal b | 20
NPVM | Number of Helical templates Maximal | 24
NDPM | Number of Driven Parameters Maximal in GRID | 10
NCDPM | Number of Co-Driven Parameters Maximal in GRID | 50

a If number of variables does not exceed this limit, the energy is minimized by the method of Davidon that builds the matrix. Otherwise, the energy is minimized by the conjugate-gradients method that does not need the matrix.

b Explicit H-bonds may can be specified in small molecules explored with MM2 and Dashevskii force fields, which do not have parameters for implicit H-bonds.

Build-up limits

Length of the Zimmerman code (mcm, wrimec, zma) | 30
Number of restraints (aplec, loop) | 127


Literature

Abagyan, R. and M. Totrov. 1994. Biased probability Monte Carlo conformational searches and electrostatic calculations for peptides and proteins. J. Mol. Biol. 235:983-1002.

Augspurger, J.D. and H.A. Scheraga. 1996. An efficient, differentiable hydration potential for peptides and proteins. J. Comput. Chem., 17:1549-1558.

Brooks, C. L., B. M. Pettitt, and M. Karplus. 1985. Structural and energetic effects of truncating long ranged interactions in ionic polar fluids. J. Chem. Phys. 83:5897-5908.

Bykhovskaia, M.B. and B.S. Zhorov. 1996. Atomic model of the recognition site of the American cockroach pheromone receptor. J.Chem.Ecol. 22:869-883.

Hopfinger, A.J. and R.D. Battershell. 1976.Application of SCAP to drug design. 1. Prediction of octanol-water partition coefficients using solvent-dependent conformational analyses. J.Med.Chem. 19:569-573.

Go, N. and H.A. Scheraga. 1970. Ring closure and local conformational deformations of chain molecules. Macromolecules 3:178-187.

Govyrin,V.A. and B.S. Zhorov. 1994. Ligand-receptor interactions in molecular physiology. St.Petersburg: Nauka, pp. 1-240 (in Russian)

Lazaridis, T. and M. Karplus 1999. Effective energy function for proteins in solution. Proteins. 35:133-152.

Li, Z. and H. A. Scheraga. 1987. Monte Carlo-minimization approach to the multiple-minima problem in protein folding. Proc. Natl. Acad. Sci. U. S. A. 84:6611-6615.

Milchevsky, J.V., B.S. Zhorov, N.G. Esipova, and V.G. Tumanyan. 1999. Two-H-bonded and one-H-bonded structure alternations in collagen. J. Biomol. Struct. Dyn. 16:977-988.

Momany, F. A., R. F. McGuire, A. W. Burgess, and H. A. Scheraga. 1975. Energy parameters in polypeptides. VII. Geometric parameters, partial atomic charges, nonbonded interactions, hydrogen bond interactions, and intrinsic torsional potentials of the naturally occurring amino acids. J. Phys. Chem. 79:2361-2381.

Nemethy, G., M. S. Pottle, and H. A. Scheraga. 1983. Energy parameters in polypeptides. 9. Updating of geometrical parameters, nonbonded interactions, and hydrogen bond interactions for the naturally occurring amino acids. J. Phys. Chem. 87:1883-1887.

Poltev,V.I., Milova,L.A., Zhorov,B.S., Govyrin,V.A. 1981. Simulation of conformational possibilities of DNA via calculation of nonbonded interactions of the complementary dinucleoside phosphate complexes. Biopolymers 20:1-15.

Tikhonov, D.B. and B.S. Zhorov. 1998. Kinked-helices model of the nicotinic acetylcholine receptor ion channel and its complexes with blockers. Simulation by the Monte Carlo minimization method. Biophys. J. 74:242-255.

Tikhonov, D.B., B.S. Zhorov, and L. G. Magazanik. 1999. Intersegment hydrogen bonds as possible structural determinants of the N/Q/R site in glutamate receptors. Biophys. J. 77: 1914-1926.

Qi, X.F., B.S. Zhorov, and V.S. Ananthanarayanan. 2000. CD, 1H NMR, and molecular modeling studies of the interaction of Ca2+ with substance P and Ala7-substance P in a non-polar solvent. J. Peptide Science 6:57-83.

Weiner, S.J., P.A. Kollman, D.A. Case, U.C. Singh, C. Chio, G. Alagona, S. Profeta, and P.K. Weiner. 1984. A new force field for molecular mechanical simulation of nucleic acids and proteins. J. Am. Chem. Soc. 106:765-784.

Zhorov, B.S. 1981. Vector method for calculating derivatives of energy of atom-atom interactions of complex molecules according to generalized coordinates. J. Struct. Chem. 22:4-8.

Zhorov, B.S. 1983. Vector method for calculating derivatives of the energy deformation of valence angles and torsion energy of complex molecules according to generalized coordinates. J. Struct. Chem. 23:649-655.

Zhorov BS 1993. Comparison of Lowest-Energy Conformations of Dimethylcurine and Methoxyverapamil: an Evidence of Ternary Association of Calcium Channel, Ca2+, and Calcium Entry Blockers. J.Membr.Biol. 135:119-127.

Zhorov,B.S., Ananthanarayanan,V.S. 1994. Similarity of Ca2+ bound conformations of morphine and Met-enkephalin: a computational study. FEBS Letters 354:131-134.

Zhorov, B.S. and V.S. Ananthanarayanan. 1995. Conformational analysis Ca2+-bound opioid peptides: implications for ligand-receptor recognition. J.Biomol.Struct.Dyn. 13:1-13.

Zhorov, B.S. and V.S. Ananthanarayanan. 1996a. Structural model of a synthetic Ca2+ channel with the bound Ca2+ ions and dihydropyridine ligand. Biophys.J. 70:22-37.

Zhorov, B.S. and V.S. Ananthanarayanan. 1996b. Conformational and electrostatic similarity between polyprotonated and Ca2+-bound mu-opioid peptides J.Biomol.Struct.Dyn. 14:173-184.

Zhorov, B.S. and V.S. Ananthanarayanan. 1998. Signal transduction within G-protein coupled receptors via an ion tunnel: A hypothesis. J.Biomol.Struct.Dyn. 15:631-637.

Zhorov, B.S. and V.S. Ananthanarayanan. 2000. Homology models of mu-opioid receptor with organic and inorganic cations at conserved aspartates in the second and third transmembrane domains. Arch. Biophys. Biochem. 375:31-49.

Zhorov, B.S. and P.D. Bregestovski. 2000. Chloride channels of glycine and GABA receptors with blockers: Monte Carlo minimization and structure-activity relationships. Biophys. J. 78:1786-1803.

Zhorov,B.S. and Brovtsyna,N.B. 1993. Conformational analysis of d-tubocurarine: implications for minimal dimensions of its binding site within ion channels. J.Membr.Biol. 135:19-26.

Zhorov, B.S. and Govyrin, V.A. 1984. An atomic model of beta2-adrenergic receptor active site complementary to the productive conformations of adrenomimetics. In: Conformations and functions of biological molecules. Theoretical aspects. (Eds. Chipens, G., Galaktionov, S.G., Dashevskii, V.G., and Nikiforovich, G.V.) Riga: Zinatne, p. 123-32 (in Russian).

Zhorov, B.S. and S.X. Lin. 2000. Monte Carlo-minimized energy profile of estradiol in the ligand-binding tunnel of 17-beta-hydroxysteroid dehydrogenase: atomic mechanisms of steroid recognition. Proteins 38:414-427.

Zimmerman, S.S., M.S.Pottle, G.Nemethy and H.A. Scheraga. 1977. Conformational analysis of the 20 naturally occurring amino acid residues using ECEPP. Macromolecules 10:1-9.


ZMM file system allows running different tasks (jobs) for a given molecular system

The ZMM file system allows the user to explore simultaneously many molecular systems and to perform many different tasks (jobs) for each molecular system.

The chemical structure of a molecular system is specified in files molname.pep and molname.sym that describe the system, respectively, at the level of fragments (amino acids, nucleotides, ligands, ions, water molecules) and chemical bonds.

The name of a molecular system (molname) may consist of up to 31 characters. The structural information for the digit-crunching module zs is encoded in file molname.bin generated from file molname.sym by module zm.

Starting conformation of the system and parameters that control energy calculations are specified in task-files molname.jobname.tsk where jobname is the name (up to 31 characters) of a concrete job to be performed with the system molname.

The system molname may be explored by using many different task-files. ZMM-specific information about molname is encoded in the file molname.bin that is generated by the program

A task file molname.jobmane.tsk is the command-line argument for zs module that produces files molname.jobname.filetype

A task may include energy minimization, MC-minimization, GRID building, etc. ZMM job submitted from a working directory reads input files from and delivers results to the directory.

Files with two-part names such as molname.pep, molname.sym, molname.bin, are common for all jobs to be done with the system molname. It is recommended to keep these files as well as template.pdb in the project root directory.

Any files residing in directories up to three levels towards the root are available for ZMM. In addition, directory ./safe/ are also readable by ZMM. Keeping precious files in directory ./safe/ would protect them from accidental deleting.


ZMM data files are part of ZMM distributive

ZMM data files are part of ZMM distributive. They describe geometry of standard amino acids, Force fields, Standard ligands, etc. The user is not expected to modify these files. Normally, ZMM data files reside in directory ZMM_HOME/dat. The user may put a modified copy of the file in the working directory. In this case, the original file in directory ZMM_HOME/dat is ignored.

File | Used by | Content
Amacir_s.dat | ZP | Structure of amino acids
Nucleica.dat | ZP | Structure of nucleic acids
Ligand_a_.dat | ZP | Structure of ligands
Angle_a.dat | ZM | Bond Angles, MM2
Angle_w.dat | ZM | Bond Angles, Amber
Bond_a.dat | ZM | Bond Lengths, MM2
Bond_w.dat | ZM | Bond Lengths, Amber
Con_res.dat | ZS | Optimal conformations of the amino acid residues
Controls.dat | ZS | Default controlling parameters
Mendelem.dat | ZS | Parameters of elements of the Mendeleev Periodic Table
Name_all.dat | ZM | Charges and vdW radii of atoms in amino acids in all-atom presentation
Name_noh.dat | ZM | Charges and vdW radii of atoms in amino acids without hydrogens (Rigid shell)
Name_una.dat | ZM | Charges and vdW radii of atoms in united-atom amino acids
Tors_a.dat | ZM | Torsion potentials, MM2
Tors_w.dat | ZM | Torsion potentials, Amber


Files molname

Files molname.filetype pertinent for any job with molecular system molname

Filetype | Made by | Used by | Content
bin | zm | zs, zg | Binary Model of the molecular system
car | InsightII | zg | Structure in InsightII format (MCI inc., USA)
csd | CSD | zl | Ligand structure in Cambridge Structural Database (CSD) format
index | User | zv | Indexes to be delivered upon termination of any job with given molname
mod | zd | User | Binary model for ZMM debugging
pdb | PDB | ZMM | Coordinate of atoms deposited in the Protein Databank.
pdn | zu | USER | PDB file with renumbered residues
pep | User; zi | zp | Protein sequence
sym | User zl, zg | zm | Specification of conformation-independent Molecular Structure
lbl | User | zm | Table to assign residues new labels, e.g. labels universal for P-loop channels
zl.warn | zl | USER | Warning information
zm.warn | zm | User | Warning information
Files indicating a ZMM failure
arc | MOPAC | zl |  |
ba | zm | User |  | bond angles read before zm failure.
mop | zv | MOPAC |  |
genc | zg | zg |  | Generalize coordinates
mno | MOPAC | zl |  |
symr | zm | User |  | Part of molname.sym read before the fail
zm.fail | zm |  |  |


Files molname

Files molname.jobname.filetype specific for a concrete job

Filetype | Made by | Used by | Content
ask | User | zs | User may create ask-file to examine or terminate a job
fail | zs | User | Describes a fatal error
hist | zs | Usera | History of energy decrease during the MCM search
stat | zv | User | Statistics from files .stack, .mcm, .grid, .movie, .conv
list | zs, zv | User, zs | Listing of ZS. May contain one or many models.
index | User | zv | Input data with indexes to be delivered by zv
current.pdb | zs | MVM | Current pdb file
ndo | zs | MOPAC | Input data for computing atomic charges
tsk | zg, User | zt | Setting task, start point, control parameters, constraints, etc.
tune | zt | zs | Machine-readable derivative of tsk-file
tsk.read | zs | User | A copy of file molname.jobname.tsk read before the fail
zg.warn | zg | User | Warning information
zs.warn | zm | User | Warning information

a The file is updated upon each decrease of energy in the MCM trajectory. To read the file, rename it or move to another directory. Reading the file when zs is active may halt the process.


Atomic-coordinates files molname

Atomic-coordinates files molname.jobname.filetype

filetype | Made by | Content
pdb | zs | Best MEC found in the job (delivered if KVGM > 0 and KLEC > 0)
conv.pdb | zv | MECs of historical energy minimizations
grid.pdb | zv | Apparent global MECs found in each node of the GRID
mcm.pdb | zv | Internal stack of MECs delivered during MCM. Used to restart interrupted search.
stack.pdb | zv | External stack of MECs delivered in the MCM search

Any molecular graphics program, including MVM, RASMOL, WebLab may be used to visualize these files.


ZMM-generated job-specific files with generalized coordinates molname

ZMM-generated job-specific files with generalized coordinates molname.jobname.filetype are used to generate files *.pdb, *.list, *.stat, to restart a job. New jobs may use MECs from the GENC files as starting points. Each genc-file contains n records. Each record shows the energy of the structure, the record number, the reason of termination of the energy optimization, and the list of generalized coordinates.

Filetype | Content
conv | MECs of historical energy minimizations in MCM
grid | Apparent global MECs found in each node of the GRID or at each starting point in stream calculations.
mcm | Internal stack of MECs periodically delivered during MCM search. This file contains GENC and data to restart interrupted search.
stack | Stack of MECs found in the job. May contain one or many MECs. During the MCM search, this file contains external stack of MECs
lrbest | Stack of MECs with the BEST Ligand-Receptor energy. Contains structures with the lowest ligand-receptor energies found during MCM search. The ligand should be specified under operator PART
genc | Command zg molname input.pdb transfers file input.pdb (that may include multiple models) to GENC whose format is specified in molname.bin. Useful to save results when updating elasticity of the model.
stream | A user may use previously generated stack-file to recalculate structures with different parameters. The results of such jobs are delivered to file molname.jobname.stream (see zmm/test/peptides/ala.take_stack.tsk


ZMM ask-file molname

Every job produces an empty file “molname.jobname.kill-to-stop”. Simply delete this file if you want to stop the job and deliver all intermediate files that are necessary to restart the job at a later time.


Working files molname

Working files molname.jobname.filetype removed upon successful completion of ZS.

Filetype | Made by | Used by | Content
Rgrid | ZS | ZS | Working file to restart GRID after interruption
Str | ZS | ZS | Starting points for multiple energy minimizations


ZMM distributive consists of nine modules

ZMM consists of nine executable modules. The major module, zs, performs digit-crunching energy calculations. Other modules create input files for zs and analyze results produced by zs.


ZI: ZMM Import

Module zi (ZMM Import)

- imports file molname.pdb

- generates file molname.pep that describes polymer sequence and ligands.

- Calls modules zl, zm, zg, and zs, which generate multiple files for further jobs.

- Can import files molname.pep and molname.sym

If the .pdb file contains multiple models, e.g., NMR structures, only the first model is imported.

Synopsis:

zi molname.pdb [-u] [-n] [-h] [-ni] [-nc] [-o] [-lib] [-il] [-iw] [-ii] [-ira] [-is] [-nl] [-lcl] [-mvm] [-olg] [-w] [-r] [|-s|-s2|-sc|-ala| <residue label > [<residue label>] <flexible-shell radius> <rigid-shell radius>]

zi molname.pep [-n] [-o]

zi molname.sym [-o]

=================

Command-line keys:

-ala, make file molname.pep with all amino acids, except G, A and P, substituted by ALA. Introduced to explore potential ligand-binding pockets in tight interfaces (DDT in Nav).

-h, keep ligand H ydrogens

-ii, Ignore Ions

-il, Ignore Ligands

-ira, Ignore Redundant Atoms. Useful to create PLIC entries of homo-tetrameric channels like KcsA when pdb file contains four copies of ions and/or waters

-is, Ignore Small factors (ligands, waters, ions)

-iw, Ignore Waters

-lib, replace ligands extracted from file molname.pdb with matching ligands in ZMM LIBraries (if any). Usually, ligands in ZMM libraries are better tested than those extracted from .pdb file. This key may also save time on bypassing MOPAC calls when large standard ligands (like NADP) are extracted.

-lcl, take Ligand from Component Library (file ~ZMM\databases\Chem_Comp_Dic\components.txt)

-mvm, instructs zi NOT to remove .sym and .pdb files for extracted ligands. The key may be used to analyze ligands in MVM

-n, No system calls (zi generates file .pep, delivers .pdb files for ligands found in the input files, and .sym files for ligands found in ZMM libraries)

-nc, do Not calculate MOPAC Charges for ligands

-ni, No Ionized residues. Titrable residues E, D, K, and R are treated in the neutral form. Histidine residues HIS and HIE are always generated in the neutral form. The user can edit file .pep manually to assign charged histidine HIP

-nl, do Not make cross-Links. Cross-links are links between non-consecutive residues, e.g. link between Lys and retinal in rhodopsin

-o, Optimize geometry of the protein for limited number of cycles

-olg, Original Ligand Geometry. In many PDB files ligand geometry is poor. Therefore, by default, ligand bond length and angles are calculated with the standard ZMM geometry. Key "-olg" may be used to preserve the original geometry of ligands.

-r, Root is the central residue of a chain (default root is the first residue of the chain)

-s, make a double Shell model of a protein around a residue, which may be a ligand (Zhorov & Lin, 2000).

-u, United-atom model is produced (lower-case residue names)

-w ignore Warnings

Example: command zmm/test/proteins/0.bat [zi 1iol.pdb -s 400 5. 10.] generates file 1iol.pep, which specifies a double-shell model around steroidal ligand (residue 400). The flexible shell includes residues that have at least one atom within 5 Å from the ligand. The rigid shell includes residues that have at least one atom within 10 Å from the ligand 400 and do not belong to the flexible shell.

-s2, make a double shell model around 2 residues (e.g., substrate and cofactor).

Example: command ~/zmm/test/proteins/0.bat [zi 1afs.pdb -u -s2 A_320 A_321 6. 10.] generates file molname.pep that specifies a united-atom shell of flexible residues around testosterone and NADP cofactor. The flexible shell include residues that have at least one atom within 6 Å from ligands A_320, A_321. The rigid shell includes residues that have at least one atom within 10 Å from these ligands and do not belong to the flexible shell.

-sc, make a double shell model around a chain of residues.

Example: ~/zmm/test/proteins/0.bat [zi kcsa_denis -w -u -o -sc E___1 E___3 9. 12.] specifies double-shell around three K+ ions of KcsA.

=============================

In some cases, ZMM cannot generate a ligand from the PDB file because of several reasons:

- Not all atoms of the ligand are specified in the PDB file

- The ligand has an atom for which force-field parameters are not known

- The ligand has a functional group not yet specified in the ZMM library

In such cases, the ligand is excluded from the model by assigning its status in the *.pep file as “-“. Reasons of failure are shown in *fail files in the working directory. If the failed ligand is a solvent component, the model still can be explored. For example, file 9nse.pdb has cacodylic acid without two oxygen atoms. ZMM cannot generate this ligand, but its removal would not affect the major results.


ZI: ZMM Import

Module zp (prepare structure) reads file molname.pep that describes molecular system on the level of residues and generates file molname.sym that describes the system at the level of chemical bonds.

Synopsis:

zp molname [-mvm]

Command-line keys:

-mvm This key instructs zp NOT to remove .sym and .pdb files for extracted ligands.

If zp fails, file molname.symr is delivered with the fail reason at the file end.

Module zp may be called as a child process by module zi.

If file molname.pep is modified by the user, the command

zp molname.pep

must be executed to update file molname.sym.


ZM

Module zm (make) reads molecular structure in file molname.sym and creates file molname.bin that encodes all structural information necessary for energy calculations.

Once molname.bin file is generated, it can be used by any job that is set to explore or simulate properties of molname.

File molname.bin in the given folder is seen by ZMM in subfolders up to three levels up.

If zm fails, the reason of the fail can be found in the tail of file molname.zm.fail.


ZI: ZMM Import

Display bin-file

This module is used by ZMM developers to analyze file molname.bin.


ZS: Search optimal conformations

Module zs (search) is the major ZMM program.

Command

zs molname.jobname.tsk [-sf | -r ]

performs one of the following tasks:

- Minimizing or Monte Carlo Minimizing energy from a set of starting points

- Computing multidimensional GRID

- Searching lowest-energy pass between two conformations (PASS)

- Rigid-body movement to minimize constraints (RIBOM))

- Compare analytical and finite difference derivatives (ANFID). This function is for ZMM developers.

Key –sf can be used to integrate results of serial-farm jobs as follows:

zs molname.jobname_last.tsk -sf
where _last is the last serial-job index

Key -r allows to run RIBOM without *.bin file (made for PLIC-3DA)

zs KcsA_L.rb.tsk -r " in ~Test\Proteins


ZV: ZMM Visualize results

Module zv delivers data from zs-generated stack files

Synopsis

zv molname.jobname.stacktype [m [n]] [p[n] | t | rc | rca | s | c | a | x | m | d[r] | sc | i | gl ]
stacktype = |stack|grid|conv|pass|mcm|stream|genc|lrbest|
m and m (n >m) are sequential numbers of MECs in file .stacktype to be delivered or processed.
Default values: m = 1, n = ns, where ns is number of MECs in slack-file *.stacktype

zv delivers file(s) molname.jobname.stacktype.filetype according to the following command-line keys:

Key | filetype | Content
 | list, pdb | Listing and PDB coordinates of MEC 1
m | m.list, m.pdb | Listing and pdb coordinates of MEC n
p[N] | pdb | Deliver P DB Coordinates for each Nth record in grid/stack/stream file (N<10)
t |  | Deliver PDB coordinates of only those atoms that are present in the template

rc

rc.csv
R esidue C ontacts

Atom-atom contacts sorted by distance. Columns:

A-F, Atoms in contacts; G, Distance;
H (Cnt 1), Type of atom-atom contact:
HB, bond; S, Sidechain; B, Backbone; Knb_Hl, Knob-into-Hole;
Bchl1 or BcHl2, heteroatom 1 or 2 is a bachelor (no H-bonds)
I (Cnt 2) Type of residue-residues contact:
Ch-Ch, Chain- chain
Sg-Sg, Intersegment (if file molname.jobname.lbl is specified)
J-K (E Res 1, E Res 2) Interaction energy of residues with the system
L (E R1-R2), Inter-residue energy
M (E total), MEC Energy
N (CACB ang), Angle between CA-CB vectors of the residues
O-P (Expo 1, Expo 2), Solvent Exposure of atoms 1 (Garden & Zhorov, 2010)
Q-R (Label 1z, Label 2z) Alternative labels of Residues (with molname.jobname.lbl)
S-V (Index, MEC, Visits, #SC), Index; MEC # in stack; MEC Visits #,
# of Short contacts between the residues

 If n and m are specified, for each next MEC a contact is delivered that is either absent in the previous MECs or at least 0.2 Å shorter than the matching contact in the previous MECs.

Only very short sidechain-backbone contacts (<3.5 Å ) are delivered between small atoms (Large atoms are S, F, Cl, Br, and I).

The total number of contacts in all the MECS is limited (4000). To reduce the number of contacts, reduce parameter SCT (default is 5 Å).

For symmetric models, inner- and intra-subunit contacts are delivered only for subunit A (e.g., contacts A-A, A-D and A-B for KcsA). Other intra- and inter-subunit contacts are symmetric.

re.csv
R esidue E nergies

R esidue e nergy & top contacts. Columns:

A-C, Residue and its energy
D-H, Top intersegment contact, its energy and minimal distance

I-M, Top interdomain contact, its energy and minimal distance

N, Screen - Excluded volume by all contacts
O-Q, Top contact by excluded volume (the larger Q, the tighter contact)
Example: ~\Test\Proteins\KcsA_Denis.0.stack.rc.scv, *re.csv

rca

rc.csv

R esidue c ontacts a ll. Same as “rc”, but all contacts for all MECs are delivered

s

Stat

S tatistics: minimal, maximal, and average values of indexes over all the MECs. The indexes should be specified in at least one of the following files

zmm.index ! general indexes
molname.index ! indexes specific for system molname
molname.jobname.index ! job-specific indexes in index file
molname.jobname.tsk ! job-specific indexes in tsk file

For each index, a criterion c can be specified. If MEC n2 from molname.jobname.stacktype matches criterion c for at least one index, this MEC appears in molname.jobname.stacktype.stat

x

stat, ind.cvs

Same as -s, but file .xls with indexes in MS E x cel format are delivered

m

n.a.

Show movie (works with MVM)

c

Stat

Same as -s, but to appear in molname.jobname.stacktype.stat, MEC n2 should match all c riteria c specified for indexes.

sc

Pdb

Deliver a multi-chain protein as a s ingle-c hain .pdb file

d [r]

Stat

Same as –s, but generalized coordinates that d isperse between individual structures in the stacktype more than r (radian or Å) appear in .stat file. This helps detect most dispersed generalized coordinates. Default r = 0.1. To reduce the output, specify r > 0.1

gl

pdb

Deliver G enuine L abels instead of ZMM labels in case file molname.lbl is specified
Example: ~\Test\Proteins\safe\Kv12_pore.lbl
~\Test\Proteins\Kv12_pore.1.stack.pdb

By tuning index-files and resubmitting zv, the user can filter-out MECs matching specific criteria or set of criteria. This is useful, when file .stacktype contains thousands MECs (e.g., accumulated during HOT GRID job). To deliver files .pdb and .list for structure n2 (filtered-out in file molname.jobname.stacktype.stat) type: zv molname.jobname.stacktype n2


ZL: ZMM Ligand

Module zl (ZMM Ligand) generates file ligandname.sym from input files with Cartesian coordinates: ligandname.pdb or ligandname.car.

zl can be evoked by module zi or by the user. When .pdb file does not contain hydrogens, zl attaches them to heavy atoms by using a built-in library of standard chemical groups. Some groups are recognized by bond lengths and bond angles. These characteristics are poorly defined for many ligands. This may result in incorrect recognition of the chemical group and hence incorrect protonation of heavy atoms. ALWAYS double-check structure of the ligand generated by zl. If necessary, correct the ligands by using MVM. When zl fails to recognize a functional group, edit the ligand by MVM to specify hydrogens explicitly. Please also E-mail this ligand to ZMM developers.

Synopsis: zl ligandname.filetype [|-ng|-nc|-n|-r|-s|-1|-h|-b|-aa|-t templatename].

filetype = | pdb | mol2| cif | csd | car | (default filetype=pdb)

Keys:

-ng, n o g eometry optimization

-nc, n o c harges calculation

-n, n o geometry optimization and charges calculation

-r, r ename atoms (assign ZMM atom names)

-h, keep hydrogens. Normally, hydrogen positions in PDB files are unreliable and therefore they are automatically removed. However, user may keep the positions of hydrogens with this key.

-s, assign s tandard ZMM bond lengths and bond angles. This is a choice when PDB geometry is poor.

-1, atom 1 of PDB file serves as a root atom. Default root is a central atom

-b, in aromatic rings, use bond types "B" (variable torsion) rather than "C" (constant torsion) if large deformations of aromatic rings are expected (e.g., in polycyclic molecules)

-aa, treat a new ligand as an amino acid (N is a root atom; hydrogens are kept)

-t, templatename will appear in .sym file. Coordinates of the ligand will match those in templatename.pdb

Coordinate files for ligands can be exported from a PDB file molname.pdb by command

zi molname.pdb –n

File ligandname.pdb can also be generated by programs such as MVM. MOE, and ChemDraw.

Command zl ligandname.pdb imports file ligandname.pdb and runs a short MCM trajectory to optimize the geometry of the ligand without electrostatics. Results are delivered to ligandname.mop, the input file for public-domain quantum chemistry program MOPAC. The latter can be downloaded from ftp://ftp.ccl.net/pub/chemistry/software/MS-WIN95-NT/mopac6/index.html. Command zl also generates file ligandname.mod with reduced van der Waals radii of atomic groups, which are used to calculate the hydration energy by the method of Augspurger and Scheraga (1996). The MOPAC atomic charges and reduced van der Waals radii are imported to the final version of file ligandname.sym. If you expect the often usage of the ligand, you may put the ligandname.sym file in the ligand directory ZMM/ligands.

Command zl ligandname.mol2 used TRIPOS-format files that contain atomic charges. The charges are imported to ZMM and MOPAC is not executed. files .mol2 may be generated by MOE.
Caution: MOE at Windows generates UNIX file molaname.mol2. Use u2d to convert it to Windows format.

Ho to modify protein-bound ligand in MVM

  1. Generate original ligand-protein complex
  2. Modify ligand using Ligand menu
  3. Select the ligand: left double-clicking any atom in it
  4. Click Ligand/Standard geometry
  5. Save the resulting structure as PDB file.
  6. Use this PDB file as template for new project.

How to use ChemDraw/Chem3D to generate molecular structure.

  1. Activate ChemDraw and draw the chemical structure of the ligand.
  2. Save the chemical structure in the working directory as file ligandname.chm.
  3. Activate Chem3D and import file ligandname.chm.
  4. Minimize energy using MM2.
  5. Upon the job termination, save structure as file ligandname.pdb.
  6. Analyze atom names in file ligandname.pdb. You may want to rename some or all atoms.
  7. Type "zl ligandname.pdb". File ligandname.sym will be generated.


ZT: ZMM Tune

Module zt (tune) converts user-readable file molname.jobname.tsk to machine-readable file molname.jobname.tune.

If file molname.jobname.tsk is correct, zt produces file molname.jobname.tune. Otherwise file molname.jobname.tune.fail is delivered.

Normally, command zs molname.jobname.tsk calls zt as a child process and the user does not need to run zt.

The user is advised to run zt molname.jobname.tsk before submitting large background job at UNIX. If the tsk-file is correct, zt delivers file molname.jobname.tune. In this case, subsequent command zs molname.jobname.tsk does not call zt but reads file molname.jobname.tune.

Upon successful termination of zs, file molname.jobname.tune is deleted.

Serial-farm jobs at UNIX

Module zt can be used to submit multiple jobs at serial-farm clusters as follows.

Command

zt molname.jobname.tsk –sf [ –r runtime]

submits NSERF serial jobs to the serial queue. Upon successful completion, resulting .grid, .stack, and .lrbest files are merged automatically.

Parameter runtime specifies expected runtime for single processor in format of program sqsub:

15 (15 minutes)

15m (15 minutes)

.25h (15 minutes)

2.5h (two hours 30 minutes)

3.5d (three days 12 hours)

Command

zt molname.jobname.tsk –sf –nm –r -runtime

submits NSERF serial jobs to the serial queue. Resulting files are left in the working directory for subsequent merging by the user. This can be done by command

zs molname.jobname_last.tsk -sf

where _last is the last serial-job index, and key –sf instructs zs to integrate serial-farm results.

Serial-farm jobs at multi-processor Windows

You can use command

zt molname.jobname.tsk -sf -nm –n

To deliver multiple .tsk files, which can be run later at multi-processor Windows computer.


ZG: Geometry importing

Module zg generates file molname.jobname.tsk with generalized coordinates specifying starting Geometry. The generalized coordinates are converted from the Cartesian coordinates. The latter can be taken from one of three files:

1) template.pdb, a PDB file specified under “PDB GEOMETRY” in molname.pep. For example, if molname = KcsA_mutant, and template=KcsA, file KcsA.pdb is used to build homology model of KcsA_mutant

2) molname.pdb, a file used to generate molname.pep. In most applications, molname=template.

3) pattern.pdb, a file used to import geometry of residues whose labels are identical in molname.pdb and pattern.pdb. For example, if pattern = KcsA, and molname = LCC, structure of K+ channel KcsA.pdb is used to build a homology model of a Ca2+ channel LCC.

Synopsis:

zg <molname.jobname> [pattern.pdb] [-n]

Key –n instructs zg to produce tsk-file with “KOPT 0” (No energy minimization)

Depending of the command-line arguments, the output files are generated as shown below:

Command | Template is specified in molname.sym | Template used to generate the output file
zg molname.jobname pattern.pdb | Does not matter | Pattern.pdb
zg molname.jobname | Yes | Template.pdb
zg molname.jobname | No | molname.pdb

zg may be used to pick up results of manual docking by programs such as MVM or RASMOL saved in file pattern.pdb.

When jobname is omitted in the command line:

zg <molname> <pattern.pdb

zg converts Cartesian coordinates specified in pattern.pdb to generalized coordinates and deliver them as molname.genc


ZMM_utilities

Synopsis: zu -hm template.pep alignment

See "Make Homology Model.htm"


ZMM_utilities

PLIC Statistics (November 2018)

Synopsis: zu -plics PLIC.list pattern segment [length]

Pattern: O1N4 | O1N5 | O1N6

Examples of segment: A6520 | A6501 | A55

Length: 10 - 99 (default=99)

File "PLIC.list" was generated by DOS command dir /b /s /n *_P.pdb > PLIC.list (see D:\z\PDB\PLIC\ get_PLIC_list.bat). The user can delete from "PLIC.list" entries that are not intended for the analysis. Instead of "PLIC.list" any name can be used.

Example: in command zu -plics PLIC.list O1N4 A6520 50

Pattern "O1N4" instructs ZMM to calculate distances between backbone oxygens in positions i and backbone nitrogens in positions i+3, which can from H-bond 1,3. "O1N5" or "O1N6" can be used to check possible H-bonds 1,4 and 1,5, respectively.

Address "A6520" and length "50" instruct ZMM to analyze 50 residues in IS6, starting from residue A6520 (residue labels A6.520 - A6.570).

The above command returns two files: "PLIC_O1N4_A6520_50.csv" and " PLIC_O1N4_A6520_50_.csv " with distances between backbone atoms Oi and Ni+3 in segment 1S6 in all .pdb files specified in "PLIC.list" (see "ZMM\Test\Utilities\safe\PLIC.list").

Any part of the transmembrane segment or loop following this segment can be specified by:

- repeat: A,B,C or D stand for repeat I, II, III or IV

- transmembrane segment: 1 - 6 stand for S1 - S6)
- position of first residue in the segment to analyze

- segment length to analyze (default = 99)

Alternative "address" formats: "A6520" or A65, instruct ZMM to analyze up to 99 residues in segments S6, repeat 1 starting, respectively, from residues A6.520 or A6.501).

==========================================================

Other options of command "zu -plics" are under development

Old version (commands to be incorporated)

Command ' zu -plics molname.tsk' reads all PLIC-3DA files *_P.pdb in the given folder and all subfolders and returns file molname.csv with geometrical characteristics specified in file molname.tsk.

Example: ~ \Test\Utilities\safe\PLICS_test.tsk
==========================
# Z-coordinate
Z CA_*5850

# Distance between atom and Z-axis
D_AZ CB_*6569

# Atom-atom distances
DIST CB_A6556 CB_D6565
DIST CB_B6556 CB_A6565
DIST CB_C6556 CB_B6565
DIST CB_D6556 CB_C6565

# Angle between axis Z and vector CA-CB
#ANG_Z CA_A6569 CB_A6569
===============================

To get characteristics of all PLIC-1 files, submit command ~/PLIC-1/job.tsk from folder
PLIC-1


ZMM_utilities

zu -ext

Description (Also See "How to Make PLIC-3DA files" and "Update_PLIC_3DA")

1. Automatic mode

fst

Synopsis: zu -fst [channel_name] molname.pdb

If (channel_name in ~\PDB\PLIC\PLIC.csv) is provided) then
zu creates a PLIC entry, including files molname_A.pdb, molname_P.pdb,
folders MCM/safe, MCM/0, MCM/1, and folder M/
with the files molname$, where $
.cls - sequences of channel_name and molname.pdb
 .fst - sequence of molname.pdb with PLIC labels
.toc - T able of Content in molname.pdb
_rb.pdb - 3D aligned molname.pdb
_rb.hist - history of 3D alignment (large energy may indicate wrong
alignment of P1-helices)
_rb.list - distances between matching atoms in channel_name
and molname.pdb(large energy may indicate wrong
alignment of P1-helices)
Example: "zu -fst KcsA_Long 3F7Y.pdb"
in ~ \PLIC\KcsA\Opening\17\ creates all the PLIC files
else
 zu generates user-editable file molname.fst with the protein sequence in the
FASTA format , PDB residue chain labels and numbers, and space to add
PLIC-3DA labels at segment N-ends.
Example: compare original and user-edited files 4dxt.fst _, 4dxt.fst,
4dxt.toc _ and 4dxt.toc in PLIC-3DA\Two-pore\Ligand\Prozac\M\
end if

2. Manual mode

toc

Synopsis: zu -toc molname.pdb
Generates user-editable file molname.toc - Table of Content in molname.pdb.
The first field contains two columns of identical PDB labels of all block in molname.pdb. If user-edited molname.fst is available, the second field is delivered with PDB and PLIC residue labels at the N-ends of segments. The user should merge the two fields, edit the second column and then call zu -rr.

rr

Synopsis: zu -rr molname.pdb molname.toc
Re-label Residues according to molname.toc and returns file molname_.pdb

3D-align

1. Make file molname_.rb.tsk (see e.g. ~PLIC\Cav\Cav3.1\Apo\M\6kzo_.rb.tsk)
2. zs molname_.rb.tsk -r

Generate ZMM files

1. Rename molname_.rb.pdb -> molname_P.pdb
2. zi molname_P.pdb

pc

Synopsis: zu -pc molname.pdb molname_P. pdb
Generates file molname_A.pdb oriented as molname_P. pdb but with labels from molname.pdb

lb

Synopsis: zu -lb molname.pdb molname.csv
L a b el residues according to original file molname.pdb and alignment file molname.csv. The latter file should be manually created by saving file PLIC-3DA.xlsc as molname.csv and removing everything but the first row and the molname sequence. See "Make PLIC-3DA files" for details
The utility assigns PLIC labels to homotetrameric channels like KcsA.
Example: ~ZMM\Test\Utilities\ "zu -lb 1bl8.pdb KcsA.csv" generates file 1bl8_.pdb with PLIC-3DA labels
Caution:
1. Microsoft Excel saves filename.xslx as filename.scv with empty tail rows (multiple commas). Remove these.
2. Ensure that name in column 1 is less than 6 characters

cm

Compare template PLIC file with one or more query PLIC files.

Created to explore how indels affect deviations of matching atoms in 3D-aligned files (Tikhonov & Zhorov. Channels. 2017, 11:660-672; Front Pharmacol. 2018 9:880)

Synopsis: zu -cm jobname.tsk
Example: ~\Test\Utilities\PLIC_cm.tsk

Command "zu -cm PLIC_cm.tsk" generates *.csv file[s] with the following characteristics for residues whose labels match in the template and query.

Template | Template residue label
pdb code | Template Residue type
Query | Query residue label
pdb code | Query Residue type
d CA-CA | Distance between CA atoms in the template and query
Dd CA-z | Deferential distance of CA atoms to the z axis
Dz | Deferential z-coordinate
Av CA-CB | Angle between vectors CA->CB

INDEL commands increase or decrease residue numbers in the query file. They work only within the specified segment (helix or loop).

In the output file ~/Test\Utilities\5klg_P.csv, query file residues are shown only if they mismatch with the template residues.


ZMM_utilities

Get protein Side Chain conformations with Dunbrack method

The utility uses program SQWRL3 (Canutescu et al. A graph-theory algorithm for rapid protein side-chain prediction. Proteins. 2009. 77: 778-95) http://www.ncbi.nlm.nih.gov/pmc/articles/PMC2885146/

Useful for building a starting geometry of a homology model.

Synopsis: zu -scd molname.pdb molname_d.pdb [-unr]

molbane.pdb - coordinates of the initial structure
molbane_d.pdb - coordinates with reassigned sidechains
unr – reassign only unresolved sidechains (residues with only backbone [and Cβ] atoms in molbane.pdb)

File molbane_d.pdb retains ligands, ions, waters, REMARKS, and other non-“ATOM” lines from file hm0.pdb

Warnings

Command "zu -scd" calls program SCWRL3.0, which is a subject of a license agreement and therefore is NOT distributed with ZMM.

SCWRL3.0 considers only proteins and can assign incorrect side chain conformations at the ligand binding site. These can be optimized in the presence of the ligand using ZMM.

A new version, SCWRL4.0, is free for academic users.
It can be obtained at http://dunbrack.fccc.edu/scwrl4/


ZMM_utilities

Other ZMM Utilities
Synopsis: zu [-]<utility_name> <filename 1> [filenames...] [options]

Utility name

Description

aph

A dd Polar Hydrogens to protein. This utility can be used, e.g., to generate rigid-protein model for subsequent docking of ligands.

Synopsis: zu aph source.pdb dest.pdb [-ni]

This command calls “zi source –u –is [-ni]”, which generates file source.0.pdb of the united-atom model without small factors (waters, etc.). Then filer dest.pdb is formed. It includes all the lines from source.pdb plus polar hydrogens from source.0.pdb.

ni – ni, no ionized residues. Titrable residues E, D, K, and R are treated in the neutral form. Histidine residues HIS and HIE are always generated in the neutral form.

To manually edit protonation states of titrable residues and other features of the rigid-protein model:

1. Call zi source.pdb –u –is [-ni]
2. Edit file source.pep
 3. Call zu -aph source.pep dest.pdb

Example: ~ Test\Utilities\0.bat

center

Synopsis: zu -center molname.pdb
Translates the system so that its geometrical center occurs in point [0,0,0]

pdb2csv

Synopsis: zu -pdb2csv source.pdb
Returns sequence in csv format (requested by VSK April, 2020)

cif

Converting ligand coordinate file from CIF format (Cambridge Crystallographic Data Center) to PDB format.

Synopsis: zu -cif ligand.cif ligand.pdb

This command imports coordinates from file ligand.cif and creates file ligand.pdb with coordinates in PDB format.

Warning: Some .cif files contain buffer atoms, which are NOT linked to the ligand. You can remove these atoms manually from ligand.cif or ligand.pdb.

Example: ~\zmm\Test\Utilities\
zu –cif TUBOBM.cif TUBOBM.pdb

Compare the ZMM-generated generated file TUBOBM.pdb with the template TUBO.pdb. Note masked lines in the template file.

Warning: zu –cif needs comprehensive testing with many .cif files
You can use OpenBabel
 http://openbabel.org/wiki/Main_Page

mgf

Converting coordinates from .mgf to .pdb format
Synopsis: zu -mgf molname.mgf molname.pdb

namd

Converting coordinates from NAMD to standard PDB
Synopsis: zu -namd molname1 molname2

Utilities under reconstruction

ble

Makes Bottom-Line Energy profile from two profiles. Command zubl molname.g1 molname.g2 molname.g3 produces grid-file molname.g3 in which a MEC represents the lower MEC found in analogous positions of the same-size grid-files molname.g1 molname.g2. Command zu –bl allowed to get a smooth MC-minimized energy profile from several ragged profiles of estradiol rotating in 17-beta HSD

igf

I nverts Grid File. Command zu -igf molname.g1 molname.g2 produces grid-file molname.g2 with MECs 1, 2, …n taken from MECs n, n-1, …1 in file molname.g1. Command zu –ig was used to get bottom-line profile using MC-minimized profile of estradiol rotating clockwise and counterclockwise in 17-beta HSD

gls

Gl ue two Stacks. Command zu –gl molname.g1 molname.g2 molname.g3 makes stack molname.g3 in which non-identical MECs from molname.g1 and molname.g2 are ordered by energy increase


Examples of ZMM jobs

Examples

Examples in directory zmm/test/ can help to learn ZMM and clone analogous projects.

- Run file 0.bat in each sub-directory and analyze input, output, and intermediate files
- Files .dif show difference of files produced by ZMM and template files *.lab with expected results.
Some differences in these files may be due to peculiarities of operational systems, random-number generators, etc.
- Read file 0.bat to see how ZMM modules are called
- Run file 0_clean.bat to remove the output and intermediate files

Short descriptions of examples are given below

Small Molecules
Peptides
Proteins
Ligands
MacProjects
Nucleic_Acids

Small Molecules

Task | Description
h2o2.trans.tsk | EM of H2O2, the smallest molecule having a torsion angle
mecyh.equat_axial.tsk | EM of Equatorial and axial conformations of methylcyclohexane
Pentane.all_trans.tsk | EM of All-trans conformation of pentane
gall.minim.tsk | EM of gallopamil
ice.short_mcm.tsk | MCM of ice
ditmm.water_scheraga.tsk | Solvation energy of two tetramethylammonium molecules as function of distance between nitrogen atoms. The method of solvation is shown in the task name
ditmm.water_Karplus.tsk
ditmm.water_hopfinger.tsk
ditmm.octanol_hopfinger.tsk
dmce.3_bad_starts.tsk | EM of dimethylcurine from 3 bad starting conformations
VERP_ions.0.tsk | EM of verapamil with two Ca2+ ions
Tetr.pdb | EM of tetrandrine, a polycyclic alkaloid
R_bay.pdb | EM of R-Bay K 8644, Ca2+ channel ligand
Ligands.pep | EM of six ligands from the ZMM ligand database
Tubobm.cif | EM of tubocurarine imported from the Cambridge Structural Database file. The latter is adjusted to remove atoms not linked to the drug. Compare original and ZMM-generated .pdb files to see how ZMM corrected some problems in the original file, e.g., bond length C36-H37

Peptides

Task | Description
peptall.all_starts.tsk | EM of a 59-residue polypeptide that includes almost all types of amino acids specified in ZMM and various secondary-structures for individual segments
term.minim.task | EM of peptides with different N- and C-capping groups
Ala.grid.tsk | Fi-Psi grid of N-acetyl-N'-methylamide alanine
Ala93.grid.tsk | Fi-Psi grid of alanine to reproduce the energies of 12 MECs in N-acetyl-N'-methylamide alanine (Zimmerman et al., 1977)
Polyg.mcm_zipper.tsk | MCM of polyglycine with alpha-helical and beta-strand H-bonds
ca1s3.rahel.tsk | EM of a transmembrane fragment form Ca2+ channel from alpha-helical start
coll.pdb | Importing collagen from .pdb file
cys_loop.mcm.tsk | Importing hexapeptide ACAACA and MCM to predict disulfide bond
enk.mcm.tsk | MCM of met-enkephalin
enk.mcm_grid.tsk | Random grid-MCM of met-enkephalin
enk.nested_mcm.tsk | Nested MCM of met-enkephalin
enk.hgrid.tsk | Hot grid-MCM of met-enkephalin
enk_wat.mcm200.tsk | MCM of met-enkephalin with 5 explicit waters
g_mobile.mcm.tsk | MCM of decapeptide with mobile residues
ggg.mcm.tsk | MCM of GGG tripeptide
npro.pdb | Importing pentapeptide P-A-HYP-A-P and EM
Cyclic_peptide | Importing pdb structure of a cyclic peptide

Proteins

~\ZMM\Test\safe\
1a28 | Hormone-bound human progesterone receptor
1afs | 3-alpha-hydroxysteroid dehydrogenase with NADP and testosterone
1bra | trypsin with benzamidine. Insertions.
1cbs | Retinoic-acid-binding protein with retinoic acid
1dwc | Hydrolase (serine proteinase)
1glu | glucocorticoid receptor with DNA
1h2s | rhodopsin with retinal. Inter-residue link Lys-Ret
1iol | Hydroxysteroid dehydrogenase with estradiol. Double-shell model.
1P0M | Human butyryl cholinesterase in complex with a choline molecule
2r9r |
4dxw | NavRh, a voltage-gated sodium channel
achr | Nicotinic acetylcholine receptor (2BG9)
1iol.centroid.tsk | Estradiol rotation around its long axis (Grid)
1iol.lri.tsk | Partitioned energy of ligand-receptor interaction
1iol.transl.tsk | Estradiol translation along the binding tunnel
KcsA.pdb | K+ channel with many non-resolved side chains. Multi-step relaxation
KcsA.z_ribom.tsk | Rigid-body orientation of KcsA to align the pore axis with the global z axis
KcsA_symmetry.em.tsk | EM of KcsA using four-fold symmetry
rhz.cent_mcm.tsk | TM helixes of rhodopsin. Sampling rotations around helical centers
rhz2.grid_pivot.tsk | Rotating Rh helix 1 around the pivot
rhz2.helix_2.tsk | Rotating Rh helices 1 and 2 around long axex constrained by pivots
rhz2.pivot2.tsk | Rotating Rh helixes 1 and 2 around pivots

Ligands

Forty three .pdb files with coordinates of ligands are imported to ZMM via module zl and then processed via module zi. To reduce time of testing, zl is called with option –n that precludes MOPAC call.

MacProjects

Fifty .pdb files containing proteins with small-molecule ligands, peptides, and nucleic acids are imported to ZMM via module zi. To reduce time of testing, the latter is called with option –lib that instructs to use ligands from the library zmm/ligands rather than generate them with calling MOPAC. See file zmm/tests/MacProjects/Projects.doc for details of the projects

Nucleic acids
see file \Test\Nucleic_acids\0.bat


Examples of ZMM jobs

ZMM has two libraries of ligands:

- file ligands_a.dat

- directory zmm/ligands/

When module zi imports structure from file projectname.pdb, ligands found in this file are exported to the working directory as files ligand.pdb and then are converted to files ligand.sym. The user may edit or substitute these files.

It is recommended to keep files ligand.sym in the working directory. This ensures that the same ligand is used if a project file .pep is changed.

If the user substitutes a ligand in file .pep, corresponding file ligand.sym should be placed in the working directory.

Converting ligands to .sym format involves calling program MOPAC to calculate atomic charges. This may take time, especially for large ligands.

Calling zi with the key –lib instructs ZMM to search libraries of ligands. If matching ligand is found in a library, it replaces the ligand extracted from file projectname.pdb.

PDB databank may contain files with the same-name ligands, which have different geometry and/or atom names. This may cause problems when zi is called with key –lib. When using ligands from the ZMM libraries, double-check that these ligands are compatible in terms of atom names and general architecture with ligands extracted from projectname.pdb.

The user can delete ligands from the library or add new ligands.


Examples of ZMM jobs

  • You may create directory zmm/pdb to keep PDB files of macromolecules of your interest. This helps avoiding duplication of large *.pdb files

  • ZMM looks for the PDB template in the working directory and then in directory zmm/pdb.


ZMM consists of nine programs, 15 data files, help files, library of ligands, and several utilities

ZMM distributive includes:

- Executable modules

- Graphical User Interface MVM (Windows only)

- Data files

- Test files (examples)

- Help file

- Library of ligands

At WINDOWS, the user may work via MVM, or in a command-line mode. In the latter case, the system needs a file manager, e.g.:

- WinNC http://www.dunesmm.nl/winnce/

- GNU MidNight commander http://home.a-city.de/franco.bez/mc/mc.html


ZMM runs at the Windows and Unix platforms

ZMM works under Windows and Unix.

At Windows, ZMM can be used with graphical interface MVM created by Dr. Denis Tikhonov (Russian Academy of Sciences, St. Petersburg) or PyMol.

At UNIX, ZMM may be used with any molecular graphics program, such as PyMol, WebLab, etc.

ZMM can be run in the file-operated (command-line) mode that allows a 100% reproducibility of results, debugging input data and cloning homologous jobs.


To install ZMM:

Execution of ZMM_SETUP.EXE will invoked the installation procedure as provided by InstallShield.

One can also install ZMM by carrying out the following:

- Create a root (home) folder for ZMM (any name and any location are allowed). In the examples shown below, the root folder is d:\zmm

- Copy folders exe, dat, pdb, help, and test from the ZMM distributive to folder d:\zmm.

- Specify path to folder d:\zmm\exe in file autoexec.bat:
PATH=d:\zmm\exe (ensure that no space is left at the end of this line)

- Set environmental variable ZMM_HOME in file autoexec.bat
SET ZMM_HOME=d:\zmm\ (note backslash at the end of this line)

- Restart your computer


To install ZMM:

Download the specific UNIX version from www.zmmsoft.com and follow these steps.

1. Create a home directory for ZMM. It may have any name and any location. The following commands assume that the ZMM home directory is ~/zmm/

2. Put file zmm.tar.gz in ~/zmm/

3. Go to directory ~/zmm/

4. Type: gunzip zmm.tar.gz

5. Type: tar xpf zmm.tar

6. Specify path to folder ~/zmm/exe/ (See Examples below)

7. Set environmental variable ZMM_HOME (See Examples below)

8. To test ZMM, go to zmm/test/ and type “run”. Upon completion of the test, type “check”. You should see neither *fail files, nor ZMM_error files. Files *.dif will show the output difference between your computer and ZMM-developers computer. The difference may occur due to specific hardware configurations. In case of big difference(s), please contact ZMMSoft.

9. Use PC/Windows to read and search ZMM-2006 help file.

Examples:

tcsh: add the following two lines to file .cshrc

set path=(~/zmm/exe $path)

setenv ZMM_HOME ~/zmm/

bash: add the following two lines to file .bashrc

export PATH=${PATH}:${HOME}/zmm/exe
export ZMM_HOME=${HOME}/zmm/

The above lines may vary depending on the operating system and command interpreter. Contact your system administrator for details.

Registering ZMM on UNIX

The ZMM installation described above is fully operational, but has a limit of 100 cycles of Monte Carlo minimization. Registering ZMM will remove this restriction for 6 months. Purchasing ZMM will completely remove the restriction.

To register ZMM:

  1. Go to directory ~/zmm/exe/ and type: Get_User_Infos_Linux. The file USER_INFOS.TXT should appear.
  2. E-mail this file to info@zmmsoft.com
  3. Visit www.zmmsoft.com, fill in the registration form, and click “SUBMIT”

In a few days you receive a license file ZMM_LICENSE.KEY. Put this file to ~/zmm/exe/


Licensing Policy

When you install a DEMO version without registration, ZMM will run for 30 days with restricted capabilities (up to 100 iterations in each cycle of energy minimization, and up to 100 cycles of energy minimizations in the Monte Carlo protocols). After 30 days, you can still run ZMM for another 60 days, but with further reduced capabilities (10 iterations..).

The MVM viewer (GUI of ZMM) has no expiration date. You can keep using it forever.

You can register ZMM without buying it to run it with full capabilities up to one month.

To register:

1) Run module “Get_User_Infos.exe” in a command-line interface. This module will generate file USER_INFOS.TXT in the ZMM_HOME\exe\ directory.

2) Go to www.zmmsoft.com and click "Register" on any page and follow instruction.

You will receive file “ZMM_LICENSE.KEY” by e-mail in a few days. Please save it to ZMM_HOME\exe directory (e.g. in Windows: c:\Program files\zmm\exe)

To buy ZMM, go to www.zmmsoft.com and click "Purchase" on any page and follow instruction.

If you have problem submitting the web form please send an E-mail to info@zmmsoft.com with your information and USER_INFOS.TXT as an attachment.


END-USER LICENSE AGREEMENT FOR ZMM SOFTWARE

IMPORTANT - READ CAREFULLY: This ZMM End-User License Agreement ("ZEULA") is a legal agreement between you (either an individual or a single entity) and ZMM SOFTWARE Inc. ("ZSI"), for the ZMM product, which includes computer software and may include associated media, printed materials, and "online" or electronic documentation ("PRODUCT"). The PRODUCT also includes any updates and supplements to the original PRODUCT provided to you by ZSI. Any software provided along with the PRODUCT that is associated with a separate end-user license ZEULA is licensed to you under the terms of that license ZEULA. By installing, copying, downloading, accessing or otherwise using the PRODUCT, you agree to be bound by the terms of this ZEULA. If you do not agree to the terms of this ZEULA, do not install or use the PRODUCT.

SOFTWARE LICENSE

The PRODUCT is protected by copyright laws and international copyright treaties, as well as other intellectual property laws and treaties. The PRODUCT is licensed, not sold.

1. GRANT OF LICENSE.

This ZEULA grants you the following rights:

. This product as downloaded from the ZSI web site is a DEMO Version. It will run for 30 days with LIMITED capability and an additional 60 days with VERY LIMITED capability. You can uninstall the product anytime by clicking the "uninstall" button on the window manual.

. You can register online at www.zmmsoft.com to obtain a license key for running the product for 30 days with UNLIMITED capability.

. You can purchase a regular license online at www.zmmsoft.com to run the product with UNLIMITED capability.

. If you work for a non-profit research or teaching institution you can purchase an Academic Version.

. If you are a full time student you can purchase a Student Version.

· Installation. You may install and use this PRODUCT on only one computer, including a workstation, terminal, or other digital electronic device ("COMPUTER").

· Storage or Network Use. You may also store or install a copy of the PRODUCT on a storage device, such as a network server, used only to install or run the PRODUCT on your other COMPUTERS over an internal network; however, you must acquire and dedicate a license for each separate COMPUTER on or from which the PRODUCT is installed, used, accessed, displayed or run. A license for the PRODUCT may not be shared or used concurrently on different COMPUTERS.

· Site License. If you have acquired this ZEULA as part of a site license, you may install and use additional copies of the computer software portion of the PRODUCT up to the number of copies specified above as "Licensed Copies."

· Restrictions. All rights not expressly granted herein are reserved by ZSI.

2. DESCRIPTION OF OTHER RIGHTS AND LIMITATIONS.

· Academic Version Software. If the PRODUCT is identified as "Academic Edition" or "AE," you must be a "Qualified Educational User" to use the PRODUCT. If you are not a Qualified Educational User, you have no rights under this ZEULA. To determine if you are a Qualified Educational User, please contact ZMM SOFTWARE Inc.

. Student Version Software. If you are not a full time student user, you have no rights under this ZEULA

· Limitations on Reverse Engineering, Decompilation and Disassembly. You may not reverse engineer, decompile, or disassemble the PRODUCT, except and only to the extent that such activity is expressly permitted by applicable law notwithstanding this limitation.

· Separation of Components. The PRODUCT is licensed as a single product. Its component parts may not be separated for use on more than one COMPUTER.

· Limitations on Use. You may not modify, adapt, translate, loan, resell for profit, distribute, network, rent, lease or create derivative works based upon the PRODUCT or any copy, except as expressly provided in Section 1 above.

· Trademarks. This ZEULA does not grant you any rights in connection with any trademarks or service marks of ZMM SOFTWARE Inc.

· Termination. This license is effective until January 1, 2099, unless terminated earlier. You may terminate the license at any time by destroying the PRODUCT and all related documentation together with all copies or modifications in any form. ZSI will have the right to terminate this ZEULA if you fail to comply with the terms and conditions of this ZEULA. Upon any termination, you must destroy all copies of the PRODUCT and all of its component parts and any copies or modifications in any form.

3. UPGRADES.

If the PRODUCT is labeled as an upgrade, you must be properly licensed to use a product identified by ZSI as being eligible for the upgrade in order to use the PRODUCT. A PRODUCT labeled as an upgrade replaces and/or supplements the product that formed the basis for your eligibility for the upgrade. You may use the resulting upgraded product only in accordance with the terms of this ZEULA. If the PRODUCT is an upgrade of a component of a package of software programs that you licensed as a single product, the PRODUCT may be used and transferred only as part of that single product package and may not be separated for use on more than one COMPUTER.

4. COPYRIGHT.

All title and intellectual property rights in and to the PRODUCT (including but not limited to any images, photographs, animations, video, audio, music, text, and "applets" incorporated into the PRODUCT), the accompanying printed materials, and any copies of the PRODUCT are owned by ZSI or its suppliers. All title and intellectual property rights in and to the content which may be accessed through use of the PRODUCT is the property of the respective content owner and may be protected by applicable copyright or other intellectual property laws and treaties. This ZEULA grants you no rights to use such content. All rights not expressly granted are reserved by ZSI.

5. LIMITATION OF LIABILITY.

IN NO EVENT WILL ZSI BE LIABLE TO YOU FOR ANY SPECIAL, INDIRECT, CONSEQUENTIAL OR INCIDENTAL DAMAGES, INCLUDING ANY LOST PROFITS, LOST DATA, OR LOST SAVINGS, EVEN IF ZSI HAS BEEN ADVISED OF THE POSSIBILITY OF SUCH DAMAGES, OR FOR ANY CLAIM BY ANY OTHER PARTY. Some states do not allow the exclusion or limitation of special, incidental or consequential damages, so the above exclusion or limitation may not apply to you.

6. LIMITATION OF REMEDIES.

ZSI's entire liability and your exclusive remedy shall be: you may terminate this ZEULA by uninstalling the PRODUCT from your computer, and the purchase price you paid will be refunded.

7. INDEMNITY.

You agree that ZSI shall have no liability whatsoever for any use you make of the PRODUCT. You shall indemnify and hold harmless ZSI from any third party claims, damages, liabilities, costs and fees (including reasonable attorney fees) arising from your use of the PRODUCT as well as from your failure to comply with any term of this ZEULA.

8. MISCELLANEOUS.

This ZEULA is governed by the laws of the province of Ontario, Canada.

Should you have any questions concerning this ZEULA, or if you desire to contact ZSI, please write: ZMM Software Inc., 7 Innovation Drive, Flamborough, Ontario, Canada L9H 7H9.


Specifying macromolecular structure in file molname

Specifying macromolecular structure in file molname.pep

The amino acid sequence of a macromolecular system is specified in file molname.pep. This file is usually generated automatically by program zi from file molname.pdb (see zmm/test/proteins/KcsA). The user can modify the file to change some amino acids, to add ligands, ions, etc. Program ZP reads molname.pep and creates file molname.sym, in which the molecular structure is defined by bonds. Table below shows fields in file molname.pep.

Field | Necessity | Example | Structure of the field
FORCE FIELD | Required | any .pep file | AMBER | AMBERL | SCHERAGA | MOMANY | MM2 | DASHEVSKIY | ZHURKIN |
PDB GEOMETRY# template_name | Optional | KcsA | See description of file molname.sym
SEQUENCE | Required | any .pep file | See examples in ~/test/proteins/
LIGANDS | Optional | 1dwc | See example
WATERS | Optional | 1dwc | See example
SS-BONDS | Optional | 1dwc | See example
IONS | Optional | KcsA | See example

In the field SEQUENCE in .pep file, each line specifies up to ten residues. In each line, ten rightmost characters specify status of the corresponding residues as described below

Residue status | Eigen degrees of freedom | Valid fields
-, excluded | Residue is not in the model | All
x, fixed | No Eigen degrees of freedom. Atomic coordinates are imported from a .pdb file and remain unchanged in calculations | Sequence, ligand, ion
r, rigid | No Eigen degrees of freedom, but atomic coordinates may change with geometry of proceeding residues in the chain | Sequence, Ligands
f, flexible | Torsions; translation and orientation (in root residues). | Sequence, ligands, waters
m, mobile | f with translations and orientations | Sequence
e, elastic | f with elastic bond angles | Sequence, ligands
a, all | m with elastic bond angles | sequence


Peptides

Chemical structure of amino acids, N-end and C-end capping groups are defined in file amacir_s.dat. Amino acids are designated by their standard one- or three-letter codes. Each amino acid may be presented by all atoms or united atoms. United-atoms amino acids are designated by lower-case characters. If the user specifies an N-end amino acid as the united-atom residue, due to technical reasons ZMM converts it to the all-atom residue. Different protonation states of ionogenic amino acids have specific ZMM names shown below.

Amino acid | Protonation / tautomeric state | ZMM name
 |  | All-atom | United-atom
Lysine | Lys | LYS, K | lys, k
 | Lys+ | LYP | lyp
Arginine | Arg | ARG, R | arg, r
 | Arg+ | ARP | arp
Glutamic acid | Glu | GLU, E | glu, e
 | Glu- | GL- | gl-
Aspartic acid | Asp | ASP, D | asp, d
 | Asp- | AS- | as-
Cysteine | Cys | CYS, C | cys, c
 | Cys- | CY- | cy-
Histidine | His, HN delta1 | HIS, H | his, h
 | His, HN epsilon2 | HIE | hie
 | His+ | HIP | hip

N-capping groups |  | C-capping groups
ZMM name | Structure | ZMM name | Structure
NH2 | H2N- | C0 | C-end in a loop
NH3 | H3+N- | CNM | -CO-NH-CH3
NME | CH3HN- | CGO | -CO-NH-CH2-CH2-OH (gly-ol)
NAC | CH3-CO-HN- | CNH | -CO-NH2
NH | N-end in proline | COM | -CO-O-CH3
N0 | -N (Loops) | CME | -CO-CH3
NL | N-end in a loop | COH | -CO-OH
 |  | CH | -COH
 |  | COO | -COO-
 |  | CEA | -CO-Empty atom

The user can create up to 8 artificial (non-standard) amino acids with names AA1, AA2, … AA8

How to create a non-standard Amino Acid

  1. Run MVM
  2. Click File/open
  3. Go to directory ~zmm/ligands/fragments/
  4. Select an amino acid closest to that you want to design
  5. Click “Edit/Start Ligand Modification”
  6. Modify the side chain of the amino acid
  7. Click “End Modification”
  8. In the pop-up box, enter name, e.g., AA1
  9. Click “File/Save All”
  10. Save ligand in the chosen directory under new name (e.g., AA1)
  11. Open a command window in the chosen directory
  12. Type: zl AA1.pdb –aa
  13. Add all lines from file AA1.sym to zmm/dat/amacir_a.dat

Please note that atomic charges and the valence bond geometry in non-standard amino acids are calculated with MOPAC-6 (AM-1 method) and ZMM, respectively. The results are expected to differ from those in file amacir_a.dat, which is based on ECEPP/2 force field standards. The user may edit file molname.sym to modify respective characteristics of the non-standard amino acids.

Non-standard amino acids

PHM | N-Methyl Phenylalanine
DAL | D-alanine
ORN, orn | Ornithine
HYP | Gamma-Hydroxyproline
ATHR | Allo-threonine
IPH | 2S,3R beta-isopropyl-phenylalanin
MSE, mse | Selenomethionine
CEA | Cysteine with MTSEA
CET | Cysteine with MTSET
CES | Cysteine with MTSES
CEH | Cysteine with MTSEH
CGU | Carboxy Glutamic Acid
CG0 | Carboxy Glutamic Acid Neutral
LYL, lyl | Lysine linked to retinal
PTR | Phosphotyrosine


Nucleic Acids

Structure of nucleotides, 2'-deoxy nucleotides, 5'-end and 3'-end capping groups defined in file zmm/dat/nucleica.dat are specified as follows

Nucleotide | ZMM name
 | DNA | RNA
Adenosine monophosphate | dA | ADE
Guanosine monophosphate | dG | GUA
Cytosine monophosphate | dC | CYT
Deoxythymidine monophosphate | dT |
Uridine monophosphate |  | URA

5'-capping groups |  | 3'-capping groups
ZMM name | Structure | ZMM name | Structure
HO | HO- | OH | -OH


Small molecules

Ligands (Small molecules)

ZMM has two libraries of ligands specified in the .sym format:

- file ligand_a.dat
- directory zmm/ligands/ currently contains ~ 100 ligands

A user may download from http://www.wwpdb.org/ccd.html Chemical Component Dictionary (components.cif), rename it to “components.txt” and install as ZMM\databases\Chem_Comp_Lib\components.txt. This big file contains thousands of ligands in the CIF format with hydrogens. Therefore, chemical structures are unambiguous unlike in standard pdb files that usually lack hydrogens. Use zi key –lcl in to search components.txt as the first option. Testing –lcl key in ~100 complexes in Teach\3y03\Proteins_3y03 shows that ~ 90% ligands in .cif format are digested by ZMM (December, 2013).

A user may specify a new ligand either as a stand-alone file newligand.sym in the working (upper) directory or in file ligand_a.dat.
Table below show ligands currently described in file ligand_a.dat.

Ligand's Class | ZMM name | General name
Cofactors | ADP NCA+ NCA NADP NAP | Adenosinediphosphate Fragment of NAD(P)+: nicotinamide +, ribose and phosphate Fragment of NAD(P)H: nicotinamide, ribose and phosphate NADPH with atom numbered C1, C2, … NADPH with standard atom labels AC5* used in many pdb files
Steroids | E2 DHEA HOPS E1 EADT DHT TES | Estradiol Dehydroepiandrosterone 20-alpha-OH-progesterone Estrone Epiandrosterone Dihydrotestosterone Testosterone
Opioids | MOR NAL NLXN NLP | Morphine Naloxone
Ligands of glutamate receptors (Denis Tikhonov) | KAI AMP NMD LGL | Kainate l-glutamate
Protein Kinase inhibitors | H9 |
Blockers of Cl- channels | STRN PICR CTB | Strychnine Picrotoxinin Cyanotriphenylborate
Ligands of Ca2+ channels | NIFE VERA RBAY SBAY DMCN VERP TETR DILT | Nifedipine (NIF1) Verapamil neutral R-Bay 8644 R-Bay 8644 Dimethylcurine neutral Verapamil Protonated Tetrandrine Diltiazem


Specifying valence structure in file molname

Specifying valence structure in file molname.sym

Valence structure of a molecular system is specified in the file molname.sym as a list of bonds.

Modules ZP and ZL create file molname.sym ,respectively, from files molname.pep and molname.pdb. Description of each monomer starts with the residue name and label.

Table below explains structure of the file molname.sym. Some fields may be corrected or added by the user. See directory /test/small/ for examples of molname.sym files.

Fielda,b,c

Needfulness

Structure of the field a

System identification

Mandatory

A line describing the system

Force field

Mandatory

| AMBER | AMBERL | MOMANY | SCHERAGA | MM2 | DASHEVSKIY | ZHURKIN

PDB GEOMETRY
template_name

Optional

ZM reads file template_name.pdb from the working directory (in the absence of the file there from the ZMM directory). The template is used to specify bond angles, bond lengths, rigid torsions PIN constraints, and starting geometry in the peptide/protein.

List of bonds

Optional

Description of bonds between ZMM atom types. See files .sym in the test directory for examples and details. Line END closes the list of bonds.

WATER
ALL

Optional

Importing all waters from file template.pdb

WATER
ONLY n
<numbers of waters>

Optional

Importing specified waters from file template.pdb. In the absence of the template, inserting n waters (see zmm/t/enk_wat.sym).

WATER
CLOSE

Optional

Importing waters within 5 A from heavy atoms in file template.pdb.

FREE ATOMS
<Quantity of free atoms>
< list of free atoms>

Optional

For each free atom, its ZMM type, PDB name, and charge should be specified, e.g. 'Ca' 'Ca++.Free.108' 2.

Fixed parts. Only one type of rigid part may be specified for a given system

FIXA
<Quantity of atoms>
<List of fixed atoms>

Optional

FIXA: List of fixed atoms and their coordinates in the PDB format.

FIXR
<Quantity of fixed residues>
<numbers of resid.>

Optional

The following three forms of the field specify a rigid part of the system as a set of atoms whose coordinates are given in the template pdb file.

FIXR
m

Optional

Imports m fixed residues specified in the template *.pdb file.

FIXR
m n

Optional

Imports residues m-n from template.pdb

ELASTIC
List of entries
END ELASTIC

Optional

This field specifies atoms with variable bond angles. The field may include several entries. Each entry is either a line specifying elastic residue(s) or a list of elastic atoms. Entries may appear in any order. An atom or residue may appear in more than one entry.

ALL ! All atoms
RESIDUES [lbi [lbj]]
PROLINES
MAIN [lbi [lbj]] ! main chain atoms (all atoms in prolines)
MAINB [lbi [lbj]] ! main chain and Cb atoms (all atoms in prolines)
ATOMS
list of elastic atoms
END ATOMS

STRETCHED
ALL
END

Optional

Only one field STRETCHED may appear in file *.sym

STRETCHED
HEAVY
END

Optional

List of stretched bonds (see zmm/test.small_molecules/mecyh.sym)

STRETCHED
<quantity of bonds>
<numbers of bonds>

Optional

LINKED RESIDUE
<number of links>
<list of N-terminal nitrogens in the flexible fragments linked to C' atoms of the previous fixed fragments>

Mandatory if a chain is split in fixed and flexible parts

To speed up computations, a polypeptide chain may be partitioned into rigid and flexible segments (Zhorov and Lin, 2000). Smooth connections between the flexible and the rigid segments are established via links. A link connects the N-end of a flexible segment to the C' atom of the previous rigid segment. Root atoms of the linked flexible segments are frozen. C-terminal atoms C' and O in the flexible segments are pinned. List of flexible residues linked to the fixed residues is automatically generated by ZP. (see zmm/test/proteins/1iol.sym generated by zp).

H-BONDS
<quant. of H-bonds>
<list of H-bonds>

Optional

Explicit H-bonds for Dashevskiy and MM2 force fields. See zmm/test/small_molecules/gall.sym

BOND ANGLES
<list of bond angles>
END BOND ANGLES

Optional

Values of rigid bond angles are specified.

CORRECTION

Optional

The following arrays generated by ZM may be corrected: VMA ATCH BL ECON GCON GENC EHB DHB ECDB GCDB KAGC LOV ANB BNB CNB. This command performs a task similar to that of ARRAY in TUNE but the changes become permanent for the given molecule

END SYMOL

Mandatory

The last line in the *.sym file

b In the field name, six leading characters are important.
c Fields should appear in the *.sym file in the same order as in the Table


Vector Models of Atoms

An atom in a bond is specified by its ZMM name, ray number, and other characteristics. A ray is a unit vector in a Vector Model of Atom, VMA (Zhorov, 1975). The rays of an atom diverge from a common point specifying directions of bonds and default bond angles. The latter may be overridden in the bond angles filed of file molname.sym. For example, VMA of a tetrahedral carbon CP consists of four rays R1, R2, R3, and R4. If CP is in the origin of the Cartesian coordinate system with R1 pointing along -x axis, and R2 being in the first quadrant of xOy plane, R3 has positive and R4 negative z-coordinate. This definition helps specify absolute configuration of chiral atoms. A covalent radius is associated with each ray so that ray numbers of atoms in a bond specify a default bond length. The latter may be overridden in a bond length field of the bond specification. The table below shows ZMM atom types and characteristics of their VMAs. Parameters of atoms are specifies in file atoms.inc and files mentioned there.

Atom Types

ZMM atom name | Chemical type of Atom | Covalent radius along the ray |  |  |  | Bond angles between the rays
 |  | R1 | R2 | R3 | R4 | R1, R2 | R1, R3 | R2, R3
Carbon
CP | Paraffin | 0.77 | 0.77 | 0.77 | 0.77 | 109.5 | 109.5 | 109.5
CA | Aromatic | 0.77 | 0.695 | 0.695 |  | 120 | 120 | 120
CO | Olefin | 0.695 | 0.77 | 0.77 |  | 120 | 120 | 120
CK | Carbonyl | 0.695 | 0.77 | 0.77 |  | 124 | 124 | 112
CC | Acetylene | 0.75 | 0.605 |  |  | 180 |  |
CN | Allen | 0.665 | 0.665 |  |  | 180 |  |
CF | Five-bond ring | 0.675 | 0.725 | 0.725 |  | 130 | 110 | 120
CE | Peptide | 0.76 | 0.66 | 0.68 |  | 115.0 | 120.5 | 124.5
CG | Guanidine | 0.77 | 0.77 | 0.77 |  | 120 | 120 | 120
CT | three-bond ring | 0.77 | 0.77 | 0.77 | 0.77 | 60 |  |
C: | With lone pare | 0.57 | Carbon Monoxide N-butyl-isocyanide (myoglobin)
 | United-atom carbons. (Ray3 has +z in C1 and -z in C4.)
C1 | CH in Leu_Cg | 0.77 | 0.77 | 0.77 |  | 109.5 | 109.5 | 109.5
C4 | CH in Ala_Ca | 0.77 | 0.77 | 0.77 |  | 109.5 | 109.5 | 109.5
C2 | CH2 | 0.77 | 0.77 |  |  | 109.5 |  |
C3 | CH3 | 0.77 |  |  |  |  |  |
CH | CH aromatic | 0.695 | 0.695 |  |  | 120. |  |
Hydrogen
HP | Paraffin (aliphatic) | 0.3 |  |  |  |  |  |
HN | Attached to N | 0.3 |  |  |  |  |  |
HA | Aromatic | 0.3 |  |  |  |  |  |
HO | Attached to O | 0.3 |  |  |  |  |  |
HS | Attached to S | 0.3? |  |  |  |  |  |
HW | Water | 0.3 |  |  |  |  |  |
Oxygen
OR | Ether | 0.66 | 0.66 |  |  | 109 |  |
OF | Furan | 0.68 | 0.68 |  |  | 107 |  |
OK | Carbonyl | 0.55 |  |  |  |  |  |
ON | Negative | 0.5 |  |  |  |  |  |
OW | Water | 0.68 | 0.68 |  |  |  |  |
OT | Three-bond ring | 0.66 | 0.66 |  |  | 60. |  |
OL | With lone pairs | 0.66 | 0.66 |  |  |  |  |
Nitrogen
NM | Amino | 0.7 | 0.7 | 0.7 |  | 109.5 | 109.5 | 109.5
ND | Amide | 0.53 | 0.7 | 0.7 |  | 120 | 120 | 120
NN | Nitro | 0.7 | 0.65 | 0.65 |  | 116.5 | 116.5 | 127
NO | Azo | 0.7 | 0.6 |  |  | 120 |  |
NA | Aromatic | 0.7 | 0.675 | 0.675 |  | 120 | 120 | 120
N+ | Nicotinamide + | 0.7 | 0.675 | 0.675 |  | 120 | 120 | 120
NP | Pyridine | 0.675 | 0.675 |  |  | 120 |  |
Nc | Coord, >N---Fe | 0.675 | 0.675 | 0.675 |  | 120 | 120 |
NT | Nitrile | 0.574 |  |  |  |  |  |
NI | Isycyanide | 0.7 | 0.5 |  |  | 140 | Hemoglobin 101m
NZ | Azide | 0.64 | 0.547 |  |  | 180 |  |
NR | Pyrrole | 0.7 | 0.7 | 0.7 |  | 127.5 | 127.5 | 105
NL | Pyrazol | 0.725 | 0.675 |  |  | 110 |  |
NF | Four bonds (+) | 0.7 | 0.7 | 0.7 | 0.7 | 109.5 | 109.5 | 109.5
NE | Peptide | 0.665 | 0.683 | 0.7 |  | 121.0 | 124.0 | 115.0
Sulfur
SF | S Thioether | 1.04 | 1.04 |  |  | 100 |  |
SK | S Thiocarbonyl | 0.94 |  |  |  |  |  |
SN | S Thiophene | 1.02 | 1.02 |  |  | 91 |  |
SS | S Sulpho | 1.04 | 1.04 | 0.94 | 0.94 | 109.5 | 109.5 | 109.5
ST | S Three coord. | 1.04 | 0.94 | 0.94 |  | 94 | 92 | 92
S- | S- Thiolate | 1.04 |  |  |  |  |  |
Phosphorus
PF | P Phosphate | 1.1 | 1.1 | 1.1 | 1.1 | 109.5 | 109.5 | 109.5
PT | P Three-coordinated | 1.1 | 1.1 | 1.1 |  | 109.5 | 109.5 | 109.5
Halogens
Ft | F | 0.64 |  |  |  |  |  |
Cl | Cl | 0.99 |  |  |  |  |  |
Br | Br | 1.14 |  |  |  |  |  |
I | I | 1.33 |  |  |  |  |  |
Metals
Na | Na+ |  |  |  |  |  |  |
K+ | K+ |  |  |  |  |  |  |
Rb | Rb+ |  |  |  |  |  |  |
Li | Li+ |  |  |  |  |  |  |
Cs | Cs+ |  |  |  |  |  |  |
Ca | Ca2+ |  |  |  |  |  |  |
Mg | Mg2+ |  |  |  |  |  |  |
Zn | Zn2+ |  |  |  |  |  |  |
Cu | Cu2+ |  |  |  |  |  |  |
Cd | Cd2+ |  |  |  |  |  |  |
Mn | Mn2+ |  |  |  |  |  |  |
Hg | Hg2+ |  |  |  |  |  |  |
Fe | Fe2+ |  |  |  |  |  |  |
Other Atoms
Si | Si | 1.17 | 1.17 | 1.17 | 1.17 | 109.5 | 109.5 | 109.5
B | B (Boron) | 0.84 | 0.84 | 0.84 | 0.84 | 109.5 | 109.5 | 109.5
Se | Se* | 1.04 | 1.04 |  |  | 100 |  |
EA | Empty Atom |  |  |  |  |  |  |
LP | Lone Pair | -0.16 |  |  |  |  |  |
Pseudo-atoms for a receptor model around adrenaline (Zhorov & Govyrin, 1984)
AP | Acceptor of H | 1.4 |  |  |  |  |  |
DP | Donor H | 0.7 |  |  |  |  |  |
OB | O Bare | 0.55 | 1.4 | 1.4 |  |  |  |
OH | O Half bare | 0.66 | 0.66 | 1.4. | 1.4 |  |  |
CS | C of the Shell | 2.0 |  |  |  |  |  |
CB | C Bare | 0.77 | 0.695 | 0.695 |  |  |  |
HL | H of the Shell | 1.2 |  |  |  |  |  |
HB | H Bare | 0.3 |  |  |  |  |  |
HH | H in H-bond | 0.3 | 0.4 |  |  |  |  |
NH | N Half bare | 0.7 | 0.675 | 0.675 |  |  |  |
-< |  |  |  |  |  |  |  |
-< |  |  |  |  |  |  |  |

* May 26, 2004. BSZ and DSY introduced selenium, which is needed for selenomethionine. No parameters are available. Treated as Sulfur.

Atom properties are specified in the following files:

File | Subroutine
lib_zmm.f | zmm_atoms
atoms_w.dat |
vdWpar_w.dat |
l_lib.f | planar_atom
l_atoms.f |
l_groups_b.f |
v_putndo.f |
atoms.inc |


Bond format of in .sym file

Format of bonds in *.sym file

In most cases, sym-files are generated automatically and the user does not need to edit them. However, understanding the sym-file format may help to edit ligands, e.g. to rigidify some bonds, changing names of atoms and torsions, changing bond angles, etc. The links below show, as an example, the adenosine molecule and ZL-generated sym-file of adenosine with explanation of each column

An atom with two or more rays can be attached to the basal atom via one of the following bond types:

B, regular Bond, rotation around which is allowed
C, Constant-torsion bond (rotation is not allowed)
L, Loop-closing bond, which is not a generalized coordinate. Dummy atoms at this bond are used to keep the loop closed.
R, Rigid-loop-closing bond that is not a generalized coordinate.
U, Unessential-torsion bond, rotation around which does not produce conformers in the conformational stack (e.g, bond C-Me)

For L- and R-bonds, the following modified format is used to specify bond angles of the adjacent atom AA. Fields "name of torsion" and "torsion angle" contain atom name A3 and bond angle A3-AA-BA; fields "AA charge", NAENG, and RERA contain atom name A4 and bond angle A4-AA-BA.


Inter-residue loops

Some polymers contain loops, chemical bonds connecting non-adjacent residues or non-standard chemical bonds between adjacent residues. Examples are disulfide bonds in proteins, bonds between side chains of different residues, and macrocycles, in which the last residue is bonded to the first residue. The loops are specified in *.sym file by modifying descriptions of the two residues linked via a non-standard bond.

  • First line in the descriptor of the last residue in the loop refers to the label of the first residue in the loop
  • The last residue in the loop contains a loop-closing bond of L-type. In this bond, the number of the adjacent atom is omitted, and the name of the adjacent atom refers to the bonded atom in the first residue of the loop.

Disulfide bonds in proteins are recognized by zi. Corresponding field "SS-BONDS" is added to *.pep file. This field is used by zp to generate *.sym file (see example zmm/test/peptides/cys_loop).


Tuning ZS jobs

Module zs can perform various tasks with the molecular structure specified in the file molname.sym. A concrete job is specified in file molname.jobname.tsk.

General structure of file molname.jobname.tsk

The file molname.jobname.tsk may contain blank lines and comment lines starting with characters "# " or "!".

If the first non-comment line in file molname.jobname.tsk is one of the following: |PASS|RIBOM|ANFID| it instruct zs to perform a non-standard function:

PASS search for the lowest-energy path between two conformers
RIBOM rigid-body rotation of molecular system
ANFID compare gradient calculated analytically with that computed by finite-difference method (for ZMM developers)

The tune-file contains fields that define starting geometry, control parameters, constraints, etc. A filed starts with the line FIELDNAME and ends with the line END [FIELDNAME].

The following field names are possible:

GRID | RGRID | HGRID
START
RESUDUE SETTINGS
CONSTRAINT
PARAMETER
INDEX

Fields GRID and RGRID have rigid syntax. With few exceptions, other fields and lines within these fields may appear in any order.

Several identical fields may appear in the tune-file. If an item (e.g., a TORSION) is defined several times, the last definition overrides previous ones.

The file molname.jobname.tsk ends with the line END [TUNE].


Field GRID n controls performance of the GRID task

GRID is a tool for efficient sampling of conformational space from different starting points. For example GRID allows to pull a ligand through an ion channel and MC-minimize energy at each node of the grid.


Field GRID n controls performance of the GRID task

Field GRID controls a GRID procedure that modifies specified variables in a nested-loop mode. GRID builds starting structure for each node and (depending on parameter KOPT) calculates, minimizes or MC-minimizes the energy in each node.

Parameter n specifies a number of driven parameters, i.e. the grid dimensionality. (See file “size limits” for n limit, NDPM). Once grid dimensionality is given, n lines should follow to specify driven parameters. The following example specifies a two-dimensional grid of 18 (3 x 6) nodes. The first torsion is assigned values of 60, 180, and 300°. The second torsion is assigned values of 60, 120, 180, 240, 300, and 360°.

GRID
3
6
END

2
0
0

'Fi .ALA. ___1 '
'Psi.ALA. ___1 '

60.
60.

120.
60.

A driven parameter may modify up to NCDPM co-driven parameters (see size limits for current value of NCDPM). Definitions of the parameters are given below.

- Driven parameter = {generalized coordinate | constraint | pivot| rotation }

- Generalized coordinate = {torsion_name | Xmol | Ymol | Zmol | Fi_M | Ps_M | Te_M}

- Constraint = 'constraint-name.{L|H}.constraint-number'.

o   Constraint-name = any name in column 1 of the field CONSTRAINTS.

o   "L" and "H" refer to the Lower (DL) and Higher (DH) limit of the constraint.

o   Constraint-number = Sequential number of the given-type constraint as it appears in the field CONSTRINTS. E.g., 'AA.L.3' refers to the lower limit of the third constraint 'AA' in the field CONSTRAINTS.

- Pivot = 'PVT.{X|Y|Z|FI|PSI|TETA|S}.pivot-number' Example: \Test\Proteins\rhz2.grid_pivot.tsk

- Rotation = {RotX | RotY | RotZ} Example: \test\proteins\WF201.rotate_y.tsk

The following example \test\proteins\1iol.transl.tsk specifies a one-dimensional grid of 16 nodes in which the driven parameter ('APNC.L.1') is the Lower limit of the first constraint APNC. Three co-driven parameters (APNC.H.1, APNC.L.2, and APNC.H.2) instruct ZMM to modify, respectively, the high limit of the first APNC constraint, the Lower limit of the second APNC constraint, and the high limit of the second APNC constraint. Importantly, when driven or co-driven parameters are constraints, the field CONSTRAINTS must precede the field GRID.

CONSTRAINTS
APNC ' O3 .E2. _400 ' 8.361 13.481 -14.072 12.232 4.884 -8.037  0.  0. 100.
APNC ' O17.E2. _400 ' 8.361 13.481 -14.072 12.232 4.884 -8.037 11.2 0. 100.
END

Six coordinates in each line specify a plane by the vector, which is normal to the plane. The first tree coordinates are the vector origin (8.361 13.481 -14.072) and the last there coordinates are the vector end. These coordinates are PDB coordinates of the O3 and O17 atom in the x-ray structure of the ligand-enzyme complex.

If you want to move a ligand through a path, but do not have x-ray structure in which the ligand is within the path, you can make a model with two dummy atoms, place “manually” the atoms in the beginning and the end of the path, and then extract coordinates of the atoms from the PDB file of the model.

GRID
11

END

1
3

'APNC.L.1 '
'APNC.H.1 '
'APNC.L.2 '
'APNC.H.2 '

-5.
-5.
4.34
6.2

1.
1.
1.
1.

This example specifies a GRID, that pulls estradiol (E2) through the ligand-binding tunnel. For each of the 11 nodes of the GRID, the driven parameter (APNC.L.1) modifies the Lower limit of the first APNC constraint specified in the CONSTRAINTS field. The starting position of the Lower limit is -5 Å and the step is 1 Å. The lower limit adopts the following values :-5., -4., .... 4., 5. Å (see Table below). The first co-driven parameter in this example (APNC.H.1) is the Higher limit of the first APNC constraint in the CONSTRAINTS field. As the GRID job is calculated, APNC.H.1 hops via 11 points starting from -5 Å with 1 Å step (-5, -4, ...4, 5 Å). The other two co-driven parameters modify the lower and higher limits of the second APNC constraints. The GRID procedure moves estradiol E2 along the binding tunnel in an enzyme (Zhorov and Lin, 2000). Since the lower and upper limits of the APNC constraints change synchronously, the energy minimization increases the distance between the plane and atoms O3 and O17.

 | APNC.L.1 | APNC.H.1 | APNC.L.2 | APNC.H.1
CONSTRAINTS_FIELD | 0. | 0. | 11.2 | 0
Node # |  |  |  |
1 | -5. | -5. | 4.32 | 6.2
2 | -4 | -4. | 5.32 | 7.2
3 | -3. | -3. | 6.32 | 8.2
…. | … | … | … | …
10 | 4. | 4. | 13.32 | 15.2
11 | 5. | 5. | 14.32 | 16.2

APNC for atom O3 has the same lower and upper limits so that at each node, the atom-plane distance is fixed. APNC for atom O17 has different lower and upper limits so that at each node, the atom-plane distance can vary. This allows estradiol long axis to deviate from the tunnel axis. Please see ref. http://www.ncbi.nlm.nih.gov/pubmed/10707028 for more details.

When calculating GRID, the starting point in each node contains GRID-specified driven and co-driven parameters as well as other generalized coordinates. The starting value of latter depends on parameter IAD: if IAD =2 (default), the coordinates correspond to the starting geometry specified in tune file, otherwise coordinates obtained in previous node are inherited in the next node.

Several examples of GRID tasks are available:

- zmm/test/small_molecules/ditmm.scheraga.tsk

- zmm/test/peptides/ala.grid.tsk

- zmm/test/proteins/1iol.transl.tsk


Field RGRID n specifies a Random GRID in which all variables indicated in the field are sampled randomly and simultaneously

Field RGRID n specifies a Random GRID in which all variables indicated in the field are sampled randomly and simultaneously. In the example below, RGRID specifies 100 starting points in which six parameters determining position and orientation of 'Ala. ___1 ' are randomly sampled within respective intervals. The syntax of RGRID has two peculiarities. 1) The last parameter in each line is the upper limit of the random variable rather than a step. 2) Both driven and co-driven parameters are sampled simultaneously to make a random node of the grid. A multidimensional RGRID can be specified to increase number of randomly sampled parameters.

RGRID | 1 |  |  |
100 | 5 | 'Xmol.Ala. ___1 ' | -3. | 3.
 |  | 'Ymol.Ala. ___1 ' | -2. | 8.
 |  | 'Zmol.Ala. ___1 ' | -5. | 5.
 |  | 'Fi_M.Ala. ___1 ' | -60. | 60.
 |  | 'Ps_M.Ala. ___1 ' | -20. | 20.
 |  | 'Te_M.Ala. ___1 ' | -3. | 3.
END |  |  |  |

If a driven or co-driven parameter in the fields GRID or RGRID is a constraint limit, the constraint should be defined earlier in the tune file. In other words, the field CONSTRAINTS should appear before the field GRID/RGRID.

Example: zmm\Test\Peptides\enk.mcm_grid.tsk


Command HGRID n specifies a Hot Grid in which random values are assigned to ALL torsions at each node of the grid

Field

HGRID N
variables to sample
………………….
END

instructs zs to submit a Hot Grid in which random starting values are assigned to variables specified in the HGRID field. Parameter N specifies number of nodes. Depending on the parameter KOPT, the system can be energy-estimated, energy-minimized or MC-minimized.

The following commands are possible in the field

Command | Variables to sample
EULER [label of first residue [label of last residue]] | Euler angles
TRANSL [label of first residue [label of last residue]] | Translational degrees
TORS [label of first residue [label of last residue]] | Torsional angles
SHELL_S <residue label> [Shell thickness] | torsions in a Static Shell around the residue. The shell is formed by tune and does not change in Hot Grid. THARL is a default shell thickness
SHELL_D <residue label> [Shell thickness] | torsions in a Dynamic Shell around the residue. The shell is redefined at each node of Hot Grid. THARL is a default shell thickness
SIDE_CH [label of first residue [label of last residue]] | Side Chains
RESIDUE [label of first residue [label of last residue]] | all variables in residue (except bond angles and U-torsions)
BACKBONE [first residue label [last residue label]] | Fi, Psi, and Omega
FI_PSI [label of first residue [label of last residue]] | Fi and Psi
ALL | all variables (except bond angles, bond lengths, and U-torsions)
LIBRARY <ligand label> <ligand stack filename > | Takes pre-computed library of M ligand conformers. For each conformer runs N nodes, randomly sampling variables specified below the "LIBRARY" line. A total of M*N cycles are run, where N is parameter of the HGRID line. If HGRID is interrupted, less than N conformers from the LIBRARY are sampled.
LIBRARY <ligand label> <ion label> <ligand-ion complexes stack filename > | Stack contains GENCs of pre-computed ligand-ion complexes. Ion label (e.g. ‘E___2 ‘) must be one residue higher that the ligand label (e.g. ‘E___1‘).
SHA <label of first residue> <label of last residue> | SHift Alpha carbons

Random values for the starting point are specified in the following intervals:

- Torsional angles: –180 to 180º
- Euler angles of waters: –180 to 180º
- Euler angles of ligands: previous-point angle ± HGLED
- Euler angles for a chain root or mobile residue: previous-point angle ± HGRED
- Translation of a ligands and waters: previous-point coordinate ± HGLTD
- Translation of chain roots or mobile residue: previous-point coordinate ± HGRTD

In combination with MCM method, HGRID effectively searches global minimum of ligands and small peptides.

Examples:
~zmm\Test\Peptides\enk.hgrid.tsk
~ zmm\Test\Long\kvap_s.hgrid.tsk


START field specifies the starting geometry.

Commands may contain residue labels m and n.

Positive torsion = counter-clockwise rotation of the nearest bond


Centroid Algorithm

Centroids

By default, position and orientation of a free molecule (ligand) in the global system of coordinates is specified by position of the ligand’s root atom and Euler angles of the local coordinate system defined by the root atom and two atoms bonded to it. While such generalized coordinates are efficient in energy minimizations, they may be not convenient for systematic exploration of possible orientations of the ligand relative to the protein. Some ligands, e.g. steroids and alpha-helical peptides have ellipsoidal shape. Interactions of such ligands with other molecules may be explored systematically by building energy-minimized or MC-minimized energy profiles against translation of the ligand along a specified axis or/and rotation around the axis. In other words, we need an new local coordinate system of the ligand with user-specified origin and direction of axes. Such system is called a centroid. Often (but not necessarily) the centroid’s origin is close to the center of the ligand.

File zmm\test\proteins\1iol.centroid.tsk exemplifies centroid of a ligand, estradiol ‘ E2 . _400 ‘. The command in the START field

CENTROID ' O3 .E2. _400 ' ' O17.E2. _400 ' ' C17.E2. _400 '

specifies the centroid coordinate system (red arrows) that start at O3. The axis ZL points towards O17. Atom C17 is in plane XL-O-ZL . Position of the centroid’s origin O3 in the global system of coordinates (black arrows) is given by centroid origin coordinates x,y, and z (x=y= z=0 in this example). Euler angles j and ψ specify orientation of axis ZL, and Euler angle q specifies rotation of the ligand around axis ZL. Starting values of x0, y0, z0, j0, ψ0, and q0 are computed by ZMM using the root-atom coordinated of E2 and information in the command-line CENTROID. When x0, y0, z0, j0, ψ0, and q0 , are zero, the ligand atom O3 is in the global origin, atom O17 is on the global axis Z, and atom C17 is in the global plane X-O-Z.

The centroid axes are fixed relative to the three root atoms of the ligand (which may not coincide with the centroid origin). If all generalized coordinates of the ligand are kept constant, variation of q would result in the ligand rotation around line O17-C17 (see thin image of E2 in different orientation). When the ligand is not rigid, atom O17 would deviate from axis ZL. This deviation but may be large in flexible ligand. Importantly, while centroid coordinates are treated as generalized coordinates in the CENTROID-related jobs, the stack files delivered by these jobs show generalized coordinates for the root atom of the ligand. This allows importing the stacks files by the jobs, in which CENTROID is not specified.

The user cannot assign x0, y0, z0, j0, ψ0, and q0 , but can specify the algorithm of modification of x, y, z, j, ψ, and q in the GRID field, e.g.

GRID 1

18 0 'Te_M.E2. _400 ' -180. 20.

END GRID

This field builds one-dimensional grid of 19 nodes with E2’s angle q (Te_M) increasing from -180° with the step of 20°. When grid imposes specific value of q, it does not allow it to change during energy minimization. However, other rigid-body coordinates x, y, z, j, ψ, as well as internal coordinates of E2 can move. It may result in significant reorientation of the ligand. The user may freeze all Euler angles (FIXE constraint), all translational degrees of freedom (FIXT), torsions (FIXO) or all degrees of freedom of given residue (FIXR). In the latter case, E2 rotates exactly around line O3-O17.


The commands below allow to take (import) geometry from another file

These commands import geometry from another file

Category | Command | Test | Tune action
TAKE | STACK 'filename' [m [n]] | ala.take* | ZS reads starting points from a stack that contains results of previous computations The starting points may be used for stream energy minimizations, MC minimizations, or GRID calculations. Syntax: STACK 'filename' [m [n ]] Where m and n are numbers of the first and last MECs in the stack to be read. The default values: m = 1; n = <number of MECs in the stack>. The STACK-file may reside in the upper directories. The stack file may have entries in generalized or Cartesian coordinates. In the latter case, the filename should have extension "pdb".
TAKE | MEC 'stackname' [k] | Proteins/1iol.lri.tsk | Takes k-th MEC from the stack-file stackname, which may be in current or upper directories. If k is omitted, the command takes MEC #1.
TAKE | PDB 'structure.pdb' |  | Takes structure given by pdb coordinates. Residues, which are mismatched between files molname.pep and structure.pdb, are ignored.
TAKE | H2O 'WAT_500.pdb' [dx dy dz] | ~ZMM\Test\Proteins\ safe\DEKA_500.ed.tsk | Hydrates protein with explicit waters Developed May 2020 to model ion permeation thorough Nav outer pore. Currently a sphere of 500 waters and a box of 1487 waters are available (~ZMM\Test\safe\WAT_500.pdb and ~ZMM\Test\safe\WAT_box.pdb). Optional dx dy dz can be specified to translate starting positions of all waters.
TAKE | START 'filename' [k] | Mecyh.pass | Specifies starting point for PASS calculation
TAKE | FINISH 'filename' [k] | Mecyh.pass | Specifies terminal point for PASS calculation
TAKE | TAR 'filename' [m [n]] |  | Takes torsions for residues m-n from 'filename'. If filename contains GENC TAR lines, the command reads this line. If filename contains stack or genc, the command extracts corresponding torsions.
TAKE | TARB 'filename' [m [n]] |  |
TAKE | TARS 'filename' [m [n]] |  |
TAKE | FRIM 'filename' [m [n]] |  |
TAKE | FRIA 'filename' [m [n]] |  |
TAKE | BAR 'filename' [m [n]] |  |
TAKE | BLR 'filename' [m [n]] |  |


These commands explicitly specify generalized coordinates

Category

Command

Test

Tune action

GENC

TAR n rn Fi Psi Chi1 Chi2.. Omega

Kcsa

This statement specifies Torsion Angles (radian) in a Residue n with the name rn. If the residue is amino acid, the order of torsions is Fi, Psi, Chi1, Chi2, ...Omega. Otherwise, the order of torsions is residue-specific. In case of homology modeling, TAR statement may be taken from a template and have residue name not matching that in the target model. In such a case, backbone torsions and those side-chain torsions that exist in both template and target are transferred to the target. If the target has more side-chain torsions than template, the side-chain torsions most remote from the C alpha atom are assigned value of 180 degrees. If the target has less side-chain torsions than template, the template side-chain torsions most remote from C alpha atom are ignored. If the target is proline and template is not, side-chain torsion in the target proline are assigned value 0 to ensure the ring closing. The special case in homology modeling The statement has rigid format: (a3,3x,i5,1x,a4,(10f7.3)). GENCs may be delivered in this format by zs tuned with control parameter KPGEN 4. See templates

GENC

FRIM

Kcsa

Free Molecules. Two possible formats are exemplified below. The first one (fixed format) imports ZMM-generated coordinates that are delivered with “KPGEN 2”. The second one is a free format to put a ligand’s root in a specific position x,y,z:
GENC FRIM  ' _387 ' WAT    4.805  24.977  54.930  -0.349   0.349   1.047
GENC FRIM  ‘E___1 ‘   x  y z

GENC

FRIA

Kcsa

Free Atoms. Two possible formats are exemplified below. The first one (fixed format) imports ZMM-generated coordinates that are delivered with “KPGEN 2”. The second one is a free format to put an ion in a specific position x,y,z:
GENC FRIA  ' _302 '  CA   -6.994  33.831  45.676
GENC FRIA ‘E___2 ‘  x  y  z

GENC

BAR

Bond Angles specified by residues

GENC

BLR

Bond Lengths specified by residues

GENC

MOVE m

Moves root atom of a free molecule away from the rest of the system by assigning 200 Å to its translational Eigen GENCs. This helps estimate energy of interaction between protein subunits, ligand-receptor energy, etc. Example: MOVE ' CA .ASP.2001'

GENC

PUT A1 A2

Put ion/water A1 next to atom A2, e.g., PUT 'CA++.ion .113' 'ATA .axis.114'. ZS finds an empty space next to atom A2 to accommodate atom A1

GENC

SRWE

Ice

Set Random Water Euler angles

GENC

ICE n m [rnd]

Orients water residues N through M in a slab of ice to set a regular ice structure. If the slab is too thin, ZS may run in cycle forever. In this case, abort ZS and try to change RND, the parameter that affects a random choice of the A-type water in the subroutine ICE and thus may change orientation of hydrogens at the ice faces

GENC

IDENT

Ala

Identifier of the first MEC should follow, e.g. TTGT..

GENC

TORS
torsname m

Assign m degrees to a torsion angle, e.g. TORS 'Chi1.LEU.113' -65

GENC

DTORS torsname m

Add m (degrees) to a torsion angle, e.g. DTORS 'Chi1.LEU.113' -65.
Rotates Chi1 65 degrees clockwise


START field specifies the starting geometry

Clone and other commands

Command

Test

Tune action

CLONE_B

Clone backbone torsions. For example, command
CLONE_B 10 ' 4248 ' ' 1248 '
copies backbone torsions of 10 residues, starting from ' 4248 ' to residues starting from ' 1248 '

TORA [n1 [n2]]

NTDF or (n2-n1)+1 torsions (degrees) should follow (f5.0

TORZ

FIRST ATOM

Coordinates of the first atom should follow

SET ANGLE

Mecyh.t0

Reads angles (degree, 7f10.3) for Additional MECs

IDCOL

Dmce.t0

Reads Identifiers for the additional MECs

MCT I

i Main Chain Torsions (degree, 15f5.0) should follow


Backbone Regular Conformarions

Backbone Conformations

Category | Command | Test | Tune action
CHAIN | PEPTA [m [n]] PEPTC [m [n]] PEPTD [m [n]] PEPTE [m [n]] PEPTF [m [n]] PEPTG [m [n]] | Peptall.t0 | Assigns backbone and side-chain torsion angles to residues m - n depending on the residue type and on the last character of the command (A, C, D, E, F, and G) that specify low-energy areas at the Ramachandran plot (Zimmerman et al., 1977). The file conres.dat in the ZMM directory contains low-energy conformations for each of the 20 naturally occurring residues. If m and n are omitted, the backbones of all residues are affected.
CHAIN | LAHEL [m [n]] | Peptall.t0 | Assigns to residues m - n backbone torsions of the ideal left-handed alpha-helix (Fi = 57° Psi = 47° )
CHAIN | RAHEL [m [n]] | Peptall.t0 | Assigns to residues m ¸ n backbone torsions of the ideal right-handed alpha-helix (Fi = -57° ; Psi = - 47° )
CHAIN | PIHEL [m [n]] | Peptall.t0 | Assigns to residues m - n backbone torsions of the ideal right-handed pi-helix (Fi = -57° ; Psi = - 70° )
CHAIN | HE310 [m [n]] | Peptall.t0 | Assigns to residues m - n backbone torsions of the ideal right-handed 310-helix (Fi = - 75.5° ; Psi = - 4.5° )
CHAIN | BETAS [m [n]] | Peptall.t0 | Assigns to residues m - n backbone torsions of the ideal beta-sheet (Fi = -139°; Psi = 135° )
CHAIN | TURN k n | Peptall.t0 | Makes the k-type turn starting from residue n by assigning specific values to the backbone torsions Fi and Psi in residues Rn+1 and Rn+2

Backbone turns

Turn designation |  | Residue N |  | Residue N+1
General | ZMM | Fi | Psi | Fi | Psi
Beta 1 | TURN 1 | -60 | -30 | -90 | 0
Beta 2 | TURN 2 | -60 | 120 | 80 | 0
Beta 3 | TURN 3 | -60 | -30 | -60 | -30
Beta 1' | TURN 4 | 60 | 30 | 90 | 0
Beta 2' | TURN 5 | 60 | -120 | -80 | 0
Beta 3' | TURN 6 | 60 | 30 | 60 | 30


RESIDUE SETTINGS field contains statements that control

Sampling strategy in the MCM trajectory
Atoms/resides to be excluded from energy calculation
Degrees of freedom to be fixed in energy minimizations
Residues whose contribution in the total energy may be partitioned and analyzed


Sampling Strategy

Sampling Strategy. For example, a probability of conformational changes of the residues at the ligand-binding site may be increased. The statements generally consist of the control word and residue labels m and n. If residue n is not specified, the control applies to residue m only. If neither m nor n is specified, the command applies to all residues of the system.

Statement | Test (example) | Action
 |  | Statements NOR* instruct ZS NOT to sample specific R esidue-related variables shown below
SCENT m | 1iol.transl.tsk (SCENT ' _400 ') | Sampling Center (See also parameter THARL )
NORA | Ice | A ll degrees of freedom
NORT [m [n]] |  | T orsions in residues m-n
NORB [m [n]] |  | B ackbone in residues m-n
NORS [m [n]] |  | S ide chains in residues m-n
NORR [m [n]] |  | R oot atom in free R esidues m-n
NORP [m [n]] |  | P rolines in residues m-n
NORE [m [n]] |  | E uler angles in free molecules m-n
NORC [m [n]] |  | C artesian Coordinates in free molecules m-n
 |  | Statements RD* instruct ZS to r an d omize specific variables
RDR [m [n]] |  | all degrees in R esidues m-n
RDW [m [n]] | Ice | all degrees of freedom in W aters m-n
RDWE [m [n]] | Ice | W aters' E uler Angles
RDRM [m [n]] |  | R esidues' M ain chain
RDRS [m [n]] |  | R esidues' S ide chain
RDT [m [n]] |  | all T ranslations of free molecules with root residues m-n
RDTX [m [n]] |  | T ranslation X of free molecules with root residues m-n
RDTY [m [n]] |  | T ranslation Y of free molecules with root residues m-n
RDTZ [m [n]] |  | T ranslation Z of free molecules with root residues m-n
RDE [m [n]] |  | All E uler Angles of free molecules with root residues m-n
RDEF [m [n]] |  | E uler Angles F i of free molecules with root residues m-n
RDEP [m [n]] |  | E uler Angles P si of free molecules with root residues m-n
RDET [m [n]] |  | E uler Angles T eta of free molecules with root residues m-n


Atoms, residues, and degrees of freedom to be excluded from energy calculation

Atoms and residues to be excluded from energy calculations

Statement | Example | Tune action
AEXC <atom_name> | AEXC ' CA .ALA.15' | A tom to Exc lude from energy calculations.
AINC <atom_name> | AINC ' CA .ALA.15' | A tom to Inc lude in energy calculations.
AEUP < atom_name> | AEUP ‘ O1 .J2.E___1 ‘ | A toms to E xclude UP root from the given atom. Excluded atoms are not shown in pdb.
AIUP < atom_name> | AIUP ‘ O1 .J2.E___1 ‘ | A toms to I nclude UP root from the given atom. Excluded atoms are not shown in pdb.
REUB [<residue label>] [<residue label>] | REUB ‘A___1 ‘ ‘A__10 ‘ | R esidue sidechains (except Pro) are Ex cluded UP from C B. Excluded atoms are not shown in pdb.
REX [<residue label>] [<residue label>] | REX ‘A__27 ‘ | R esidue(s) are Ex cludes from energy calculations.
REXB [<residue label>] [<residue label>] | REXB ‘A__27 ‘ | R esidues to Ex clude B ackbone atoms from energy calculations.
REXS [<residue label>] [<residue label>] | REXS ‘A__27 ‘ | R esidue to Ex clude S idechain atoms from energy calculations.
REIN <residue label> [<residue label>] | REX REIN ‘A__27 ‘ ‘A__35’ | Re sidue(s) to in clude in energy calculations. In this example, energy is calculated only for residues A__27 to A__35
PROIN <residue label> [<residue label>] | REX PROIN | Pro lines to In clude in energy calculations. Commands REX and PROIN exclude everything except prolines. Can be used to optimize geometry of prolines in homology modeling
REDSIN <residue label> <residue label> <flexible shell thickness> <fixed shell thickness> | REX FIXR REDSIN ' ___9 ' ' ___9 ' 7. 10. FIXMC ~\Test\Proteins\safe\1IOL.DS.tsk | Re sidue in D ouble S hell to In clude. In this example, REX & FIXR nullify the model. REDSIN includes all residues in the fixed shell within 10 Å from the ligand ‘ ___9 ‘ and flexible residues within 7 Å from the ligand. The ligand label must be specified twice due to a technical reason. FIXMC precludes main chain deviations of fixed residues, which are downstream from the flexible residues and are not specified as "m" residues in the .pep file When double shell job is completed, generalized coordinates of the full-fledged model are delivered to *.stack and *.mcm files. These can be used as the starting point to visualize results or continue optimization of the full-fledged model.

Variables (generalized coordinates) and Atoms to be exclude from similarity analysis. The following commands help reduce the size of stack files

Statement | Example | Tune action
RESA <residue label> [<residue label>] | RESA ‘ ___1 ’ ‘ ___2 ’ | R esidue(s) in which all variables in are E xcluded from the S imilarity A nalysis when MECs are merged into stack files. \test\Peptides\enk.hgrid.tsk
VESA <variable name> | VESA ‘Chi1.MET . ___5 ‘ | V ariable E xcluded from S imilarity A nalysis when merging conformers into stack files. \test\Peptides\enk.hgrid.tsk
AESA [<atom name>] AESA <residue_label > [<residue_label >] | AESA ‘ C1 .VER. ___1 ’ AESA ‘ ___1 ‘ AESA | A toms to E xclude from S imilarity A nalysis by Ligand’s RMSD (KLEC 5)
AISA [<atom name>] AISA <residue_label > [<residue_label >] | AISA AISA ‘ C1 .VER. ___1 ’ AISA ‘ ___1 ‘ | A toms to Include in S imilarity A nalysis by Ligand’s RMSD (KLEC 5)


Partition Energy

Command | Test | Description
PART m [n] | 1iol.lri.tsk | Partition energy of residues m through n. This command may be used to estimate the ligand-receptor energy
SEGM lb1 lb2 lb3 lb4 | Proteins\1IOL.ssi.tsk | Partition energy of interactions between two segments. Segment 1 is specified by labels of the first (lb1) and end (lb2) residues. Segment 2 is specified by labels of the first (lb3) and end (lb4) residues.
SEG1 lb1 [lb2] ……. SEG2 lb3 [lb4] | Proteins\1bra.patch_segm.tsk | Partition energy of interactions between two patched segments. Specified by [multiple] lines SEG1 and SEG2.


Fix/Relax degrees of freedom

Statement a | Test | Tune action
FIXR [m [n]] | 1iol.rot* | FIX all degrees of freedom in R esidues m-n
FIXPRO [m [n]] |  | FIX all degrees of freedom in Prolines
RELR [m [n]] |  | REL AX all degrees of freedom in R esidues m-n
RELPRO [m [n]] |  | REL AX all degrees of freedom in Prolines
FIXO [m [n]] |  | FIX torsi o ns in residues m-n
RELO [m [n]] |  | Rel ax t o rsions in residues m-n
FIXTA <tn> |  | Fix a T orsional A ngle, e.g. FIXTA ‘C1C2.DLMT.E___1 ‘
RELTA <tn> |  | Rel ax a T orsional A ngle, e.g. RELTA ‘C1C2.DLMT.E___1 ‘
FIXMC [m [n]] |  | FIX Main Chain in Residues m-n
RELMC [m [n]] |  | RELAX Main Chain in Residues m-n
FIXP [m [n]] | 1iol.rot* | Fix translations and orientations of Particles (root residues) m-n
RELP [m [n]] |  | Relax translations and orientations of Particles (root residues) m-n
FIXX [m [n]] |  | Fix X-coordinates of free particles (root residues) m-n
FIXY [m [n]] |  | Fix Y-coordinates of free particles (root residues) m-n
FIXZ [m [n]] |  | Fix Z-coordinates of free particles (root residues) m-n
FIXT [m [n]] |  | Fix translational degrees in free particles whose root residues are m-n
FIXE [m [n]] |  | Fix Euler degrees in free particles whose root residues are m-n

a m, n - labels of residues; tn – Torsion angle Name


CONSTRAINTS

This field specifies objects (atoms, residues, generalized coordinates, helices) to be constrained. Each line in the field specifies names of atoms (variables) of the constraint, low (DL) and high (DH) limits of the flat-bottom constraint (Brooks et al., 1985), and force constant F. If DL = DH or DH = 0., the parabolic constraint is imposed. The constraints may be specified in any order. Names of atoms and generalized coordinates are enclosed in quotation marks. Parameters DL, DH, and F are real numbers. The following constraint types are currently available.


Atom-Atom Constraints

Constraint a | Test | Action
AA A1 A2 DL DH F | ggg.mcm | Distance constrain between atoms A1 and A2 'DIST' A1 A2 DL DH F
AAT A1 A2 DL DH F |  | A tom A1 to Atom A2 of the Template
AAX A1 A2 DL DH F |  | A tom A1 to A tom A2 in the X-ray structure whose name should be specified in TEMPL
AAXM n A1 A2 DL DH F |  | AAX M ultiple. Imposes “n” constrains between same-name atoms in residues i, i+1, …i+n-1 and j, j+1, …j+n-1, where is i and j are residue numbers of atoms A1 and A2, respectively.
AAC A1 xyz DL DH F | KcsA.z_ribom.tsk | Atom A1 to Atom Coordinates xyz
AAS A1 A2 DL DH F |  | Atom A1 to Atom A2 Stochastically activated constraint (restrain)
AAST |  |
AASC |  |
CNL m n |  | C-end to N-end Link. CNH- and NH2-capped residues are linked with excluding NC, 2HC atoms. High energy is expected because of 1,2 and 1,3 interactions

Multiple Atom-Atom Constraints

Constraint a | Test | Action
AATM n A1 A2 DL DH F |  | A tom A1 to A tom A2 of the T emplate M ultiple. n, number of consecutive residues in the model chain to be constrained to respective template chain
LGSC lb1 lb2 DL DH F | AFS.dmct.tsk | L igand – S idechain. Attracts a ligand to a residue. Finds a pair closest atoms between a ligand (lb1) and a residue side chain (lb2) and imposes a distance constraint between these atoms. May 2012.
LASC A lb DL DH F |  | L igand A tom – S ide Chain. Attracts an atom in a ligand to a residue. For the ligand atom (A) finds the closest atom in the side chain (lb) and imposes distance constraints between the two atoms. July 2018. Example: LASC ' H24.ETO.L___1 ' 'A5528 ' 2. 3. 100.
RRD lb1 lb2 DL DH F | AFS.dmct.tsk | R esidue-R esidue D istance. At the beginning of each energy minimization, the closest pair of atoms in the specified residues is selected and the distance constraint is imposed to them.
RSD lb1 lb2 DL DH F | AFS.dmct.tsk | R esidue-S idechain D istance. At the beginning of each energy minimization, the closest pair of atoms in residue lb1 and sidechains of residue lb2 is selected and the distance constraint is imposed to them.
DIPT lb1 lb2 |  | Dipeptide. Targets N-end of lb2 to C-end of lb1. Helpful when modeling indels, but mobile residues do not work. A user needs to add commands AEXC to exclude C- and N-capping atoms as well as C_lb1 or N_lb2 atoms to avoid their clash
SSD lb1 lb2 DL DH F | AFS.dmct.tsk | S idechain-S idechains D istance. At the beginning of each energy minimization, the closest pair of atoms in the sidechains of the specified residues is selected and the distance constraint is imposed to them.
SGSG lb1 lb2 lb3 lb4 DL DH F |  | Segment-Segment D istance. At the beginning of each energy minimization, the closest pair of atoms in backbones of segments lb1- lb2 and lb3- lb3 is selected and the distance constraint is imposed between the atoms. Made Feb-2017 to close Cav1.1-based Cav1.2 model and transmit the AID helix motion to beta-subunit. The AID helix was RHHB-constrained and two beta subunit helices were pinned.
SSDM n lb1 lb2 DL DH F | Peptides\deca.SSDM.tsk (Imposes stacking interactions) | S idechain-S idechains D istance M ultiple. At the beginning of each energy minimization, “n” closest pairs of non-hydrogen atoms in the specified sidechains are selected and the distance constraint is imposed to them. Each atom of a residue is selected just once, by having the closest separation from another residue.
MCAD [lb1 lb2 ] [Δd F] |  | M atrix of C-Alpha Distances. A flat-bottom parabolic penalty function is imposed for deviation of each element of the matrix beyond the lower limit dij - Δd and the upper limit dij + Δd, where dij is a distance between atoms Cαi and Cαj in the template (j<i). Residue labels lb1 and lb2 define limits of index i. Default values: lb1, label of first amino acid in the system; lb2, label of last amino acid in the system; Δd = 1 Å; F =10 kcal mol-1 Å-1.
RHHB m n [D F] | polyg.mcm_zipper | R estraints alpha-Helical H-Bonds in residues m-n. Residue m should have the proton donor to make H-bond with the acceptor in residue m-4. Default values for D istance NH---O and F orce constants are 2.0 Å and F=100 kcal/mol, respectively. Example: line RHHB ‘A___5’ ‘A__20’ imposes constraints in alpha-helical segment between residues ‘A___1 ‘ and ‘A__20’.
ZIPP n 5 12 | polyg.mcm_zipper | Imposing a ZIPPer of n H-bonds between backbone atoms in residues 5¸ 12: 5_H...O_12, 5_O...H_12, 7_H...O_10, 7_O...H_10 ,...

a A1 and A2 are 16-character atom names

DL and DH are lower and High distance limits

F is a Force constant, default 100 kcal mol-1 Å-2

lb1 and lb2 are residue labels


Atom-Line

Constraint | Test in zmm/test | Action
ALT A1 A2 A3 DL DH F | Proteins/1iol.rot* | A tom A1 to the Line passing via Template atoms A2, and A3
ALC A1 xyz2 xyz3 DL DH F | Proteins/ KcsA.z_ribom.tsk | A tom A1 to the Line passing via atoms A2, and A3 specified by Cartesian coordinates
AN A1 A2 A3 A4 DL DH F |  | Atom A1 to the Normal of the plane A2, A3, A4 passing via A2


Atom-Plane

Constraint | zmm/test/ | Action
APNT A1 Ab Ac DL DH F | Proteins/1iol.rot* | A tom to the Plane Normal to Template line B --> C. Constraining A between planes P1 and P2, which are normal to and distant from B by dl and dh, respectively (dl < dh). dl and dh may be positive (P1 and P2 are between B and C) or negative.
APNC A1 xyzb xyzc DL DH F | Proteins/1iol.tran* | APN with Atoms B and C specified by Coordinates
APNZ A1 xyzb xyzc DL DH F | Long\ A1_NA.1a.tsk A1_NA.refine_grid_sf.tsk | Feb-2016: Made to refine grid-file of niflumic acid pulled along the Z-axis, through the pore of glycine receptor using constraint APNC ' N1 .NIFL.F___1 ' x1 y1 z1 x2 y2 z2 0. 0. 100. File .tsk for the refining serial-farm job should have APNZ in place of APNC. For each serial-farm job APNZ attracts atom N1 to the Z-level where the atom occurs in the starting point. NSERF must be equal to # of nodes in the grid file.
APAT A1 A2 A3 A4 DL DH F |  | A tom A1 to the Plane of Atoms A2, A3, and A4 in the Template


Generalized-Coordinates Constraints

Generalized-coordinate constraints

See also KROM - Key to Restrain all Omega Torsions

Constraint | ZMM/Test/ |
DMCT [residue1 [residue2]] [DG [F]] | Proteins/ 1afs.dmct | D eviation of the M ain C hain T orsions. Limits generalized coordinate to deviate from the starting conformation not more than DG. The value of DG is given in degrees.
DT [residue1 [residue2]] [DG [F]] | Proteins/ 1afs.dmct | D eviation of T orsions. Limits generalized coordinate to deviate from the general starting conformation (defined in START field of .tsk file) no more than DG. The value of DG is given in degrees.
GENC genc_name GL GH F | Small/ h2o2.trans.tsk | Limits GEN eralized C oordinate whose name is specified in genc_name between the L ower limit GL and the H igher limit GH. The value of DG is given in degrees for rotors and in Å for translations. F is the F orce constant. Example: GENC 'Fi.Ala.124' 40. 80. 100. constrains the torsion between 40 and 80 degrees.
DGEN genc_name DG F | Proteins/ 1iol.centroid.tsk | Maximal D eviation of GEN C. Limits generalized coordinate to deviate from the seeded starting conformation (current start generated in HGRID) not more than DG. The value of DG is given in degrees for rotors and in Å for translations. To limit deviations of the driven and co-driven parameters in GRID, use constraint DDCG below.
DDCG genc_name DG F |  | Maximal D eviation of D riven or C o-driven G eneralized coordinate from the value, assigned by GRID for the given node. DDCG constraints must be specified AFTER the GRID field. The value of DG is given in degrees for rotors and in Å for translations.
TOR A1 A2 A3 A4 A5 DL DH F | Small/ice | Torsion. Imposes a range of DL - DH (degrees) to a virtual torsion A1-A3-A4-A5 by applying pair of forces to atoms A1 and A2 equidistant from the axis A3-A4. If A1 and A2 are connected by a flexible chain, TOR deforms the chain. This problem can be solved by using a dummy molecule TORQ (H1)(H2)C-HA whose bond C-HA is constrained HA to the axis of rotation, and atoms H1 and H2 bear forces imposing a momentum. Test: /test/ice/id.t0 in which TORQ rotates an alpha-helix above a plane H2 H1 of ice. Two atom-line constraints (AL) and one atom-plane constraints AP are used to impose the rotation, whereas 8 distance constraints are used to impose dummy atoms at the helix axis.
TORT A1 A2 A3 A4 A5 DL DH F | Proteins/ 1iol.rot* | Works as 'TOR', but the forces applied to atoms A1, A2 lie in the plane normal to the axis of ligand's rotation A3 - A4 drawn via Template atoms. TORT is not expected to translate the ligand along the axis.


Line-Helix

Constraint | Test | Action
CLHB n (LHB) |  | Line - Helix Beginning. Imposes a dummy atom to a line between two given points. An atom name should be CA atom in the helix beginning.
CLHE n (LHE) |  | Line - Helix End. Each constraint forces a dummy atom to a line between two given points. An atom name should be CA atom in the helix end.
CPHB n (PHB) |  | Plane - Helix Beginning. Each constraint forces a dummy atom to a plane normal to a line between two given points and distanced "d" A away from the first point in the direction of the second point. An atom name should be CA atom in the helix beginning.
CPHE n (PHE) |  | Plane - Helix End. Each constraint forces a dummy atom to a plane normal to a line between two given points and distanced "d" A away from the first point in the direction of the second point. An atom name should be CA atom in the helix end.


Residue-Target

Residue to target constraints

Constraint a | Test | Action
RA residue_label atom_name dL dH [F] | Proteins\1iol.constraints.tsk | Distance constrains between Residue and Atom. Every atom of the residue is constrained to atom
RAT residue_label atom_name dL dH [F] | Proteins\1iol.constraints.tsk | Distance constraints between Residue and Atom in Template. Every atom of the residue is constrained to atom
RAC A1 xyz DL DH F |  | Atom A1 to Atom Coordinates xyz
RLT residue_label A1 A2 DL DH F |  | R esidue to the Line passing via Template atoms A2, and A3
RLC residue_label xyz2 xyz3 dL dH [F] | Proteins\1iol.constraints.tsk | R esidue to the Line passing via atoms A1, and A2 specified by Cartesian coordinates
RN residue_label A1 A2 A2 DL DH F |  | R esidue to the Normal of the plane A2, A3, A4 passing via A2
RPNT residue_label A1 A2 DL DH F |  | R esidue to the Plane Normal to Template line B --> C. Constraining residue between planes P1 and P2, which are normal to and distant from B by dl and dh, respectively (dl < dh). dl and dh may be positive (P1 and P2 are between B and C) or negative.
RPNC residue_label xyzb xyzc DL DH F | Proteins\1iol.constraints.tsk | R esidue to the Plane Normal to line specified by Cartesian coordinates of points B --> C. Constraining residue between planes P1 and P2, which are normal to and distant from B by dl and dh, respectively (dl < dh). dl and dh may be positive (P1 and P2 are between B and C) or negative.
RPAT residue_label A1 A2 A3 DL DH F |  | R esidue to the Plane of Atoms A1, A2, and A4 in the Template

a A1 and A2 are 16-character atom names

DL and DH are lower and High distance limits

F is a Force constant, default 100 kcal/(mol Å)


Pins

PIN* constraints are specified in field CONSTRAINTS of file molname.jobname.tsk. Pins are flat-bottom parabolic penalty functions that affect energy calculations only if file template.pdb is specified in the .pep, .sym, or .tsk file. A pin imposes a penalty for a deviation of an atom by more than D Å from the same-name atom in file template.pdb. Parameters m and n are residue labels. Default parameters: m = <label of the first residue> 1, n = <label of the last residue >, D = 1 Å, F =10 kcal mol-1 Å-2.

Statement | Test | Tune action
TEMPL <template> or TEMPLATE <template> | Proteins/ KcsA_P.relax.tsk | Reads coordinates of atoms from the file template.pdb and uses them to impose constraints PINA, PINW, AAT, etc. The template specified in file .tsk applies only to constraints specified below statement TEMPL and overrides previously specified templates in files .pep, .sym, or the same .tsk file. The same file .tsk may have several statements TEMPL. File template.pdb should be in the current, upper, or in the ZMM directory. File template.pdb can be specified in different forms, e.g. | KcsA | KcsA.pdb | ’KcsA.pdb’ | ”KcsA.pdb” |
PINW [m [n ]] [D[F]] | ice.short_mcm | Pin Waters. Only oxygen atoms are pinned
PINI [m [n ]] [D[F]] |  | Pin Ions
PINA [m [n ]] [D[F]] | proteins/1iol | Pin Cα atoms in amino acids. Example: PINA 1. 100.
PINS [m [n ]] [D[F]] | Proteins/ KcsA_P.shift | PIN Shifted. Randomly shifts template coordinates of specified Cα atom(s) up to SPIN Å so that a Cα atom of the shifted template deviates up to sqrt(3*SPIN) Å from the original template. Parameter D imposes both lower and higher limits for penalty-free deviation of the model Cα atom from the shifted-template Cα atom. The example uses mobile residues, PINA, UNPIN, and PINS to modify backbone geometry protein segments. Made August 2008 to reproduce Ca2+ binding in proteins with modified backbones (Cheng & Zhorov, 2008)
PINB [m [n ]] [D[F]] |  | Pin C beta atoms in amino acids
PINR [m [n ]] [D[F]] |  | Pin all heavy atoms in a Residue (which may be a ligand)
PAGS [m [n ]] [D[F]] | Proteins\ WF201.rotate_ y_Te_MCM.tsk | P in Alpha carbons to Grid Start. Useful when GRID rotates a protein against a target with RotX, RotY, or RotY as driving parameters with the goal of systematic mapping of the energy against driven parameters. During energy optimization, the protein may deviate significantly from the start. DGEN cannot be used to restrain the protein position/orientation because of complex relations between the driving parameters and root atom coordinates/Euler angles. PING prevents large deviations from the node starting geometry.
UNPIN m [n] | Proteins/ KcsA_P.shift | Remove all pins from residues m - n

A polymer chain may consist of rigid and flexible segments (e.g., double-shell models generated by zi). In such chains, the C-terminal CO group in a flexible segment is linked to the NH group of the N-terminal residue of the fixed segment via built-in PINO and PINC operators analogous to PINA, PINB.


Pivots

A pivot defines constraints imposed on a helix. A pivot consist of a vector P and two scalars. P is defined by with origin Op and direction - polar ingles FIp and PSIp.

In ZMM, position and orientation of a free helix (Hf ) is defined by coordinates of its root atom Cαr, which is Cα at the N-end of Hf and Euler angles of a Cartesian system at the triplet N-Cαr-C'.

The free-helix axis Af is a vector drawn between the dummy atoms DN and DC inserted at the centers of triplets of Cα atoms at the N- and C-ends of Hf, respectively. When Cαr is fixed, the C-end of Hf and hence Af moves with the main-chain torsions.

The free helix Hf can be constrained to the pivot P, which is a vector drawn from point Po with coordinates Pox, Poy, Poz, and the direction defined by the polar angles FIp and PSIp.

If a pivot for helix Hf is specified in the PIVOT field, the axis Af is constrained to P by a penalty function EH = CH(rb2 + re2), where CH is the force constant, rb is the distance P -DN, and re is the distance P -DC. To calculate contribution from EH to the energy gradient, force vectors directed normally to P and decreasing with EH are applied to the triplets of Cα atoms.

A rotation of Hf around Af is defined by TETAp , an angle between the Cartesian axis x and the vector DN-Cαr. A displacement of Hf along P id defined by Sf , the distance between Po and -DN.

Variables TETAf and Sf may be sampled in the nested MCM protocol.

PIVOT
m n X Y Z FI PSI TETA S
{pivot 2}
. . . . . . . . . . .
{pivot k}
END PIVOT

This field specifies pivots. The helices constrained to the pivots are allowed to rotate around and shift along the pivots. Each pivot is specified by the following 9 parameters.

m, n: Labels or residues in the helix beginning and end

X, Y, Z: Coordinates of the origin of the pivot

FI: Angle between the global ort k and the pivot P

PSI: angle between global ort i and the pivot projection at the plane xy

TETA: angle defining rotation of the helix around the pivot axis

S: Shift of the helix along the pivot

Pivots were used to predict orientation of alpha helices in mu-opioid receptor (Zhorov and Ananthanarayanan, 1998) using as a template the electron cryomicroscopy structure of rhodopsin. The latter defines an approximate disposition of the helical axes, while coordinates of atoms are unknown. The orientations of residues were predicted in the MCM trajectory in which the helices were allowed to rotate around and shift along the pivots

Importing constraints from a file

TAKE PERM 'fileneme'. Importing all constraints from a file and treating them as permanent
TAKE STOC ' fileneme'. Importing all constraints from a file and treating them as stochastically activated/inactivated


Controlling Parameters

The field PARAMETER controls ZMM performance. The default values of the parameters are specified in the file controls.dat, which is located in the ZMM directory. A modified copy of controls.dat may be also placed in the root of the working branch to specify default controlling parameters for a given molecular system. Entries in this field override the default controlling parameters. Table below shows parameters and their default values. The parameters are organized in categories, frequently tuned parameters being at the top of each category.


GRID and stream control

GRID and stream control. ZMM allows stream energy minimizations from starting points predefined in the tune-file (tasks SETCON, GRID) or/and stochastically generated during the MCM search.

Parameter

Default

Test

Definition

MP_M

0

MP I Parallelization Mode: 0, Serial; 1, GRID Level; 2, GREN level

NSERF

0

Small\
SND_2_K.sf.tsk

Proteins\
1IOL.transl.tsk

N umber of Serial-Farm processors. Command zt molname.jobname.tsk –sf submits NSERF serial jobs to a serial queue. The .tsk file should specify multiple MCM trajectories, in which the starting point for the next trajectory does not depend on results of the preceding trajectory (parameter IAD=2). The .tsk file should contain one of the following words: HGRID, TAKE STACK, RGRID.

When submitting a regular grid to the serial farm, ensure that in the GRID field the product of grid steps of the top driving parameters is equal to NSERF. If the product is too large, use parameter JSERG

JSERF

1

Small\
SND_2_K.grid_sf.tsk

Jobs per SERial-Farm processor. Allows submitting a two-dimensional systematic GRID with number of nodes > NSERF. Number of steps in the second driven parameter should be divisible by JSERF.

FSERF

0.01

Failed-jobs fraction allowed in SERial-Farm calculations. Allows tolerating hardware/software failure at large clusters. Such failure does not affect results of HGRID and its refinement with TAKE STACK command

KRIG

1

K ey to Rigidify the Grid.
0: The driven parameters may deviate from the starting values during EM or MCM.
1: Those driven parameters, which are generalized coordinates, are not allowed to deviate from the starting values during energy minimization. In each grid node, these parameters have fixed values that are assigned by the GRID.

NUSP

0

dmce.t0

Nu mber of Starting Points for stream calculations. If command TAKE STACK is specified in the START field, NUSP is assigned automatically

IAD

2

dmce.t0

I nitial Approximation Dogmatism (the inheritance level). During stream energy minimizations performed by SETCON and GRID, the starting (initial) geometry of a new point may inherit certain generalized coordinates from a previous energy minimization. . Driven variables (GRID) or modified variables (SETCON) always override the inherited parameters.
0: No dogmatism (maximal inheritance). Starting point for the current minimization is formed from the previous point.
1: Intermediate dogmatism. Starting point for the current minimization is formed from the torsion angles defined in the tune file, while other GENCs are inherited from the previous point.
2: Maximal dogmatism. Starting point for the current minimization is formed from the GENC defined in the tune file.


Energy and gradient calculation

Parameter

Default

Test

Definition

KEE

4

K ey for Electrostatic Energy controls the dielectric permittivity ε

0, ignore electrostatic interactions
1, ε is constant: ε =EPS
2, ε is distance-depended: ε = EPS x d, where d is distance between two atoms

3, ε is environment-dependent: ε = ε0 + (1 - s) · (ε 1 - ε0).
s is a screening factor calculated using the modified algorithm of Lazaridis and Karplus (1999); s varies from 0 for a pair of water-exposed atoms to 1 for a pair of protein-buried atoms. ε0 and ε 1 are tunable parameters for dielectric inside and outside the protein, respectively: ε0 = EPS0, ε1 = EPS1.

4, ε is environment- and distance-dependent: ε = d · [ε0 + (1 - s) · (ε 1 - ε0)].
This default value is not recommended with KES > 0 because of
double-counting solvent screening of electrostatic interactions.

EPS

4.

Dielectric constant (permittivity) used with KEE is 1 or 2

EPS0

2.

ε0, the lower limit of dielectric used with KEE is 3 or 4

EPS1

8.

ε1, the upper limit of dielectric used with KEE is 3 or 4

EPS4

1.6

Dielectric constant used with KEE=5 (Rudiment for comparison with earlier Daniel’s experiments)

KES

0

dipent.t1

Energy of Solvation:
0 – not computed. Default value consistent with KEE=4 (Garden & Zhorov, to
be published)
1 Hydration (Hopfinger and Battershell, 1976).
2 Solvation by octanol (Hopfinger and Battershell, 1976).
3 Hydration (Augspurger and Scheraga, 1996). Was used for antifreeze protein
study (Jorov et al., 2004).
4 Hydration (Lazaridis and Karplus, 1999). This option is recommended to be
used with KEE=2

SDHB

0.

S olvent Dependency of H-Bonds. If SDHB > 1. H-bonds for buried pairs of atoms are stronger

CUTOF

8.

peptall.t0

Cut-off distance, where switching function = 0

CUTOFD

10.

Cut-off distance for ion-dipole interactions

KSF

0

KcsA_
symmetry

Key to enable Symmetry Fold. Applicable to multi-subunit polymers, which have rotational symmetry around z-axis. Only subunit with the chain label “A” is modeled. Its images are cloned with KSF-fold symmetry, and chain labels B, C, D… are assigned to the clones. Clones A, B, C, D… are arranged clockwise when viewed from the positive end of the z-axis. All parts that are not cloned should have labels larger than in the last cloned subunit (e.g. K+ ions have labels E or higher).

NICH

‘ ‘

KcsA_
symmetry.
em.tsk

No Image-Chain For Symmetric Models. When this character parameter is assigned a chain label, residues in corresponding chain (e.g. K+ ions in chain E of symmetric KcsA) are not cloned and their images are not generated.

CFC

100.

Constrains Force Constant

FPIN

10.

Force constant of PIN

DPIN

1.

energy-free Deviation from PIN

SPIN

1.

KcsA_P.
shift.tsk

maximal Shift of PINA template (coordinate of alpha-carbon). Used with PINS constraints

Keys to switch individual interactions on (1) and off (0).
See also KEE and KES
ZS sets KEE, KEA, KEB, KEL, and KECN to zero if, respectively, atomic charges, elastic atoms, elastic bonds, loops, and constraints are not specified.

KEA

1

Elastic Atoms bond angles strain energy

KEB

1

Elastic Bonds strain energy

KEN

1

Energy of Nonbonded interactions

KET

1

Energy Torsional

KEL

1

Energy of Loop closing

KECN

1

Energy of Constraints. If no constraints are specified, TUNE automatically sets KECN=0. If constraint are specified, user may set KECN=0 to ignore all constraints

KI13

1

1,3 Interactions

KI14

1

1,4 Interactions

KENER

1

Energy

KPAIR

1

PAIR (atom-atom) interactions

KELIB

0

Librational Entropy

KEHB

1

H-Bonds (Automatic Assignment in TUNE)

ILSB

0

I gnore Ligand-Sidechain Bumps. Works only with KOPT 0. Useful at the seeding stage of ligand docking: preserves seemingly unpromising ligand-binding which may turn promising after energy minimization, where bumps may disappear.

IIRI

0

I gnore Intra-Receptor Interactions. Works only with KOPT 0 and a ligand. Extremely useful at the seeding stage of ligand docking.

Other Parameters controlling energy

DROM

0.1

Penalty-free Deviation (radian) from the starting conformation when Restraining OMega

CNBR

1.

C oefficient for Non-Bonded Repulsions. With CNBR < 1, MCM overcomes energy barriers easier and may predict more structures with favorable attraction energies. The obtained structures would be NOT REALISTIC in terms of energy and geometry, but they can be imported as starting points for subsequent MCM with CNBR=1.

FCPVT

See Pivots control

SWD

1.

Switching Distance for cutoff (switching function = 1 at cutoff - swd)

DSWCN

.2

Distance Switching for Constraints

CCL

300.

Constant for Closing Loops

RRW

2.225

Reduced van der Waals radius of Water (ice-AFP).

REWD

2.

Re move Waters within this Distance from non-water heavy atoms

DEW

0.

Delta E to dehydrate an ice water (ice-AFP)

RHW

1.87

Radius of the Hydration shell of ice Water (ice-AFP)

SEC

1.

Solvation Energy Coefficient (ice-AFP).

AKFIND

0

Key to calculate gradient by Finite Differences

DGC

.0002

Delta GENC (finite differences)

GRISP

.66

Grid Spacing (Angstrom). Scheraga, 1999. Under construction


Energy Minimization

Parameter

Default

Test

Definition

KOPT

1

dmce.t1

K ey to specify the mode of energy OPTimization: 0 No energy minimization; 1 simple energy minimization; 2 MC-minimization of energy.

DEMGR

10.

Test\
Proteins\
KcsA.
z_ribom.
tsk

The local energy minimization process resembles a downhill ski race: slalom at highlands and smooth but not straightforward move towards the lowest point in the valley. Parameter DEMGR controls automatic switching between methods of calculating the decent direction during local energy minimization. The steepest-descent method is most efficient at the initial stages of relaxation, when the energy is high and anti-gradient changes dramatically at each step. Methods that employ history of anti-gradient changes, such as Davidon method or conjugating gradient methods are inefficient at this stage. When the energy change between two iterations becomes relatively small (less than DEMGR), it may indicate that the racer left the highlands and has reached the valley. In this environment, the steepest-descent method becomes inefficient and other method should be employed. The DEMGR parameter works as follows: when the energy change between two iterations dE < DEMGR, the energy-Minimization protocol switches from the Gradient to the conjugated-gradient or Davidon method. The protocol returns to the gradient method if dE > DEMGR.

KTSM

0

dmce.t1

Key for two-step EM.
1 local optimizations are performed it two steps, the first step with the fixed bond angles, bond lengths and backbone torsions, and the second step with these generalized coordinated relaxed.
2 reduce van der Walls radii while MCM imposing ligand in the binding site with the help of constraints.

STIN

.1

Step Initial (radian) for EM

STMAX

1.

dipent.t1

Step Maximal (radian) during EM

ILUP

50

peptall.t0

Interaction List Updating Periodicity.

KNR

0

Key to use Newton-Raphson EM (rudiment?)

KPVT

see MCM

KROM

0

Test/
Proteins/
1afs.krom2

K ey to Restrain OMega torsions:
0, do not restrain
1, Restrain to start
2, Restrain to template
3, Restrain to 0/180 degrees, whichever is closer to the start

DROM

0.1

“

penalty-free Deviation (radian) for Restraining OMega torsions

FCROM

100.

“

F orce Constant for Restraining OMega torsions

Termination of energy minimization

Parameter | Default | Test | Definition
KIAR | 0 | ala.tn | Key for Initial Approximation Region control. 0 No control 1 If during EM at least one GENC deviates from the starting-point value by more than DTAM, the EM is terminated with the "Outstart" diagnostics
ALO | .1 | ala93.tn | Accuracy of Local Optimization.
DTAM | 1.05 |  | Deviation of a Torsion Maximal from the starting point. If exceeded and KIAR> 0 EM is terminated with "Outstart" diagnostics
LIMIT | 200 | dmce.t1 | LIMit of Iterations.
NREMI | 3 | term.t0 | N umber of reminimizations. NREMI > 0 improves EM.
STMIN | .0001 | dmce.t0 | St ep Minimal
DESTL | .001 | Cys_loop | D elta Energy in one Step Limit
AMD | .001 | dmce.t0 | A ccuracy of energy Minimization by the Davidon method
LIMNR | 30 |  | Limit of Newton-Raphson Iterations (rudiment?)


General MCM

Parameter

Default

Test

Definition

KMSR

0

zmm/
test/
Mac-
Projects

K ey for Multi-Step Relaxation. When KMSR=/=0 and KOPT=2, ZS runs four consecutive MC-minimization of a starting structure (which may be a homology model or imported X-ray structure) in a stepwise fashion to ensure minimal deviations from the PDB template. The First MCM runs with varying only those degrees of freedom, which are NOT defined in the PDB template: orientation of waters, torsions involving hydrogens, and side chain torsions in undefined residues. At the second MCM, all side chains torsions are added to the list of variables. At the third MCM, backbone torsions are added. At the fourth MCM, all degrees of freedom are allowed to vary. KMSR is a very powerful key for initial relaxation of bad starting approximations.

KMSR also defines the duration of initial MCM runs: LIMNE=LIMNE/KMSR and LIMIN=LIMIN/KMSR. Final MCM runs are controlled by standard parameters

MCM2

0

MCM with 2 steps for GRID jobs.
0, run regular MCM at each node
1, run two-stage MCM at each node. First MCM runs with fixed backbone and biopolymer roots to avoid large deformations caused by bad contacts, e.g., with ligand. At the second MCM, all degrees of freedom are allowed to vary.

KMLT

0

Key to Move Ligand to Target position/orientation.
Initial KMLT energy minimizations in the SETCON, MCM, or GRID are performed with KPAIR=0. This moves the ligand to the target position.

TMPR

600.

ggg.t1

Temperature

SEED

0.26

Seed random number

KIPI

0

Key to Ignore Permanent Interactions

NAMCT

1

Number of Alternative MCM Trajectories Launched in each node of the grid. The trajectory yielding the lowest MEC characterizes the node.

NTW

1 (limit of 7)

Number of Trial Ways. At each branching point (the first step is the first branching point), ZMM generates (NPW-1) alternative starting points and launches NPW trajectories from the branching point and alternative points. Each trial trajectory runs for LTW steps. ZMM compares energies from each trial trajectory and selects the lowest-energy point as the new branching point. Upon interruption of MCM, information on trial ways is lost. Upon continuation of the interrupted process, GENC on the hard drive serves as the starting point. The first LTW-fold point after continuation serves as new branching point

LTW

100

Length of Trial Way

KSTW

1

Key to Sample variable for the Trial Way.
1 Any variable N, position/orientation of free particle N


Sampling Variables in MCM

Sampling Variables in MCM. See also:
SCENT and other controls under sampling strategy in the field “RESIDUE SETTINGS’
Fields HGRID and RGRID

Parameter | Default | Test | Definition
THARL | 6. |  | Th ickness of Around-Residue-Layer to sample, Å. This parameter has effect when either SCENT or ISAS/LSAS are specified.
ISAS | 10 |  | I nterval to Shake Around Strains. At each ISAS-fold step of MCM trajectory, ZS determines residue with the largest energy and list of generalized coordinates whose variation affects interaction of this residue with its neighbors within distance THARL. During following LSAS steps of the trajectory, only variables from the above list are sampled. This essentially accelerates relaxation of bad contacts at initial stages of MCM trajectory.
LSAS | ISAS/2 |  | L ength of sub-trajectory that Shakes Around Strains.
KRELS | 5 | ggg.mcm | Key to RELax Strains at KRELS-fold steps
MCPL | 0 |  | Main Chain Preservation Level: 0, no; 1, Omega; 2, Fi, Psi, Omega
MCMBP | 2 |  | MCM Biased Probability method (Abagyan and Totrov, 1994) 0 do not apply (use conventional MCM) 1 apply at each MCM step N Switch to MCMBP at each Nth step and to MCM at each 2*Nth step
MCBR | 0 |  | Main Chain Bias in Biased Probability MCM 0 do not bias specific zone 1 Bias alpha-helix zone 2 Bias beta sheet zone
KSCV | 0 | enk.t0 KSCV 2 converges better than 0 or 1. | Key for Scaled Collective Variables (Noguti & Go, 1985; Maurer et al., 1999). N, MCM modifies simultaneously essential variables at each N-th MCM step. The list of essential variables is formed automatically to include all degrees of freedom except U-torsions, bond lengths, bond angles, and fixed variables. In docking experiments, the number of essential variables depends on SCENT and THARL . The search on the SCV space also depends on parameters IRHM, RASCV, and TASCV.
IRHM | 20 | enk.t1 | Interval to Rebuild Hessian Matrix over SCV when KSCV>0. The default value of IRHM is high because building of the matrix is expensive. For small molecules, IRHM can be decreased.
MSEA | 2 | Proteins\ rhz.cent_mcm.tsk | M ethod to Sample Euler Angles. Determines the way to turn a free molecule when its Euler angle is coined. 0, Turn around the root atom. Worth using for small molecules only. 1, If the helix is specified in the PIVOT field, modify the Euler angle of the pivot and move the root-atom to align the helix axis with the pivot. 2, Turn around the geometric center of the free molecule
MST | 0 | Proteins\WF201.trans_Zmol.tsk | M ethod to Sample Translations 0 – along x,y,z 1 – along three gyration axes
HGLED | 180. |  | H ot Grid Ligand's Euler-angle Deviation (degrees)
HGRED | 90. |  | H ot Grid R oot's Euler-angle Deviation (degrees)
HGLTD | 10. |  | H ot Grid Ligand's Translation Deviation
HGRTD | 2. |  | H ot Grid Root's Translation Deviation


Amplitudes of sampled variables in MCM

Parameter | Default | Test | Definition
EUMC | 180. |  | Euler Angle Maximal
DTBM | 20. | enk.t0 | Delta Torsion Backbone Maximal. The default is optimal for proteins (nres 20). In peptides, it should be larger.
DTBME | 180. |  | Delta Torsion Protein Backbone Maximal in peptides
DTSM | 180. |  | Delta Torsion Side-chain Maximal
DTM | 180. |  | Delta Torsion Maximal
TRAMC | 4. |  | Translation limit, A
RASCV | 180. |  | Rotational Amplitude in SCV method. The default value of 180 degrees was optimal for enkephalin, in proteins it should be lower.
TASCV | 3. |  | Translation Amplitude of a SCV, A


Termination of MCM trajectory

Parameter | Default | Test | Definition
LIMIN | 50000 | enk.t1 | Limit (number) of Minimizations in the trajectory
LIMNE | 1000 |  | Limit of No-Energy-down minimizations. MCM trajectory is terminated if during last LIMNE minimization the energy of the lowest MEC did not decrease.
TIMEJ | 23. |  | Time of Job (hours)
KSIAN | 0 |  | Key for Simulated Annealing. 0 No simulating annealing. 1 Increases temperature tenfold after KSIAN non-historical steps; restores it after an historical event
KBTR | 0 |  | Key to support Back Track mechanism. 0 no backtrack N, after N non-historical events, a MEC from the internal stack is selected randomly as a staring point to continue MCM protocol.


Aborting non-promising minimizations

Parameter | Default | Test | Definition
NIIT | 15 |  | Number of Initial Iterations to Test Energy
KSIM | 0 | ala93.tn | Key to control Similarity between GENC and dogma: 0 Ignore similarity 1 Check in LOPT 2 Check in LOPT and MCM


Nested MCM

Nested MCM. Significant perturbations such as pivot move, restraint activation, or protein backbone torsion sampling result in essential energy increase making an acceptance of the perturbed state in the trajectory a low-probable event. In an attempt to solve this problem, a nested MCM algorithm is elaborated (Zhorov, unpublished). In this algorithm, an external MCM cycle periodically perturbs certain parameters while relatively short internal MCM cycle relaxes the perturbed state. At each NEMCPth step, the external MCM cycle calls for a procedure that performs the following steps. Step A retains the energy of the last accepted conformation (Exl). Step B randomly selects and perturbs a specific parameter from the category defined by KSH. Step C minimizes the energy yielding the initial energy of the perturbed state Eis. Step D runs NEMCL iterations of the internal MCM cycle using Eis as the initial energy and yielding the final accepted conformation Cif and its energy Eif. Step E compares Eif with Exl and accepts Cif in the external trajectory using a standard Mertopolis criterion and temperature TMPR2. Step F returns control to the external cycle.

Parameter | Default | Test | Definition
NEMCP | 0 | Enk.t0 | Ne sted MCM trajectory periodicity. To run the nested MCM, assign to this parameter a value 10
NEMCL | 0 | Enk.t0 | Ne sted MCM trajectory length. This parameter should not exceed NEMCP
KSH | 2 | Enk.t0 | K ind of shake. This parameter specifies a category of variables to shake during nested MCM: 1 Pivot shaking. ZMM performs the following steps. Step C: switching off all the pivots . Step B: randomly selecting a helix and randomly modifying one of the pivot parameters . Step E: recalculating pivot parameters if the MEC is accepted. Step F: switching the pivots on. 2 If the system is a protein or a large peptide (100 atoms), ZMM deviates random number of backbone angles from the starting point by random increments with the amplitude of either DTBME (peptides) or DTBM (protein). If the system has less than 100 atoms, sample random number of torsions by the same way. 3 Switching on a NOE restraint 4 Shaking all torsions 5 Shaking all degrees of freedom
TMPR2 | 300. | Enk.t0 | Temperature of the nested MCM cycle
 |  |  | See also SHIFM and TETAM under pivots


Stochastically Restrainable MCM control

Parameter | Default | Test | Definition
CNSB | 0. |  | Per Constrain energy Benefit
KSH |  |  |
KRCN | 0 |  | Key to Randomize Constraints/Restraints


Pass

STPAS | .1 | Step in Pass Search
JRB | 1 | Jerk Rigid-Backbone model before MC-minimizing complete model
IMDV | 0 | Immobilize Most Deviating Variable (1) and symmetric ones in subunits (2)
MNPD | 0 | Make New Pass Direction MNPD


Stack control

Parameter

Default

Test

Definition

KLEC

2 for small systems

4 for systems with ligands

6 for systems with no ligand and > 100 residues

Peptides/

ala.grid.tsk
ala93.grid.tsk
ggg.mcm.tsk
enk.mcm.tsk

K ey to create List (stack) of Equilibrium Conformers (MECs) molname.jobname.stack.
MECs are sorted by the total energy.
MECs with the energy > DELEQ kcal/mol from the apparent global minimum are not included in the stack.

For each new MEC, a match among all MECs in the stack is searched. If the match is NOT found, the new MEC is added to the stack. If a match is found, depending on energy, the new MEC is either ignored or replaces the matching MEC in the stack. In any case, the number of visits to the stack MEC increases by 1.

KLEC may have the following values

0, Stack is not supported

For other values, two MECs are considered a match if they have:

1, Same backbone code (Zimmerman et al., 1970) and similar root
coordinates
2, Same backbone code, similar side chain torsions, and similar root
coordinates
3, Similar torsions and root coordinates
4, Similar torsions and root coordinates of the ligand, which should
be specified by command PART
5, RMSD of ligand’s Cartesian coordinates are less than TRMSD.
Comparable atoms should be defined by commands AESA and AISA.
6, Identical residue-residue contacts, see peptides/deca.h2.tsk
 does NOT work with MPI (parallel)
7, Identical ligand-system contacts. The ligand label must be specified
by PART. To find all the chelating patterns of an ion by a small
molecule, specify the ion by PART and adjust parameter SCT (e.g., 3.5)
does NOT work with MPI (parallel)

In two MECs, comparable Torsion Angles, Translation coordinates, or Euler Angles are considered similar if they deviate by less than DLTAS, DLTRS, or DLEAS, respectively.

ETTS

10000. kcal/mol

E nergy Threshold to Take Stack. Works with command TAKE STACK in the START field. Setting ETTS below the default level (e.g., ETTS=0) helps avoiding importing high-energy MECs, e.g., from stacks produced by HGRID.

TLRE

1.E10

T hreshold of Ligand-Receptor Energy to add a MEC in a stack.
If energy of ligand-receptor interactions ELRT < TLRE, a MEC is added to a stack. For example, if (TLRE = -10.) then only MECs with ELRT < -10. kcal/mol will be added to a stack.

LBEST

0

Long\1iol.lri.tsk

Create List (stack) of MECs molname.jobname.lrbest that accumulates structures with the BEST ligand-receptor energies. Ligand-receptor energy currently consist of:
Ligand-receptor
van der Waals energy +
electrostatic energy +
solvation energy +
intraligand
van der Waals energy +
electrostatic energy +
solvation energy +
torsion energy +
bond angles strain energy
Thus, the ligand-receptor energy used to sort molname.jobname.lrbest may dramatically differ from the ligand-receptor interaction energy printed with index ELRT.

Structures in molname.jobname.lrbest are expected to have smaller energy fluctuations than in molname.jobname.stack since the former is insensitive to interactions far from the ligand-binding site. E.g., molname.jobname.lrbest would keep a structure with the low ligand-receptor energy even if the total energy of the complex were too high to include the structure in molname.jobname.stack.

It is NOT recommended to generate molname.jobname.lrbest when ligand is docked in the double-shell model, because the latter already contains rigid residues far from the ligand.

The ligand label should be specified in command PART under RESIDUES field. Only those MECs are kept in the stack, whose ligand-receptor energy is within DELEQ kcal/mol above the apparent global minimum of the ligand-receptor energy.

DELEQ

7. kcal/mol

Peptides/ala93.tn

D elta Energy in the List of Equilibrium conformations (in the stack of MECs). When a new MEC is found during MCM, it is added to the stack only of the energy of the MEC above the apparent global minimum is less than DELEQ

LIMST

100

Limit of MECs in external Stack

DELEL

7.

D elta Energy in the List of E quilibrium conformations LRBEST

IDEM

500

Peptides/ggg.t1

I nterval to Deliver file molname.jobname.mcm during MCM.

DLTAS

.2 rad

D eviation Limit of two Torsional Angles to treat them as Similar

DLTRS

1. Å

D eviation Limit of two Translational coordinates to treat them as Similar

DLEAS

.2 rad

D eviation Limit of two Euler Angles to treat them as Similar

TRMSD

1. Å

T hreshold of RMSD between ligands’ Cartesian coordinates to treat two MECs similar

IMWS

1

I gnore Movement of Waters when analyzing similarity of MECs in the Stack


Listing control

Keys to include (1) or not include (0) items in the output file

Parameter | Default | Test | Definition
TSHEL | 0. |  | T hickness of the Shell around Ligand. Affinity of the ligand depends on several factors, two of which can be calculated at each energy call: ligand-receptor nonbonded interactions (available with index ELRT) and intraligand interactions (available with indexes ELN, ELBA, ELTOR, ELT). A ligand in a protein can induce intra-receptor strains, which decrease the ligand affinity. The strain energy, which depends on TSHEL, is available with indexes ESHA and ESHR at the stage of post-digit-crunching analysis with module zv
KNDO | 0 |  | K ey to deliver file *.mop for MNDO calculations in MOPAC
KTIME | 0 |  | K ey to print Time
KPM | 0 |  | K ey to Print Minutes. 1 each EM; 2 each iteration in EM; To prevent huge output in UNIX jobs, do not use this key.
KPRSE | 0 | ice.sh* | K ey to Print Residue - System Energies. 1, command 'zv molname.jobname.stack' delivers: - file 'molname.jobname.rc.csv' with atom contacts - file 'molname.jobname.re.csv' with residue contacts, intersegment and interdomain contributions to the residue energy
KPLRC | 0 |  | Key to Print Ligand-Receptor Contacts (Ligand should be specified in command PART under RESIDUE SETTINGS) 0, No Contacts 1, Ligand heavy atoms with receptor sidechain heavy atoms 2, Ligand heavy atoms with receptor heavy atoms 3, Ligand all atoms with receptor sidechain all atoms 4, Ligand all atoms with receptor all atoms
DPLRC | 5. |  | Distance threshold to Print Ligand-Receptor Contacts
KDISC | 0 | Proteins/ 1iol.lri.tsk | K ey to Deliver Inter-Segment Contacts. KDISC, RTRC and ETCR, instruct ZV to deliver good/bad contacts between residues that are in different segments or separated by more than four residues. Used with key KPRSE
ETRC | 10. | “ | E nergy Threshold to deliver Residue Contacts. If KPRSE =/= 0, ZMM computes array Er , the interaction energy of each residue with the rest of the system. If for a given residue |Er| < ETRC, contacts of this residue are not delivered. The key filters out contacts of those residues that have weak energy of interaction with the rest of the system.
ETRRC | 3. | “ | E nergy Threshold to deliver Residue-Residue Contacts. If absolute value of residue-residue energy > ETRRC, corresponding contact is delivered. The key filters out weak residue-residue contacts. To appear in the list of residue-residue contacts, two residues should be in different chains or should be separated by 3 or more residues within the same chain.
KHIST | 1 | Enk.t0 | K ey to track History of MCM upon E decrease. 0, Nil 1, Append file molname.jobname.hist 2, Append files molname.jobname.hist and molname.jobname.conv. The latter accumulates GENCs that can be converted to PDB coordinates by ZV and then visualized by Rasmol_2.7.1 (see script zmm/t/1.rsm) or by MVM
KPDB | 1 |  | K ey to deliver/update file *curr.pdb upon each decrease of the apparent global minimum found in MCM job. MVM program reads this file to visualize structures generated by MCM. Setting KPDB 0 reduces output in background jobs.
MPDB | 1 |  | M ode of arranging atoms in the PDB file. 0, By atom numbers. Flexible-shell atoms first, then fixed-shell atoms, if any. 1, By residue labels. Flexible and fixed shells (if any) are mixed-up. 2, By residue labels. Flexible and fixed shells as well as residues present in the PDB template but not in the model are mixed-up. You may need this key, e.g., to visualize a double-shell model in the context of entire structure, which can be much larger that the double-shell model. 3, deliver coordinated of dummy atoms (For ZMM developers)
KHPDB | 1 |  | K ey to print Hydrogens in PDB file
KRPDB | 0 |  | K ey to Reduce redundant coordinates in PDB file with multiple models. 0 – do not reduce 1 – Reduce delivery of fixed atoms in models 2 and beyond 2 – For MECs 2, 3, …, deliver only residues specified under PART
KDGF | 1 |  | K ey to Deliver Grid File. Some jobs (e.g., stream docking of ligands) may produce huge grid files, while accumulating in *.stack relatively small number of low-energy MECs. KDGF=0 blocks delivering of *.grid file.
KDSF | 0 | Peptides/ ala.take_ stack.tsk | K ey to Deliver Stream File 0: Do not deliver 1: If file molname.jobname.tsk contains a command TAKE STACK, each MEC imported from the stack is processed (energy evaluated, energy minimized, or MC-minimized) and the best MEC obtained is delivered to file molname.jobname.stream. The key may be used, e.g., to process .grid file with new parameters and order resulting MECs in .stream file in the same order as in the .grid file.
KPGT | 0 |  | K ey to Print Grid Table 0 Nil; 1 Each node of the grid is shown by the driven parameters and energy.
TDMC | .1 |  | T hreshold to Deliver Mismatched Constraints. If TDMC = 0., all constraints are delivered, even those matched in the structure; this option allows upgrading NMR constraints
SCT | 5.0 |  | S hort Contacts Threshold
SSDT | 8. |  | S egment-Segment Distance Threshold - cutof to exclude a pair of residues from calculations of intersegment energy
KPSA | 0 |  | K ey to Print Solvation energy partitioned by Atoms
KPGEN | 1 | Ligands.t0 | Key to Print GENCs 0, nil 1, All 2, Partitioned by residues (TAR) 3, Partitioned by torsions (TORS) 4, Partitioned by non-excluded residues
KPT | 0 | gall.t1 | K ey to Print Torsions 0, nill 1, one line per torsion 2, few lines per torsion when MM2 3, Backbone torsions only
KPFP | 0 |  | K ey to Print Free Particles' coordinates (A) and Euler angles (deg)
KPB | 1 | gall.t1 | K ey to Print elastic Bonds
KPBA | 0 | gall.t1 | Key to Print Bond Angles (1) and GENCs (2)
KPRRC | 0 |  | Key to Print Residue-Residue Contacts. Distances between Ca atoms and angles between vectors
DFRRC | 8.2 |  | Distance Filter for Residue-Residue Contacts. The default value selects Leu-Ala contacts between TM helices of KcsA
AFRC1 | 50. |  | Angular Filter 1 for Residue-Residue Contacts having smaller angle between vectors CaI-Caj, Cai-CbI
AFRC2 | 90. |  | Angular Filter 2 for Residue-Residue Contacts having smaller angle between vectors CaI-Caj, Cbj-Caj ...redefine it to Caj-Cai, Cbj-CaI
KPVMA | 0 | gall.t1 | K ey to Print Vector Models of Atoms
KPPVT | 0 |  | Key to Print Pivots
KPFA | 0 | Gall.t1 | Key to Print Forces at Atoms
KPCC | 0 | gall.t1 | Key to Print Cartesian Coordinates
KPAGC | 0 | Gall.t1 | Key to Print Axes of GENCs


Statistics control

LSTAT | 0 | Level of the statistics output in ZV: 0, minimal, 1, intermediate, 2, maximal
STADT | 0.1 | STAt Dispersion Threshold. Prints var. dispersed > STDAT rad


Coordinate calculation

KTRFA

0

K ey for Translation-Rotation of the First Atom (transforms geometry of a mono-molecular system)

MSCD

0

M ake up protein Side Chains by Dunbrack’s program
0 do not make up

1 make once by scwrl3 after reading line “START” in .tsk file
2 make by scwrl3 after each GRID seeding of ligand in the flexible protein
3 make by scwrl3 after each GRID seeding of ligand in the rigid protein

4 make once by scwrl4 after reading line “START” in .tsk file
5 make by scwrl4 after each GRID seeding of ligand in the flexible protein
6 make by scwrl4 after each GRID seeding of ligand in the rigid protein

To pack side chains around a ligand, specify the ligand label in command PART

Example: Test\Side_Chains\Dunbrack\1cbs\

For a good example where "MCPD 1" solved a problem, compare
~/PLIC\ KcsA\Opening\20\MCM\1\3FB8_P.1.hist and
~/PLIC\ KcsA\Opening\20\MCM\2\3FB8_P.2.hist

Program scwrl4 is not a part of ZMM. It can be obtained from http://dunbrack.fccc.edu/scwrl4/
Program scwrl3 is no longer available there.

MSCR

0

M ake up protein Side Chains using Rosetta
0 do not make up
1 make up once after reading line “START” in .tsk file
2 make up after each seeding of ligand in the flexible protein
3 make up after each seeding of ligand in the rigid protein
To pack side chains around a ligand, specify the ligand label in command PART
Example Test\Side_Chains\Rosetta\1CBS.0.tsk

SCWS

0.

SCW rl[3,4] Shell thickness around ligand. If SCWS=0. (default), no shell control is implemented and all the protein is considered. Test on a small protein (1cbs) shows that sqwrl3 time does NOT depend on SCWS.


Periodic boundaries (poorly tested)

Parameter | Default | Test | Definition
RCC | 9.5 |  | Rib of Cubic Cell
KINI | 0 |  | Interactions with Neighboring Images


Pivots Control

Parameter | Default | Test | Definition
KPVT | 0 | Tm12.t0 | Key to impose pivot constraints. The corresponding helices specified in the PIVOT field should be free molecules. 0 No constraints are imposed even if pivots are specified 1 Constraining helices to the pivots specified in the field PIVOT. The pivots approximate the helical axes (that may be curved). The forces are applied to the C-alpha atoms. 2 Do not use this number. Reserved for the internal use in ZMM 3 Constraining helices to coordinates of C alpha atoms (recaha in loops.for)
IHPG | 1 | Tm12.t0 | Impose Helical Pivot in the starting point (transform PIVOT to GENC)
PFHD | 1. |  | Penalty-free Helix deviation from the pivot
FCPVT | 10. | Tm12.t0 | Pivot Force Constant
TETAM | 180. |  | Delta Pivot TETA (amplitude of turn in the nested MCM)
SHIFM | 3. |  | Shift Maximal of the Pivot in the nested MCM
KMPVT | 0 |  | Key to Move Pivot in MCM (toggles helical_pivot_energy)


The field INDEX specifies geometrical parameters to be computed in the ZS tasks

Field INDEX in file molname.jobname.tsk as well as files index, molname.index, and molname.jobname.index can specify up to 100 indexes to be delivered by zv. Each index-line contains the index name and up to four parameters that, depending on the index type, may be names of atoms, names of variables, residue labels, and Cartesian coordinates of atoms.

Command zv molname.jobname.stacktype –s generates file .stat that contains minimal, maximal, and average values of index l over MECs in .stacktype.

Command zv molname.jobname.stacktype –x generates matrix .xls, in which element vml is an energy or geometry characteristic of index l calculated for MEC m from .stacktype.

See more index-related options in description of program zv

A criterion cl may be specified to deliver a matrix sml, in which symbols “+” or “–“ to show whether value vml meets criterion cl.

sml = “+” if vlm < cl
sml = “-” if vlm >= cl
sml = “ ” if cl is 0 or not specified

To label MECs in which a group of indexes meets specified criteria, use brackets:

  OR_(  <index sub-list>   OR_)
   &_(  <index sub-list>   &_)

‘+’ will be delivered in line m, column ‘OR_(‘ if any index between ‘OR_(‘ and ‘OR_)’ is marked by ‘+’

’+’ will be delivered in column ‘&_(‘ if every index between ‘&_(‘ and ‘&_)’ is marked by ‘+’

Example: Tests\Proteins\1iol.trans_1.tsk


Energy Indexes

Energy Indexes of MECs accumulated in the .grid, .stack, and .stream files can be delivered by ZV program. To do this, specify in the .tsk file field INDEX with types of the energy component(s), which you would like to analyze. The types of energy components are shown below. For indexes involving ligands, the latter should be specified in command PART under RESIDUE SETTINGS

Example: zmm\test_big\long\1iol.trans_1.tsk

EC | Energy Conformational (total)
ELIB | Energy Librational
EA | Energy Angular
EEL | Energy Electrostatic
EN | Energy Nonbonded
ESOL | Energy of solvation (zmm/test/small/ditmm.t1)
EHBN | Energy H-bonds
EL | Energy Loop-Closing
EB | Energy Bond Stretching
ET | Energy Torsional
ECNS | Energy Constraints
NVIS | Number of times the MEC was visited in stack-file (entropy-related)
EPVC | Energy of Pivotal Constraints
EPAI | Energy of Pairwise interactions (EEL+EN+EHBN+ESOLV+EL)
ERRI m n | Energy of Residue-Residue Interaction. Residues m and n are specified by their labels. Useful for analyzing residue-residue or ligand-residue interactions in a stack, e.g., to analyze how a particular residue affects the ligand pulled through/along a protein. See: Test\peptides\ggg.mcm.tsk
ELSI m n | Energy of Ligand-Sidechain Interaction. Residues m and n are specified by their labels. Useful to analyze how a particular residue sidechain affects the ligand pulled through/along a protein.
ERSI m [n] | Energy of Residue-System Interaction; m and n are residue labels. If both m and n are specified, the index shows interaction of the residue sequence m through n with the rest of the system. Test\peptides\ggg.mcm.tsk
ERWI m | E nergy of R esidue-W ater I nteractions; m is residue label

Indexes for intra-ligand, ligand-receptor interaction, and intra-receptor interactions. Ligand should be specified in command PART under RESIDUE SETTINGS

Ligand indexes
These intraligand energy components are delivered relative to reference energies, which are calculated for the MC-minimized free ligand and can be found in the ligand .sym file or in the system .sym file under description of the ligand

ELN

Energy Ligand Nonbonded (the sum of van der Waals, electrostatic and solvation components of intraligand energy)

ELBA

Energy of Ligand Bond Angle

ELTO

Energy of Ligand Torsional

ELT

Energy of Ligand Total (ELBA + ELTOR + ELN + ELRT)

Ligand-receptor indexes

These indexes may be used to partition interaction energy of a multi-residue ligand with the system or energy of interactions between two segments.
Example: the following lines in .tsk file instruct ZMM to deliver the interaction energy between segments 'D3129 ' 'D3158 ' and 'A1001 ' 'A2225 '

RESIDUE

  REX

  REIN 'A1001 ' 'A2225 '

  REIN 'D3129 ' 'D3158 '

  PART 'D3129 ' 'D3158 '

END

INDEX

  ELRT

END INDEX

RESIDUE

  PART 'D3129 ' 'D3158 '

END

ELRH

Energy Ligand-Receptor, H-bonds.

ELRN

Energy Ligand-Receptor, Nonbonded.

ELRE

Energy Ligand-Receptor, Electrostatics.

ELRS

Energy Ligand-Receptor, Solvation.

ELRT

Energy Ligand-Receptor, Total.

Receptor indexes

ERN

Energy Receptor Nonbonded (Including solvation)

ERTO

Energy Receptor Torsional

ERBA

Energy Receptor Bond Angle

ERT

Energy Receptor Total (ERN + ERBA + ERBA)

ESHA

Energy of the SHell around the ligand, Absolute value.

Ligand affinity depends on many energy components. In particular, it decreases with the ligand-induced strain energy of the protein. Index ERT can be used to estimate how the intra-receptor energy depends on the ligand position, but unless the ligand is docked in the double-shell model, |ERT| is big and depends on protein fluctuations far from the ligand. ESHA helps estimate the receptor strain in a shell around the ligand. The shell contains all residues that have at least one atom within TSHEL Å from any atom of the ligand. ESHA is calculated as the sum of all nonbonded interactions within the shell.

The major problem is that ESHA depends on number of atoms, which vary in different ligand orientations. The strain induced by the ligand could be estimated by comparing ESHA with the energy of the same group of atoms in the relaxed structure without the ligand, but currently this is difficult to realize. As a compromise indexes NASH and ESHR can be used along with ESHA to estimate

See zmm\test_big\long\1iol.trans_1.tsk

NASH

Number of Atoms in the Shell around the ligand. As a zmm\test_big\long\1iol.trans_1.tsk

ESHR

Energy of the SHell around the ligand, Relative value. This index is the difference between ESHA and reference energy of the same shell, whose geometry corresponds to the initial position of the ligand in the stack/grid. ESHR in the first position of the grid should be zero. See zmm\test_big\long\1iol.trans_1.tsk


Geometry Indexes

These indexes are used to calculate geometrical characteristics of conformers. To deliver geometry indexes, type

zv molname.jobname.stacktype [options]

Module zv, reads structures from file molname.jobname.stacktype then reads specifications of index(es) from files .index and/or .tsk, and delivers indexes calculated for each structure to files molname.jobname.stat and/or molname.jobname.xls

Indexes can be specified in any of the following files:

zmm.index - Applicable to any ZMM job that can reach this file. If several files “zmm.index” exist within a parent folder and subfolders, the ZMM job will use the index file, which is the most proximal to the job along the path

molname.index – Applicable to any job with given molname

molname.jobname.index - Applicable only to job molname.jobname

molname.jobname.tsk - Applicable only to job molname.jobname

Indexes that can be specifies only in files *.index
Abbreviations:
vn – Variable Name (16 characters)
an – Atom Name (16 characters), e.g. 'OE1.GLU .A1234 '
xyz – Cartesian coordinates of a point (atom)
lb – Residue Label, e.g. 'A_124 '

Index | Meaning | Examples
The indexes below calculate deviations of MECs from that in file ‘template.pdb’ Note apostrophes around the index names.
‘RMSD’ ‘BKBN’ ‘template.pdb’ [c] | RMSD of backbone torsions in the given MEC in stack from those in template | test\peptides\safe\ cyclic_peptide.index
‘RMSD’ ‘DIST‘ ‘template.pdb’ [c] | RMSD of distances of all pairs of Cα atoms within the models vs. that in the template, which is not necessarily superimposed with the model. | test\peptides\safe\ cyclic_peptide.index
‘RMSD’ ‘ CA ‘ [‘lb1’ ‘lb2’] ‘template.pdb’ [c] | RMSD of Cα atoms between two superimposed models or their parts specified by residue labels (e.g., a protein and its template) | Test\Peptides\safe\ cyclic_peptide.index
‘RMSD’ ‘ CAX’ ‘lb1’ ‘lb2’ mol2.pdb ‘lb3’ | RMSD of Cα atoms between segment lb1-lb2, and same-length segment in mol2.pdb (e.g., X-ray structure), which starts from lb3. Example: comparing superimposed NavAb and Kv1.2 channels, which have different residue labels | 'RMSD' 'CAX' 'A_113 ' 'A_125 ' 'Kv12_pore.pdb' 'A_311 '
‘RMSD’ ‘LIG’ ‘lb1’ [‘lb2’] ‘template.pdb’ [c] | RMSD of Ligand. Stack MECs are compared with the template and distances between matching atoms of specified residues are calculated. The ligand may be specified by one residue or multiple residues (lb1 to lb2) | Test\Proteins\safe\ 1iol.trans_1.index
‘RMSD’ ‘LRC’ ‘lb1’ [‘lb2’] ‘template.pdb’ [c] | Like |RMSD LIG|, with both the ligand and flexible residues of the Ligand-Receptor Complex included. | Test\Proteins\safe\ 1iol.trans_1.index
‘RMSD’ ‘SHEL’ ‘lb1’ [‘lb2’] ‘template.pdb’ [c] | Like |RMSD LIG|, but only Flexible residues of the protein within 10 Å from the ligand included. |
'DIST' <an1> <an2> [c] | Distance between atoms 1 and 2 specified by their 16-char names. In case of GLU or ASP residues, which have ambiguous names OE1, OE2, OD1, OD2, the names may be given as OE or OD. ZMM returns the closest of two distances | test\peptides\safe\ cyclic_peptide.index
‘RSLD’ ’lb’ ’Ligand label’ [c] | R esidue S idechain to L igand D istance. Shows the shortest distance. |
'RRC' ['lb1' ['lb2']] | R esidue-R esidue C ontacts. No labels – all contacts lb1 – all contacts of lb1or segment lb1-lb2 | Test\Proteins\safe\Kv12_pore.index
'RPC' 'lb1' or 'RPC1' 'lb1' 'RPC2' 'lb1' 'RPC3' 'lb1' | R esidue P olar C ontact. RPC and RPC1 find a polar atom closest to the polar sidechain of 'lb1'. RPC2 and RPC3 find the second and the third closest atoms. |
'DRR' 'lb1' 'lb2' | D istance R esidue-R esidue. Finds closest contact between two residues |
'DRRP' 'lb1' 'lb2' | D istance R esidue-R esidue P olar. Finds closest polar contact between two residues |
SGSG lb1 lb2 lb3 lb4 | The shortest distance between backbone atoms of segment lb1-lb2 and segment lb3-lb4 |
HOA 'lb1' 'lb2' xyz1 xyz2 | H elix O rientation relative to an A xis. lb1 and lb2 - residue labels in the helix start and end xyz1 and xy2 - Coordinates to specify an axis A Returns: CA-CB sl, slope angle of CA-CB to CA-axis, distance from CA to A CA-CB or, CA-CB orientation, angle between CA-CB projection on the plane normal to A and an axis that is normal to A and X HB-3 etc. H-bond distances (HN to O three to five residues downstream Residue Screening from solvent Average Screening by atoms | Test\Long\safe\A1_NA.index
‘EXPW’ lb [lb2] | Exposure of residue to water | test\Proteins\ KcsA_symmetry.em.tsk

Indexes that can be specified only in file molname.jobname.tsk

Index b | Meaning | Examples in ZMM\Test\
GENC <vn> | Gen eralized coordinate. | Proteins\1iol.centroid.tsk
DIST <an> <an> | Dist ance between two atoms | small_molecules\ditmm
APNT |  |
APNC <an> <xyz><xyz> | A tom to Plane given by its Normal Coordinates | Proteins\1iol.transl.tsk
AP |  |
APC |  |
APT |  |
AL |  |
ALT <an1> <an2><an3> | A tom to L ine specified by T emplate names of atoms | \Proteins\ KcsA_symmetry.em.tsk
ALC <an> <xyz><xyz> | A tom to L ine specified by C oordinates | \Proteins\ KcsA_symmetry.em.tsk
TORS <vn> | Tors ion specified by its Generalized coordinate |
TORT <an1> <an2> <an3> <an4> | Tor sional angle between four atoms, which are not necessarily connected | proteins\1iol.centroid.tsk
DAR <an> <lb> | D istance between the Atom and the closest atom of the Residue | Proteins\1iol.trans_1.tsk
X <an> | X coordinate of atom |
Y <an> | Y coordinate of atom |
Z <an> | Z coordinate of atom |
 | Rudiments |
FI na | Euler Angle Fi of VMA of atom NA |
PSI na | Psi |
TETA | Teta |
S+X j [d] | These indexes return the distance between the vector A starting from atom j and collinear to {x, y ... -z} and the closest shielding atom k found between two planes normal to A and crossing it at the distances (d/100 or 1.5 A) and 6 A from j. N is inserted to the right-most bits of CHARC (BESM6 rudiment) |
S-X j [d]
S+Y j [d]
S-Y j [d]
S+Z j [d]
S-Z j [d]
SPLA na1 na2 na3 | Shielding PLAne (center between na1,na2) |
SLIN na1 na2 [d] | Shielding Line --..--n1---n2--..-- |
BETW na1 na2 [d] | Shielding Line n1---n2 |
FAR na1 na2 [d] | most Far atom from n1---n2 |
ANGL na1 na2 na3 | Angle na1--na2--na3 |
DAPH na1 na2 na3 | Distance from n1 to the center of n2--n3 |
DPP na1 na2 na3 na4 | Distance between centers if na1-na2 and na3-na4 |
TRAN na1 na2 na3 | Operator Transforming Coordinates (see CHARC) |
PLXN na1 na2 na3 | Normal to the plane, X-component |
PLYN na2 na2 na3 | Y |
PLZN na2 na2 na3 | Z |

b) Some indexes have syntax similar to that of constraints. If constraints are specified in the .tsk file, copy corresponding lines from the field "CONSTRAINTS" to the field "INDEX" and remove {DL DH F}


The following indexes refer to geometry of helices

The following indexes refer to geometry of helices. The indexes should be specified in rigid format (a4,1x,5i5). A helix is specified by the residue label (nr) in the beginning and end. Integer criterion c is optional

HENN nr1 nr2 nr3 nr4 | Distance between N-ends of helices nr1-nr2 and nr3-nr4
HECC nr1 nr2 nr3 nr4 | Distance between C-ends of helices nr1-nr2 and nr3-nr4,
HENC nr1 nr2 nr3 nr4 | Distance between N-end of H1 and C-end of H2
HENX nr1 nr2 nr3 nr4 | Distance between N-end of H1 and aXis of H2
HEAZ nr1 nr2 nr3 nr4 | HElix-helix Angle, Z-z axes
HEAX nr1 nr2 nr3 nr4 | HElix-helix Angle, X-x axes
HEPS nr1 nr2 | Helix nr1-nr2 Euler angle Psi
HETE nr1 nr2 | Teta
HEFI nr1 nr2 | Fi
HEOX nr1 nr2 | Helix nr1-nr2 Origin, X-coordinate
HEOY nr1 nr2 | Y
HEOZ nr1 nr2 | Z


The following indexes are dimensions of rectangles described over a part of the MEC

The following indexes are dimensions of rectangles described over a part of the MEC. The part is projected on the plane normal to A1-A2 and not extended from A1 in the direction A1->A2 more than a specified limit p. The indexes were used to select bioactive MECs of opioid peptides matching the shape of Ca2+-bound morphine (Zhorov and Ananthanarayanan, 1995).

MXRL A1 A2 p c | Maximal-Rectangle Length
MNRS A1 A2 p c | Minimal-Rectangle Square
MNRW A1 A2 p c | Minimal-Rectangle Width


Prototype lines for tune-files

Prototype lines for .tsk files

Examples of many .tsk files are given in ~zmm/test/proteins/, ~zmm/test/peptides/, and ~zmm/test/small_molecules/. Most commands in the tune-file have flexible format with one or more blank characters between components. Some fixed-format commands, prototype lines are shown below. Copy a prototype line in your .tsk file and use substitute each character ~ by single space character.

Starting geometry

TAR~~~1054~VAL~~-.132~-1.527~-3.099~~3.128~-2.982~-3.094
TAR~~~~400~DHT~~-.291~~~.127~~~.343~~-.231~-3.087~~3.127~~~.581~-1.051~~~.994
~~~.898~~-.987~~~.954~-2.830~-2.930~~~.100~~1.113~~3.142~~3.142
FRIM~~~~36~LEU~21.126-10.151~~3.316~~1.620~~1.756~-2.750

Constraints

CTOR '~C2~.E2.400' '~C4~.E2.400' '~C3~.E2.400' '~C10.E2.400' '~CA~.SER.142' 170 0. 5000.

Indexes

AA '~O17.DHT. 400' '~OG~.SER.142' 3.


To run ZMM

The simplest way to learn ZMM is to run several example jobs and analyze their results.

Many examples of ZMM jobs are available in directory zmm/test.

To run an example job:

- open file zmm/test/*/0_*.bat with a text editor

- find lines with specific molname

- execute commands one at a time by copying corresponding lines to the command-line window of your file manager.


UNIX users: when submitting a long background ZS job, make sure that field PARAMETER in *

Submitting a parallel job zsp o n SHARCNET and similar systems:

1. In file molname.jobname.tsk specify parameter “MP_M 2” for GREN parallelization.
2. Make an executable file (e.g. run_p) with a line like this:
sqsub -q mpi -n 16 -r 12h --mpp=0.5G -o out zsp molname.jobname.tsk
3. Type: zt molname.jobname.tsk
4. Check that file “molname.jobname.tune” is generated
5. Type: run_p &

In this example, a parallel job will be submitted to queue “mpi”. The job requests 16 processors, 0.5 Gbyte RAM per processor, and 12 hours of CPU time per processor. Unless completed in 12 hours, the system will terminate the job.

To see the job status, type: sqjobs
For additional information read UNIX manuals:
man sqsub
man sqjobs

Submitting a serial job: sqsub -q serial -r 24h --mpp=0.5G –o out zs molname.jobname.tsk

Submitting a serial-farm job zs on SHARCNET and similar systems:

Serial farm is an optimal solution to use multiple processors for MC-minimizing energy from multiple starting points (e.g., refining MECs accumulated in stacks, GRID, HGRID)

1. In In file molname.jobname.tsk specify N, the number of serial-farm processors,
in command “NSERF N” under PARAMETERS field

2. N, the number of serial-farm processors,
in command “NSERF N” under PARAMETERS field

3. Create executable file run with the following line:
zt molname.jobname.tsk –sf –r <time_per_processor>

4. Submit job in the serial queue: run &

Upon successful completion, resulting .grid, .stack, and .lrbest files are merged automatically.

Command zt molname.jobname.tsk –sf –nm submits NSERF serial jobs to the serial queue. Resulting files remain in the working directory for subsequent merging by the user. This can be done by command zs molname.jobname_last.tsk -sf where _last is the last serial-job index, and key –sf instructs zs to integrate serial-farm results.

UNIX Scripts by Daniel Garden

kjobs kills all jobs in 'sqjobs' that match a specific pattern in the jobname

Synopsis: kjobs [JOB PATTERN] [-f]

default (no option) creates an editable temporary executable file 1_[JOB PATTERN]. The file contains all the jobs to be killed when the temp file is run. Key '-f' instructs kjobs to kill all jobs matching the pattern

Type kjobs to display the proper usage of the program

rerun

searches for all dropped jobs in the current directory and compares them to the jobs
that are running through 'sqjobs'.

type 'rerun' to display the proper usage and the options and all the jobs to be resubmitted

Synopsis: rerun [PATTERN] [-f]

where [PATTERN] will define the jobs to be resubmitted uniquely from
other jobs in the directory.

Key '-f' forces the script to resubmit all failed jobs matching the [PATTERN] in the
current directory.

==================

Other parallel computers:

On small machines, create an executable file run_zs with a line zs filename.jobname.tsk and submit the job by typing nohup run_zs > out &.

At systems that support batch jobs (idra), execute a command bsub -c 500:00 zs filename.jobname.tsk where option -c indicates time allocated for the job (in this example, 500 hours).


ZSP, a parallel version of ZS, can be run on a multiprocessor computer with MPI system

ZSP, a parallel version of ZS requires a multiprocessor system with MPI. Examples below show how to submit job zsp enk.grid.tsk at different computers

  1. In file molmane.jobname.tsk, specify level of parallelization (parameter MP_M in PARAMETER field)
    Use <MP_M 2> for GREN level of parallelization (most cases)
  2. Test file molmane.jobname.tsk by typing zt molmane.jobname.tsk

Sharcnet systems, Opteron processors (Narwhal, Whale, etc.)

sqsub -q <mpi |s> -r <runtime limit> -n 4 -o out zsp enk.grid.tsk

Submit the job at four processors
Type sqsub --man for details

sqsub -q mpi -n 16 -r 12h --mpp=0.5G -o out zsp molname.jobname.tsk

--mmp request 0.5 Gb RAM

sqjobs

see status of your jobs

sqjobs –all

see status of all jobs

sqkill jobid | suspend jobid | resume jobid

SHARCNET systems with alpha processors (rudiment)

bsub -q parallel -n 4 -o out zsp enk.grid.tsk

Submit the job at four processors

bjobs

see status of your jobs

bqueues

see status of all queues

Bkill

In the above examples, the following file enk.grid.tsk was used.

=========================================
RGRID  2
4    5  'Psi.TYR. ___1' 0. 360.
        'Fi .GLY. ___2' 0. 360.
        'Psi.GLY. ___2' 0. 360.
        'Fi .GLY. ___3' 0. 360.
        'Psi.GLY. ___3' 0. 360.
        'Fi .PHE. ___4' 0. 360.
4    2  'Psi.PHE. ___4' 0. 360.
        'Fi .MET. ___5' 0. 360.
        'Psi.MET. ___5' 0. 360.
END GRID

PARAMETER
  KOPT  2
  LIMIT 100
  LIMIN 1000
  KLEC  1
  KHIST 0
  KPM   0
  DELEQ 20.
  MP_M  1      ### specifies the GRID mode of parallelization
END
END TUNE
=========================================

Seshat (rudiment)

To run a job on 14 nodes

1. Make executable file, e.g., ~/zmm/r/Na/LA/run

/usr/local/mpich-pathscale/bin/mpirun -v -np 14 -machinefile run_nodes ~/zmm/exe/

zsp na_lid.grid_wat_d1.tsk

2. Make executable file run_nodes

seshat:2

n001:2

n002:2

n003:2

n004:2

n005:2

n006:2

3. Remove fie “out”

4. To submit the job, type: nohup run > out &

Thoth (rudiment)

- In file .bashrc, specify path to MPI system /usr/local/mpich/mpich-1.2.4/bin

- Make executable file e.g., run_zsp:

mpirun -np 4 –machinefile run_nodes ~ /zmm/exe/zsp enk.grid.tsk

- Make file run_nodes:

thoth.mcmaster.ca:2
thoth3.thoth:2

(This file requests two processors from the master and two processors from thoth3)
- Type

run_zsp&


Results of job submitted bny command zs molname

Results of the computational job submitted by the command

zs molname.jobname.tsk

are normally delivered as generalized coordinates in files

molname.jobname.stack,
molname.jobname.stack,
molname.jobname.grid,
molname.jobname.conv, etc.

These results can be analyzed with the module zv


How to make a movie using ZMM/MVM

Structures accumulated in stack-files can be visualized by MVM as a movie.

To show a movie, MVM calls "zv molname.jobname.stacktype -|f|r|". zv delivers first frame.pdb file. MVM shows the frame and deletes it. Then zv delivers the second frame.pdb file, and so on.

How to make a movie using ZMM/MVM

  1. Check that directory has the following files:

- any multiple-MECs file: .grid, .conv, .stack, or genc

- molname.pep

- molname.jobname.tsk

- molname.jobname.list (upon termination, ZMM delivers molname.jobname.list to ensure proper functioning of MVM)

  2. Execute command
    MVM molname.jobname.tsk
  3. Go to RESULTS window
  4. Select file to animate
  5. Click "visualize"
  6. Tune visualization style by one of the following ways

- Manually

- Writhing the script

- Using a hot script

- Using pre-created .mgf file: file/replace_view/.mgf

  7. Go to RESULTS window
  8. Select mode/Replace_Coordiantes
  9. Click "Animate"


Examples of PyMol commands

Cross-Section (slice) of a surface to show cavities

hide all
show surface
set ray_trace_mode, 0
set two_sided_lighting, off
set ray_interior_color, grey50

ray trace image to see final result

load d:\z\A\BZ\...\S1i29\msq_Kv12_dlmt.S_A413_3.pdb, msq

select chA, msq and chain A ! chain A

select 1i18, chA and resi 402+406+409+413 and sch ! few residues in chain A

select ASN, resn asn ! all N

select arg_lys, resn arg+lys ! all R & K

select sh1i20, (br. (msq and sch) within 7 of 1i20) and sch ! All sidechains within 7 A from 1i20


Molecular Modeling package ZMM

Molecular Modeling program ZMM

Author: Professor Boris S. Zhorov

© ZMM Software Inc., Canada

Scientific Board:

· Professor Boris S. Zhorov

· Professor Daniel S. Yang

· Dr. Denis B. Tikhonov


Homology Modeling

Synopsis: zu -hm template.pep alignment

This command returns file model.pep in which residues from file template.pep are replaced with residues in matching positions of file alignment. Insertions or deletions in the model sequence vs. the template sequence are, respectively, ignored or replaced by united-atom glycines.

File template.pep is usually generated from the X-ray or cryo-EM structure.

To get file alignment, use server Clustal Omega and copy in the input form FASTA sequences of the template and model proteins.

To get the template sequence, call "zs template.jobname .tsk" and find string FASTA in the output file template.jobname.pdb.

The alignment file format should be exactly the same as in the example ~/Test/Utilities/safe/align (Template seq. is above the model seq.)

5gjw_P      --------------------------------------------FCLTLQNPLRKACISI     16

Q13936      QAKLMGSAGNATISTVSSTQRKRQQYGKPKKQGSTTATRPPRALLCLTLKNPIRRACISI     120

                                                        :****:**:*:*****

5gjw_P      VEWKPFETIILLTIFANCVALAVYLPMPEDDNNSLNLGLEKLEYFFLTVFSIEAAMKIIA     76

Q13936      VEWKPFEIIILLTIFANCVALAIYIPFPEDDSNATNSNLERVEYLFLIIFTVEAFLKVIA     180

            ******* **************:*:*:****.*: * .**::**:** :*::** :*:**

Command "zu hm 5gjw_P.pep align" reads the template file "5gjw_P.pep" with the sequence of Cav1.1 cryo-EM structure (α and β subunits only), the alignment file in which the template sequence is aligned against the Cav1.2 sequence (UniProt Q13936) and returns file "Q13936.pep" with the Cav1.2 sequence.

The first (and the most important) stage of homology modeling is sequence alignment of the template (a protein of known 3D structure) and to-be-modeled protein of unknown 3D structure.

If the aligned sequences of template and homology model lack indels, just substitute in the .pep file amino acid codes of the template with those from the model. You may do this my using command zu -hm (see above).

If indels exist, specify “m” (mobile) residues in the model .pep file. Mobile residue roots are assigned coordinates as in the template so that their positions do not depend on the preceding residues. However, there may be problems with the mobile residue root orientation, which depend on the previous residues. This problem is resolved during MC-minimization.

After a deletion in a model, only the first residue must have the “m” status”. An example: ~ ZMM\Test\Serial\Proteins\safe\Kv21_s.pep

After an insertion in the .pep file, the first two residues must have status “m” because orientation of the first residue after the insertion is incorrect.


PLIC-3DA is a database of 3D Aligned P-Loop Ion Channels

Each PLIC-3DA entry contains the original X-ray or cryo-EM structure copied from PDB and ZMM-generated files. Content of each file is described using as an example TBA-bound KcsA at high [K+] PMID: 17196615 .

Example location: Dropbox\PLIC-3DA\PLIC\KcsA\Blocked\TBA\High_K\

File name

ZMM command and Content

2HVK.pdb

The biological-assembly file downloaded from the PDB databank. It contains coordinates of four models of the FAB antibody-bound KcsA with four superimposed TBA ligands and four superimposed sets of potassium ions (six ions in each set). Multiple solvent factors and water molecules have unique coordinates in each model.

Anybody domains have chain labels A and B. The channel protein has chain label C.

M\2HVK.fst

User-edited file. Compare with zu-generated file M\2HVK.fst_

zu -fasta 2HVK.pdb
The protein sequence.

Each sequence line is preceded by an empty line and line with original labels.

1. Copy the channel sequence line-by-line and paste in "PLIC-3DA.xlsx". For homotetrameric channels copy only the first subunit. For dimer-of-dimer channels (e.g. two-pore channels), copy only the first two subunits. For heterotetrameric channels copy the four subunits. Do NOT copy domains and domain-like large loops.

2. Align sequence in "PLIC-3DA.xlsx" with similar channels. Use PyMol or MVM to double check positions of N-end residues in the channel segments.

3. Put four-digit PLIC-3DA number above N-end residues of the channel segments, The first digit should be exactly above the residue one-letter code.

4. If the PDB sequence is interrupted within the channel, put PLIC-3DA number at the N-end after the interruption.

5. Put star (*) at the N-end of each domain.

6. You may add comments (starting from "#") and space lines AFTER any sequence line, but do NOT touch the sequence lines or lines with the PDB residue numbers.

7. Save the file.

M\2HVK.toc
User-edited file. Compare with zu-generated file M\2HVK.toc_

zu -toc 2HVK.pdb 2HVK.fst

T able Of Content in the original .pdb file

Column "Label-1" shows labels of first residues in the:
- FAB domains (A___1 and B___1)
- blocks of subunits (C__22, C__52, C__62 and C__86)
- sets of ions (C3001)
- sets of ligands or solvent factors (C_201, C_220, C4001)
- sets of water molecules (A_221, B_213, C4002).
Do NOT touch this column.

Column "Label-2" is user-edited as follows:
- Chains of the channel subunits in the four models (C) are changed to A, C, D, B to ensure their clockwise arrangement at the extracellular view of the channel.

- The FAB domain chains in the four models (A-B) are changed to E-F, M-N, P-Q, and G-H to ensure their clockwise arrangement at the extracellular view of the channel. Do not use chain labels I, L, W - they are reserved for ions and waters.

Other columns provide additional information for the user, but not for ZMM.
- "Res" shows triplets of N-end residues.
- "Source" shows PLIC for channel segments and *PDB for star-marked domains as assigned in file *.fst. Automatically generated lines show PDB source.

- "Line" shows consecutive # of the first line "ATOM" or "HETATM" in the block.
- "Atom" shows name of the first atom in the block

- "Length" shows number of atoms in non-protein blocks

M\2HVK_.pdb

zu -rr 2HVK.pdb 2HVL.toc

Residues are relabeled according to file 2HVL.toc. The user is advised to double check PLIC labels by highlighting the following residues in PyMol or MVM:

- 1550 (S1), N in many non-potassium channels
- 2550 (S2), E/D in many channels
- 3350 (S3), D in many channels

- 4550 (S4), R in many channels

- 5550 (S5), A/G/S in majority of channels

- 5850 (P), Selectivity filter residues

- 6550 (S6), Gating hinge (G in many channels)

M\2HVK_.rb.tsk

User-made task file for RIBOM. You may copy similar file from PLIC-deposited entries and edit file name and command "TAKE MEC"

M\2HVK_.rb.pdb

zs 2HVK_.rb.tsk -r
3D aligned structure with PLIC-3DA labels

M\2HVK_.rb.list

Distances between template and model atoms. If the energy and the distanced are big, double check arrangement of the channel chains. You may remove this file.

2HVK_P.pdb

P LIC-3DA entry - A copy of M/2HVK_.rb.pdb. You may remove M/2HVK_.rb.pdb

2HVK_A.pdb

zu -pc 2HVK.pdb 2HVK_P.pdb
P LIC-3DA entry - 3D-Aligned copy of 2HVK.pdb with labels from 2HVK.pdb and PLIC-3DA Coordinates from 2HVK_P.pdb

\MCM\safe\
2HVK_P.pdb

User-made copy of 2HVK_P.pdb with removed redundant TBA molecules and potassium ions. If .pdb file has atoms with alternative locations, remove duplicated B, C ...

\MCM\safe\
2HVK_P.pep,

2HVK_P.sym,

2HVK_P.bin,

zi 2HVK_P.pdb
ZMM-generated files for energy optimization.

\MCM\0\
2HVK_P.0.list

zs 2HVK_P.0.tsk
Starting energy of the ZMM model. This may be big if the original file has clashes and/or unresolved sidechains.

\MCM\1\
2HVK_P.0.list

zs 2HVK_P.0.tsk
Energy of the ZMM model after a 100-step MCM.


To re-label file 6uz3_P.pdb

- execute command zu -toc 6uz3_P.pdb

- Open file 6uz3_P.toc

- In the left column find first residue in the first segment to be relabeled.

- Use updated sequence alignment (PLIC.xlsx) to update label in the second column

- Do it for each segment to be relabeled

- Safe file 6uz3_P.toc

- Execute command zu –rr 6uz3_P.pdb 6uz3_P.toc

- Move file 6uz3_P_.pdb to new location and rename to 6uz3_P.pdb

- To re-label files 6uz3_P.0.pdb execute command zu –rr 6uz3_P.0.pdb 6uz3_P.toc

- To re-label files 6uz3_P.1.pdb execute command zu –rr 6uz3_P.1.pdb 6uz3_P.toc

To facilitate the job, make a Table like this for each channel

Channel | PDB | Label of first residues in the segment | Sift in the alignment | New Label
Nav1.5 | 6uz3 | A1526 | -3 | A1523
 |  | A4544 | -3 | A4541


Cross linking Residues A and B

Information needed:

 A1     A2      A   RES A           B   RES B         B1     B2     Distance

'3HZ ' '    ' ' NZ .LYS .A_205 '  ' C15.RET .A_302 ' '3H15' '    '  1.11

Atoms A and B will be connected.

Atoms A1 and B1 will be replaced by B and A respectively.

Any atoms attached to A1 and B1 will be removed automatically.

Atoms A2, B2 are directly attached to A and B will be removed.

Solution

.pep file:

INTER-RESIDUE LINKS

'3HZ ' '    ' ' NZ .LYS .A_205 '  ' C15.RET .A_302 ' '3H15' '    '  1.11

END INTER-RESIDUE LINKS

Post-translational editing by zp will delete atoms and fix electro-neutral group center

Fix bonding geometry if the coordination has change

Examples:

1H2S -

Lys - ret

need to look at atom type

2sgfa-

Asn - NAG, NAG-NAG

Cyclic peptide

Need to work on zi table

Once pep file is done, zp works.


What is New

1. Create a ligand file

Option A. Build ligand with MVM

1. Generate file molname.pdb
 2. type zl molname.pdb to generate molname.sym
3. type zm molname.sym to generate molname.bin
4. type zg moname.0 to generate molname.0.tsk
5. in file molname.0.tsk add KOPT 2 under PARAMERS
6. type zs molname.0.tsk

Option B. Import ligand from PUBCHEM

1. download 3D conformer as molname.sdf file.
2. Convert molname.sdf to molname.pdb with Open Babel
http://openbabel.org/wiki/Main_Page
3. Steps A3-A6

Option C. Import X-ray structure from webcsd.ccdc.cam.ac.uk
1. Ensure that you have a licence or can access the site from your institution
http://.libaccess.lib.mcmaster.ca/text_numeric_search.php
2. Search the ligand, e.g. by name or doi
3. Downlad coordinates (file .cif)
4. Convert file from .cis to .pdb format using openBabel
5. Manually remove solvent factors from pdb file
6. Steps A2-A6


What is New

To search systematically for the optimal binding site of a flexible ligand in a protein.

1. Submit a Hot grid
2. Refine Hot Grid results

Docking library of ligand conformers (Garden & Zhorov, 2010):

A. Generating a library. Examples:

\Test\Small\REA.library.tsk
~PNAS\Du_2013\Models\Ligands\DLMT\DLMT.1.tsk

B. Docking a library. Examples:

~\PNAS\Du_2013\Models\Msq\NavAb\DLMT\Site2\Ph_In\msq_dlmt.sd.tsk

START

  TAKE MEC 'msq.6.stack.pdb' 1

END START

HGRID 2

 LIBRARY 'E___1 ' 'DLMT_lib.1.stack'

 EULER   'E___1 '

END

RESIDUE SETTINGS

  FIXP

  RELP 'E___1 '

  FIXMC

  FIXR

  RELR 'E___1 '

  PART 'E___1 '

END RESIDUE SETTINGS

PARAMETER

  KEA   0

  KLEC  4

  LIMST 100

  KDGF  0

  KET   0

  KPM   1

END


File zmm/test/mvm/1afs_a

There are two methods to replace a ligand inside the protein

Method A

Create a new ligand (or modify it with MVM without a protein).

For initial placing of the new ligand, use structure with the "old" ligand as a template, apply AAT constraints between several structurally matching atoms of the new and old ligands, disable all interactions, fix everything except six variables that govern translation and rotation of the ligand, and run MCM.

Method B

Replacing a ligand using the MVM interface. As an example, the protocol below describes how to change REDOX states of cofactor and steroid in the complex of testosterone 3-alpha-hydroxysteroid dehydrogenase with NADPH and testosterone.

  1. Start MVM
  2. Open Project window, select PDB template in the bar Files of type, select folder …zmm/test/MVM and open file 1afs_a.pdb. This is a copy of PDB databank file 1afs in which chain B is removed.
  3. To visualize the structure, click Results/visualize and choose Protein_view_1 in the Hot Scripts bar.
  4. To select NADPH cofactor, double-click line “NAP A 320” in the selection window.
  5. To select all residues except NADPH, click Select/Modify selection/Invert selection.
  6. To remove all but NADPH, click Utils/Delete selected molecules.
  7. To visualize labels of atoms, click Select/all and the click Atom/Label/Atom Label.
  8. Delete hydrogen in the nicotinamide moiety: click Ligand/Delete atoms and then click the hydrogen attached to NC4 in the six-membered ring.
  9. Rename atom ‘_NN1’ to ‘_N+_’ in the nicotinamide moiety: Ligand/Change Atom Name. The underscore characters stand for the space characters in the atom names.
  10. Make standard geometry: Ligand/Standard Geometry.
  11. Label for the ligand: click Select/all, then click Util/Set Label. A window to enter the label will appear. Since the label contains 3 parts, enter the components as follows: space to Set Chain, ‘1’ to Residue number, and ‘NAP+’ to Residue name (you cannot specify correct name NADP+ since residue names are limited to four characters in the PDB standard).
  12. Save the ligand as NAP+.pdb file using menu File/Save.
  13. Go to project
  14. Add NAP+ to the project, click Add/Ligand and select NAP+.pdb in the window.
  15. Assign for NAP+ the chain and residue number that NAP has. In the sequence field, choose chain A, and in the Firs N window enter ‘320’
  16. Remove old ligand: click line “Ligand NAP A 320 and click button Remove.
  17. To ensure that the new ligand has status “elastic”, go to Project/Advanced window, find Ligand NAP+ 320 in the sequence, and click the elastic row.
  18. Click button Generate project.
  19. Go to task window, click buttons Clear and Load/Create, and create task-file 1afs_a.1
  20. Run task
  21. Visualize results: Results/visualize/replace geometry. The position of NADP+ slightly differs from that of NADPH, because the new ligand has standard bond lengths, but several steps of energy minimization will bring all toms practically to the crystallographic position seen for NADP. You may add constraint PINR ‘A320 ‘ to pin all heavy atoms of NADP+ to X-ray coordinates.
  22. Repeat steps 4-20 to change redox state of testosterone.


What is New

Rotational symmetry. ZMM can take advantage of rotational symmetry of some proteins, e.g., ion channels. This dramatically accelerates energy calculations. An example is described in Bruhova & Zhorov, 2005 (pubmed/15908577

) where essential features of the open Shaker channel structure were predicted before the x-ray structure was published.

Potassium channels have four identical domains. To save time and preserve the symmetry, you can model them with the four-fold symmetry.

- The pore axis (the axis of symmetry) should be aligned with the z axis. Take an x-ray structure of a four-subunit channel and use RIBOM to superimpose the central pore axis with the z-axis.
Example: D:\z\ZMM\Test\Serial\Proteins\safe\KcsA.z_ribom.tsk

- Take the RIMOM output (pdb file) and remove subunits B, C, and D. The resulting pdb file should have only one subunit “A”. If K+ ions are present at the pore axis, their chain label should be “E”. Use this file as a new template with a new name.

- Create a pep file containing only one subunit “A”. This subunit will be replicated around the z-axis to create subunits “B”, “C”, and “D”.

- PARAMETERS field in the.tsk file should contain:

KSF 4 # Specifies four-fold rotational symmetry
NICH ‘E’ # Excludes chain E from symmetry operations.

- Example: D:\z\ZMM\Test\Serial\Proteins\safe\KcsA_symmetry.em.tsk


Poisson-Boltzmann Calculations

- Put APBS.exe (the Adaptive Poisson-Boltzmann Solver) to c:/ . You may download it from http://sourceforge.net/projects/apbs/files/apbs/apbs-1.3.0/.

- Use PDB2PQR server http://kryptonite.nbcr.net/pdb2pqr/ to generate *.pqr file, which is an input for APBS.

Check boxes AMBER Force field
Add/Keep chain IDs

Use PROPKA

AMBER naming scheme

Remove REMARK lines generated by ZMM

- PyMol

File/Open *.pqr

APBS Tools

Main/Use another pqr d:\your_directory\filename.pqr
APBS binary location c:\APBS.exe

Temporary file Locations

d:\your_directory\pymol-generated.pqr

d:\your_directory\pymol-generated.pdb

d:\your_directory\pymol-generated.dx

d:\your_directory\pymol-generated.in

Click “Set Grid”

Click “Run APBS” and wait until the button returns back

Click “Visualization” and set up parameters.
Option “solvent-accessible surface” gives most general view.

Use “bg_color white” command to produce publishable figures.

- Tutorial: http://www.poissonboltzmann.org/apbs/examples/visualization/apbs-electrostatics-in-pymol


# This .tsk file submits 2,000 short MCM trajectories
# in which verapamil is sampled in the central pore of Cav1.2

START
  TAKE MEC 'Cav12_VPM.mcm.pdb'   ! Take MC-minimized structure as a start
END

HGRID 2000             ! Run a Hot Grid of 2,000 MCM trajectories
  RESIDUE ' _100 '     ! Sample position, orientation and conformation of reside ' _100 '
END

RESIDUE SETTINGS
  FIXMC                ! Fix mainchain to prevent large deformations of the channel
  SCENT ' _100 '       ! At each second try, sample a variable around the ligand
END RESIDUE SETTINGS

PARAMETER
  MP_M  1             ! Grid-level of parallelization (a processor runs entire MCM)
  KOPT  2             ! MCM
  LIMIT 200           ! Energy minimizations are limited to 200 iterations
  LIMIN 20            ! MCM trajectories are limited to 20 minimizations
  DELEQ 500.          ! The stack file accumulates MECs within 500 kcal/mol from the best one
  HGLTD 3.            ! Sampled translation are within 3 A from the start
  KHIST 0             ! Prevent delivey of a huge .hist file
  KDGF  0             ! Prevent delivering of a huge grid file
  MSEA  0             ! Turn Ligand around the root atom (N+ of verapamil)
END

CONSTRAINTS
# pin S5 and S6 to KvAP geometry
  TEMPL KvAP_pore
  PINA ' 1101 ' ' 1129 ' 1.00 100.
  PINA ' 2101 ' ' 2129 ' 1.00 100.
  PINA ' 3101 ' ' 3129 ' 1.00 100.
  PINA ' 4101 ' ' 4129 ' 1.00 100.
  PINA ' 1301 ' ' 1330 ' 1.00 100.
  PINA ' 2301 ' ' 2330 ' 1.00 100.
  PINA ' 3301 ' ' 3330 ' 1.00 100.
  PINA ' 4301 ' ' 4330 ' 1.00 100.
# pin P-helices to KvAP-adjusted Nav14 outerpore model
  TEMPL Nav14_KvAP-2_force100
  PINA ' 1236 ' ' 1246 ' 0.01 100.
  PINA ' 2236 ' ' 2246 ' 0.01 100.
  PINA ' 3236 ' ' 3246 ' 0.01 100.
  PINA ' 4236 ' ' 4246 ' 0.01 100.
# pin ascending limbs to KvAP-adjusted Nav14 outerpore model
  PINA ' 1247 ' ' 1254 ' 1.00 100.
  PINA ' 2247 ' ' 2254 ' 1.00 100.
  PINA ' 3247 ' ' 3254 ' 1.00 100.
  PINA ' 4247 ' ' 4254 ' 1.00 100.
END CONSTRAINT

END TUNE


# This is an example of .tsk file used for refinement of Hot grid results

START
  TAKE STACK 'Cav12_VPM_TY.hot_grid.stack'   ! Import stack with hot grid resuts
END START

RESIDUE SETTINGS
  SCENT ' _100 '
END RESIDUE SETTINGS

PARAMETER
  MP_M  2                ! GREN-level of parallelization (energy calculation is parallelized)
  KOPT  2                ! MCM
  LIMIT 200              ! Limit energy minimization to 100 steps
  LIMIN 1000             ! Limit MCM trajectory to 1000 steps
  LIMNE 200              ! Stop MCM if the last 200 steps did not improve the best minimum
  DELEQ 100.             ! Accumulate MECs that differ no more than 100 kcal/mol
  KHIST 0                ! To prevent large output
  MSEA  0                ! Rotate teh ligand around its root atom
END

CONSTRAINTS
# pin S5 and S6 to KvAP geometry
  TEMPL KvAP_pore
  PINA ' 1101 ' ' 1129 ' 1.00 100.
  PINA ' 2101 ' ' 2129 ' 1.00 100.
  PINA ' 3101 ' ' 3129 ' 1.00 100.
  PINA ' 4101 ' ' 4129 ' 1.00 100.
  PINA ' 1301 ' ' 1330 ' 1.00 100.
  PINA ' 2301 ' ' 2330 ' 1.00 100.
  PINA ' 3301 ' ' 3330 ' 1.00 100.
  PINA ' 4301 ' ' 4330 ' 1.00 100.
# pin P-helices to KvAP-adjusted Nav14 outerpore model
  TEMPL Nav14_KvAP-2_force100
  PINA ' 1236 ' ' 1246 ' 0.01 100.
  PINA ' 2236 ' ' 2246 ' 0.01 100.
  PINA ' 3236 ' ' 3246 ' 0.01 100.
  PINA ' 4236 ' ' 4246 ' 0.01 100.
# pin ascending limbs to KvAP-adjusted Nav14 outerpore model
  PINA ' 1247 ' ' 1254 ' 1.00 100.
  PINA ' 2247 ' ' 2254 ' 1.00 100.
  PINA ' 3247 ' ' 3254 ' 1.00 100.
  PINA ' 4247 ' ' 4254 ' 1.00 100.
END CONSTRAINT

END TUNE


Cysteine and Sulfhydryl-Specific Reagents

Cysteine modified by methylthiosulfonate (MTS) reagents

MTS-Reagents (Karlin, A., and Akabas, M.H. 1998. Substituted-Cysteine Accessibility Method. Methods in Enzymology. 293:123-145).

MTSEA, X = NH3+
MTSET, X = (CH3)3N+
MTSES, X = SO3-
MTSEH, X = OH

Non-standard Amino Acids:

CEA, Cysteine modified by MTSEA

CET, Cysteine modified by MTSET

CES, Cysteine modified by MTSEA

CEH, Cysteine modified by MTSEH

Records for file amacir_a.dat describing the above non-standard amino acids have been created by Rony Kozman (July 12, 2005)